mac80211: headers: fix lockdep_assert_not_held()
authorPetr Štetiar <ynezz@true.cz>
Fri, 11 Mar 2022 19:56:02 +0000 (20:56 +0100)
committerPetr Štetiar <ynezz@true.cz>
Tue, 15 Mar 2022 07:33:45 +0000 (08:33 +0100)
LOCK_STATE_HELD define was omitted during backport of
lockdep_assert_not_held() which leads to build failures of kernels with
CONFIG_LOCKDEP=y:

 backports-5.15.8-1/backport-include/linux/lockdep.h:16:47: error: 'LOCK_STATE_HELD' undeclared (first use in this function)

Fix it by adding missing LOCK_STATE_HELD define.

References: PR#9373
Reported-by: Oskari Rauta <oskari.rauta@gmail.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/kernel/mac80211/Makefile
package/kernel/mac80211/patches/build/070-headers-fix-lockdep_assert_not_held.patch [new file with mode: 0644]

index 2f9fd11f10c8b8a8c7fb25e99deb42093e5a6917..715e851a13ef2f9635e68f68331a0119f2e09c3c 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=5.15.8-1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.15.8/
 PKG_HASH:=9f71b659c034f19d156532ec780fcb606cee3c4ccc42e2f8ef18dd3e9f1b6820
 
diff --git a/package/kernel/mac80211/patches/build/070-headers-fix-lockdep_assert_not_held.patch b/package/kernel/mac80211/patches/build/070-headers-fix-lockdep_assert_not_held.patch
new file mode 100644 (file)
index 0000000..d946efa
--- /dev/null
@@ -0,0 +1,39 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
+Date: Fri, 11 Mar 2022 18:21:04 +0100
+Subject: [PATCH] headers: fix lockdep_assert_not_held()
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+LOCK_STATE_HELD define was omitted during backport of
+lockdep_assert_not_held() which leads to build failures of kernels with
+CONFIG_LOCKDEP=y:
+
+ backports-5.15.8-1/backport-include/linux/lockdep.h:16:47: error: 'LOCK_STATE_HELD' undeclared (first use in this function)
+
+Fix it by adding missing LOCK_STATE_HELD define.
+
+References: https://github.com/openwrt/openwrt/pull/9373
+References: https://lore.kernel.org/backports/20220311194800.452-1-ynezz@true.cz/T/#u
+Fixes: af58b27b1b1a ("headers: Add lockdep_assert_not_held()")
+Reported-by: Oskari Rauta <oskari.rauta@gmail.com>
+Signed-off-by: Petr Štetiar <ynezz@true.cz>
+---
+ backport-include/linux/lockdep.h | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/backport-include/linux/lockdep.h b/backport-include/linux/lockdep.h
+index ed5ea67894e4..842e24b7ff8f 100644
+--- a/backport-include/linux/lockdep.h
++++ b/backport-include/linux/lockdep.h
+@@ -11,6 +11,9 @@ struct lockdep_map { };
+ #ifndef lockdep_assert_not_held
+ #ifdef CONFIG_LOCKDEP
++#ifndef LOCK_STATE_HELD
++#define LOCK_STATE_HELD               1
++#endif /* LOCK_STATE_HELD */
+ #define lockdep_assert_not_held(l)    do {                            \
+               WARN_ON(debug_locks &&                                  \
+                       lockdep_is_held(l) == LOCK_STATE_HELD);         \