ar71xx: switch TP-Link RE450 v1 to dynamic partitioning
authorRadek Dostál <rd@radekdostal.com>
Mon, 22 Oct 2018 20:34:17 +0000 (22:34 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 29 Oct 2018 10:21:23 +0000 (11:21 +0100)
As mentioned in commit 5f24933 recent changes on ar71xx (switch to 4.14,
memory compaction, ...) cause an increase in kernel size, making it too
big for RE450.

RE450 images were not build due to the following error message:
os-image partition too big (more than 1572864 bytes): Success

Tested on RE450, device boots and was used to send this patch.

Reported-by: Enrico Mioso <mrkiko.rs@gmail.com>
Suggested-by: David Bauer <mail@david-bauer.net>
Signed-off-by: Radek Dostál <rd@radekdostal.com>
[rewrote commit msg keeping it tight + fixed SoB lines]
Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
target/linux/ar71xx/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index 39d3ab08fe25aad006ca0fad8ee06be7de7ed711..5036e85a019689366a17743da60ffc09040edce9 100644 (file)
@@ -254,6 +254,8 @@ define Device/re450-v1
   DEVICE_PROFILE := RE450
   TPLINK_HWID := 0x0
   TPLINK_HWREV := 0
+  KERNEL := kernel-bin | patch-cmdline | lzma | tplink-v1-header -O
+  KERNEL_INITRAMFS := kernel-bin | patch-cmdline | lzma | tplink-v1-header
 endef
 TARGET_DEVICES += re450-v1
 
index 78092bc535c629f3f64be4223b13495759dde75d..7f8a5d22ad6975d4f0c68f23ba3c556df3a7f0d8 100644 (file)
@@ -1103,15 +1103,10 @@ static struct device_info boards[] = {
                .support_trail = '\x00',
                .soft_ver = NULL,
 
-               /**
-                  The flash partition table for RE450;
-                  it is almost the same as the one used by the stock images,
-                  576KB were moved from file-system to os-image.
-               */
+               /** We're using a dynamic kernel/rootfs split here */
                .partitions = {
                        {"fs-uboot", 0x00000, 0x20000},
-                       {"os-image", 0x20000, 0x180000},
-                       {"file-system", 0x1a0000, 0x460000},
+                       {"firmware", 0x20000, 0x5e0000},
                        {"partition-table", 0x600000, 0x02000},
                        {"default-mac", 0x610000, 0x00020},
                        {"pin", 0x610100, 0x00020},