ath79: add support for TP-Link EAP245-v3
authorSander Vanheule <sander@svanheule.net>
Thu, 4 Jun 2020 18:59:13 +0000 (20:59 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Wed, 9 Sep 2020 17:42:10 +0000 (20:42 +0300)
TP-Link EAP245 v3 is an AC1750 (802.11ac Wave-2) ceiling mount access
point. UART access (for debricking) requires non-trivial soldering.

Specifications:
* SoC: QCA9563 (CPU/DDR/AHB @ 775/650/258 MHz)
* RAM: 128MiB
* Flash: 16MiB SPI-NOR
* Wireless 2.4GHz (SoC): b/g/n 3x3
* Wireless 5GHz (QCA9982): a/n/ac 3x3 with MU-MIMO
* Ethernet (QCA8337N switch): 2× 1GbE, ETH1 (802.3at PoE) and ETH2
* Green and amber status LEDs
* Reset switch (GPIO, available for failsafe)

Flashing instructions:
All recent firmware versions (latest is 2.20.0), can disable firmware
signature verification and use a padded firmware file to flash OpenWrt:
* ssh into target device and run `cliclientd stopcs`
* upload factory image via web interface

The stopcs-method is supported from firmware version 2.3.0. Earlier
versions need to be upgraded to a newer stock version before flashing
OpenWrt.

Factory images for these devices are RSA signed by TP-Link. While the
signature verification can be disabled, the factory image still needs to
have a (fake) 1024 bit signature added to pass file checks.

Debricking instructions:
You can recover using u-boot via the serial port:
* Serial port is available from J3 (1:TX, 2:RX, 3:GND, 4:3.3V)
* Bridge R237 to connect RX, located next to J3
* Bridge R225 to connect TX, located inside can on back-side of board
* Serial port is 115200 baud, 8n1, interrupt u-boot by holding ctrl+B
* Upload initramfs with tftp and upgrade via OpenWrt

Device mac addresses:
Stock firmware has the same mac address for 2.4GHz wireless and
ethernet, 5GHz is incremented by one. The base mac address is stored in
the 'default-mac' partition (offset 0x90000) at an offset of 8 bytes.
ART blobs contain no mac addresses.
From OEM ifconfig:
    ath0      Link encap:Ethernet  HWaddr 74:..:E2
    ath10     Link encap:Ethernet  HWaddr 74:..:E3
    br0       Link encap:Ethernet  HWaddr 74:..:E2
    eth0      Link encap:Ethernet  HWaddr 74:..:E2

Signed-off-by: Sander Vanheule <sander@svanheule.net>
Tested-by: Stijn Tintel <stijn@linux-ipv6.be>
target/linux/ath79/dts/qca9563_tplink_eap245-v3.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

diff --git a/target/linux/ath79/dts/qca9563_tplink_eap245-v3.dts b/target/linux/ath79/dts/qca9563_tplink_eap245-v3.dts
new file mode 100644 (file)
index 0000000..f9e3f0a
--- /dev/null
@@ -0,0 +1,163 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+       compatible = "tplink,eap245-v3", "qca,qca9563";
+       model = "TP-Link EAP245 v3";
+
+       aliases {
+               led-boot = &led_status_green;
+               led-failsafe = &led_status_amber;
+               led-running = &led_status_green;
+               led-upgrade = &led_status_amber;
+               label-mac-device = &eth0;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status_green: status_green {
+                       label = "tp-link:green:status";
+                       gpios = <&gpio 7 GPIO_ACTIVE_HIGH>;
+                       default-state = "on";
+               };
+
+               led_status_amber: status_amber {
+                       label = "tp-link:amber:status";
+                       gpios = <&gpio 9 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&uart {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "factory-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot";
+                               reg = <0x040000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@80000 {
+                               label = "partition-table";
+                               reg = <0x080000 0x010000>;
+                               read-only;
+                       };
+
+                       info: partition@90000 {
+                               label = "info";
+                               reg = <0x090000 0x010000>;
+                               read-only;
+                       };
+
+                       art: partition@a0000 {
+                               label = "art";
+                               reg = <0x0a0000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@b0000 {
+                               label = "extra-para";
+                               reg = <0x0b0000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@c0000 {
+                               compatible = "openwrt,elf";
+                               label = "firmware";
+                               reg = <0x0c0000 0xe40000>;
+                       };
+
+                       partition@f00000 {
+                               label = "config";
+                               reg = <0xf00000 0x030000>;
+                               read-only;
+                       };
+
+                       partition@f30000 {
+                               label = "mutil-log";
+                               reg = <0xf30000 0x080000>;
+                               read-only;
+                       };
+
+                       partition@fb0000 {
+                               label = "oops";
+                               reg = <0xfb0000 0x040000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <0x1>;
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+               phy-mode = "sgmii";
+               qca,ar8327-initvals = <
+                       0x04 0x00080080 /* PAD0 */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+                       0xe0 0xc74164de /* SGMII_CTRL */
+                       >;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&phy0>;
+       phy-mode = "sgmii";
+
+       mtd-mac-address = <&info 0x8>;
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&info 0x8>;
+};
index 34dd975e19365e54fb71fc05bcdc83fd8650bbc8..2923ffabeb11c0f104ac3f77d7d79edb7cccb245 100755 (executable)
@@ -301,6 +301,10 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth1" "3:lan:3" "4:lan:2" "5:lan:1" "6@eth0" "2:wan:4" "1:wan:5"
                ;;
+       tplink,eap245-v3)
+               ucidef_add_switch "switch0" \
+                       "0@eth0" "2:lan:1" "5:lan:2"
+               ;;
        tplink,tl-mr6400-v1)
                ucidef_set_interfaces_lan_wan "eth0.1 eth1" "usb0"
                ucidef_add_switch "switch0" \
index 66777cb9f568d03854bab74b524e95e1c61483c3..1bfb8c2c6119adc95995a953312f3e5f749c93fc 100644 (file)
@@ -206,6 +206,10 @@ case "$FIRMWARE" in
                ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
                        /lib/firmware/ath10k/QCA9888/hw2.0/board.bin
                ;;
+       tplink,eap245-v3)
+               caldata_extract "art" 0x5000 0x2f20
+               ath10k_patch_mac $(macaddr_add $(mtd_get_mac_binary info 0x8) +1)
+               ;;
        yuncore,a782|\
        yuncore,xd4200)
                caldata_extract "art" 0x5000 0x2f20
index 7128d853f8731a919d0023fdedaf4ad4c462c4a0..daf793671f0030e5565a209cc4e43c5a1c59a045 100644 (file)
@@ -362,6 +362,26 @@ define Device/tplink_cpe610-v2
 endef
 TARGET_DEVICES += tplink_cpe610-v2
 
+define Device/tplink-eap2x5
+  $(Device/tplink-safeloader)
+  SOC := qca9563
+  LOADER_TYPE := elf
+  KERNEL := kernel-bin | append-dtb | lzma | loader-kernel
+  KERNEL_INITRAMFS := $$(KERNEL)
+  IMAGE/factory.bin := append-rootfs | tplink-safeloader factory | \
+       pad-extra 128
+endef
+
+define Device/tplink_eap245-v3
+  $(Device/tplink-eap2x5)
+  IMAGE_SIZE := 14592k
+  DEVICE_MODEL := EAP245
+  DEVICE_VARIANT := v3
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca99x0-ct
+  TPLINK_BOARD_ID := EAP245-V3
+endef
+TARGET_DEVICES += tplink_eap245-v3
+
 define Device/tplink_re350k-v1
   $(Device/tplink-safeloader)
   SOC := qca9558
index 9005ffa4874504d32e8cb4decded1daf46bca04f..dca68fa8a8953785244f402502782b0788b9c9fc 100644 (file)
@@ -1298,6 +1298,38 @@ static struct device_info boards[] = {
                .last_sysupgrade_partition = "file-system"
        },
 
+       /** Firmware layout for the EAP245 v3 */
+       {
+               .id     = "EAP245-V3",
+               .support_list =
+                       "SupportList:\r\n"
+                       "EAP245(TP-Link|UN|AC1750-D):3.0\r\n",
+               .support_trail = '\xff',
+               .soft_ver = NULL,
+               .soft_ver_compat_level = 1,
+
+               /** Firmware partition with dynamic kernel/rootfs split */
+               .partitions = {
+                       {"factroy-boot", 0x00000, 0x40000},
+                       {"fs-uboot", 0x40000, 0x40000},
+                       {"partition-table", 0x80000, 0x10000},
+                       {"default-mac", 0x90000, 0x01000},
+                       {"support-list", 0x91000, 0x00100},
+                       {"product-info", 0x91100, 0x00400},
+                       {"soft-version", 0x92000, 0x00100},
+                       {"radio", 0xa0000, 0x10000},
+                       {"extra-para", 0xb0000, 0x10000},
+                       {"firmware", 0xc0000, 0xe40000},
+                       {"config", 0xf00000, 0x30000},
+                       {"mutil-log", 0xf30000, 0x80000},
+                       {"oops", 0xfb0000, 0x40000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "file-system"
+       },
+
        /** Firmware layout for the TL-WA850RE v2 */
        {
                .id     = "TLWA850REV2",
@@ -2513,6 +2545,9 @@ static void build_image(const char *output,
        } else if (strcasecmp(info->id, "ARCHER-C6-V2-US") == 0) {
                const char mdat[11] = {0x00, 0x00, 0x00, 0x02, 0x00, 0x00, 0x00, 0x00, 0x01, 0x01, 0x00};
                parts[5] = put_data("extra-para", mdat, 11);
+       } else if (strcasecmp(info->id, "EAP245-V3") == 0) {
+               const char mdat[10] = {0x00, 0x00, 0x00, 0x02, 0x00, 0x00, 0x00, 0x00, 0x01, 0x01};
+               parts[5] = put_data("extra-para", mdat, 10);
        }
 
        size_t len;