trace-cmd: update to v3.1.2
authorNick Hainke <vincent@systemli.org>
Sat, 2 Jul 2022 19:50:36 +0000 (21:50 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 Aug 2022 17:58:46 +0000 (19:58 +0200)
Remove outdated patches:
- 100-musl.patch
- 110-mac80211_tracepoint.patch

Trace-cmd now uses libtracefs and livtraceevent as libraries.
The plugins moved to libtraceevent.

Signed-off-by: Nick Hainke <vincent@systemli.org>
package/devel/trace-cmd/Makefile
package/devel/trace-cmd/patches/100-musl.patch [deleted file]
package/devel/trace-cmd/patches/110-mac80211_tracepoint.patch [deleted file]

index e15b04ad23a7b8268b672ffb8d0a79e68e525d7c..c9b0dc980b5a828de596e9697b9770f805fc72d0 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=trace-cmd
-PKG_VERSION:=v2.9.1
+PKG_VERSION:=v3.1.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git/snapshot/
-PKG_HASH:=9404fc3cf540ea795304608068c9db6cdb38b90584c7f3c43249785913d54b38
+PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/snapshot/
+PKG_HASH:=206672af60aa0bc35cfc44a4be746efa575bac729060e54b6453f7d5dfbcd979
 
 PKG_LICENSE:=GPL-2.0-only
 PKG_LICENSE_FILES:=COPYING
@@ -21,14 +21,14 @@ define Package/trace-cmd
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=Linux trace command line utility
-  DEPENDS:=
+  DEPENDS:=+libtracefs +zlib
 endef
 
 define Package/trace-cmd-extra
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=Extra plugins for trace-cmd
-  DEPENDS:=
+  DEPENDS:=+libtraceevent-extra
 endef
 
 MAKE_FLAGS += \
@@ -36,27 +36,11 @@ MAKE_FLAGS += \
        NO_AUDIT=1 \
        prefix=/usr
 
-PLUGINS_DIR := $(PKG_INSTALL_DIR)/usr/lib/traceevent/plugins
-PLUGINS_MAIN := function hrtimer mac80211 sched_switch
-
 TARGET_CFLAGS += --std=gnu99 -D_GNU_SOURCE
 
 define Package/trace-cmd/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/traceevent/plugins
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/trace-cmd $(1)/usr/bin/
-       $(CP) \
-               $(patsubst %,$(PLUGINS_DIR)/plugin_%.so,$(PLUGINS_MAIN)) \
-               $(1)/usr/lib/traceevent/plugins
-endef
-
-define Package/trace-cmd-extra/install
-       $(INSTALL_DIR) $(1)/usr/lib/traceevent/plugins
-       $(CP) \
-               $$(patsubst %,$(PLUGINS_DIR)/plugin_%.so, \
-                       $$(filter-out $(PLUGINS_MAIN), \
-                               $$(patsubst $(PLUGINS_DIR)/plugin_%.so,%, \
-                                       $$(wildcard $(PLUGINS_DIR)/plugin_*.so)))) \
-               $(1)/usr/lib/traceevent/plugins
 endef
 
 $(eval $(call BuildPackage,trace-cmd))
diff --git a/package/devel/trace-cmd/patches/100-musl.patch b/package/devel/trace-cmd/patches/100-musl.patch
deleted file mode 100644 (file)
index 80b419e..0000000
+++ /dev/null
@@ -1,104 +0,0 @@
-From 1a000636c1828eecdcec5360a51623ef4ffbff04 Mon Sep 17 00:00:00 2001
-From: Beniamin Sandu <beniaminsandu@gmail.com>
-Date: Mon, 30 Nov 2020 14:27:55 +0200
-Subject: trace-cmd: make it build against musl C library
-
-* add some missing headers and macros
-* set pthread affinity using pthread_setaffinity_np after creating the thread
-instead of pthread_attr_setaffinity_np (which seems to not be implemented
-in musl)
-
-Tested using https://musl.cc/x86_64-linux-musl-native.tgz
-
-Link: https://lore.kernel.org/linux-trace-devel/20201130122755.31000-1-beniaminsandu@gmail.com
-
-Reviewed-by: Tzvetomir Stoyanov (VMware) <tz.stoyanov@gmail.com>
-Signed-off-by: Beniamin Sandu <beniaminsandu@gmail.com>
-[ Fixed a whitespace issue ]
-Signed-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
----
- include/trace-cmd/trace-cmd.h                     |  1 +
- lib/trace-cmd/include/trace-cmd-local.h           |  1 +
- lib/tracefs/tracefs-events.c                      |  1 +
- tracecmd/include/trace-local.h                    |  1 +
- tracecmd/trace-tsync.c                            | 16 +++++++++++-----
- 5 files changed, 20 insertions(+), 5 deletions(-)
-
---- a/include/trace-cmd/trace-cmd.h
-+++ b/include/trace-cmd/trace-cmd.h
-@@ -6,6 +6,7 @@
- #ifndef _TRACE_CMD_H
- #define _TRACE_CMD_H
-+#include <pthread.h>
- #include "traceevent/event-parse.h"
- #define TRACECMD_MAGIC { 23, 8, 68 }
---- a/lib/trace-cmd/include/trace-cmd-local.h
-+++ b/lib/trace-cmd/include/trace-cmd-local.h
-@@ -26,5 +26,6 @@ void warning(const char *fmt, ...);
- #endif
- #endif
-+#include <byteswap.h>
- #endif /* _TRACE_CMD_LOCAL_H */
---- a/lib/tracefs/tracefs-events.c
-+++ b/lib/tracefs/tracefs-events.c
-@@ -13,6 +13,7 @@
- #include <errno.h>
- #include <sys/stat.h>
- #include <fcntl.h>
-+#include <limits.h>
- #include "kbuffer.h"
- #include "tracefs.h"
---- a/tracecmd/include/trace-local.h
-+++ b/tracecmd/include/trace-local.h
-@@ -8,6 +8,7 @@
- #include <sys/types.h>
- #include <dirent.h>   /* for DIR */
-+#include <limits.h>
- #include "trace-cmd.h"
- #include "event-utils.h"
---- a/tracecmd/trace-tsync.c
-+++ b/tracecmd/trace-tsync.c
-@@ -104,13 +104,16 @@ int tracecmd_host_tsync(struct buffer_in
-       pthread_attr_init(&attrib);
-       pthread_attr_setdetachstate(&attrib, PTHREAD_CREATE_JOINABLE);
--      if (!get_first_cpu(&pin_mask, &mask_size))
--              pthread_attr_setaffinity_np(&attrib, mask_size, pin_mask);
-       ret = pthread_create(&instance->tsync_thread, &attrib,
-                            tsync_host_thread, &instance->tsync);
--      if (!ret)
-+
-+      if (!ret) {
-+              if (!get_first_cpu(&pin_mask, &mask_size))
-+                      pthread_setaffinity_np(instance->tsync_thread, mask_size, pin_mask);
-               instance->tsync_thread_running = true;
-+      }
-+
-       if (pin_mask)
-               CPU_FREE(pin_mask);
-       pthread_attr_destroy(&attrib);
-@@ -243,11 +246,14 @@ unsigned int tracecmd_guest_tsync(char *
-       pthread_attr_init(&attrib);
-       tsync->sync_proto = proto;
-       pthread_attr_setdetachstate(&attrib, PTHREAD_CREATE_JOINABLE);
--      if (!get_first_cpu(&pin_mask, &mask_size))
--              pthread_attr_setaffinity_np(&attrib, mask_size, pin_mask);
-       ret = pthread_create(thr_id, &attrib, tsync_agent_thread, tsync);
-+      if (!ret) {
-+              if (!get_first_cpu(&pin_mask, &mask_size))
-+                      pthread_setaffinity_np(*thr_id, mask_size, pin_mask);
-+      }
-+
-       if (pin_mask)
-               CPU_FREE(pin_mask);
-       pthread_attr_destroy(&attrib);
diff --git a/package/devel/trace-cmd/patches/110-mac80211_tracepoint.patch b/package/devel/trace-cmd/patches/110-mac80211_tracepoint.patch
deleted file mode 100644 (file)
index cffcaa0..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/lib/traceevent/plugins/plugin_mac80211.c
-+++ b/lib/traceevent/plugins/plugin_mac80211.c
-@@ -165,12 +165,15 @@ static int drv_config(struct trace_seq *
-               { 2, "IDLE" },
-               { 3, "QOS"},
-       );
--      tep_print_num_field(s, " chan:%d/", event, "center_freq", record, 1);
--      print_enum(s, event, "channel_type", data,
--              { 0, "noht" },
--              { 1, "ht20" },
--              { 2, "ht40-" },
--              { 3, "ht40+" });
-+      tep_print_num_field(s, " chan:%d@", event, "control_freq", record, 1);
-+      print_enum(s, event, "chan_width", data,
-+              { 0, "20_noht" },
-+              { 1, "20" },
-+              { 2, "40" },
-+              { 3, "80" },
-+              { 4, "80p80" },
-+              { 5, "160" });
-+
-       trace_seq_putc(s, ' ');
-       SF("power_level");