uclibc++: make verbosity affect uClibc++ build
authorWren Turkal <wt@penguintechs.org>
Mon, 25 May 2020 21:05:51 +0000 (14:05 -0700)
committerPetr Štetiar <ynezz@true.cz>
Wed, 8 Jul 2020 14:07:05 +0000 (16:07 +0200)
Before this change, setting the verbosity to anything with V=blah would
cause uclibc++ build to print errors to the screen. Now, it the
clibc++ build verbosity will be altered in the following manners:
* V=s will set V=1 in the uclibc++ build
* V=sc will set V=2 in the uclibc++ build

Signed-off-by: Wren Turkal <wt@penguintechs.org>
package/libs/uclibc++/Makefile

index 7a0d9094ffac35d15d7d400f97eb352040266733..0e3210a5b9aaec49b5c2bafdc0ad878ecdbfa63b 100644 (file)
@@ -55,6 +55,14 @@ ifeq ($(CONFIG_USE_MUSL),y)
 SSP_LIB=-lssp_nonshared
 endif
 
+ifeq (${V}, s)
+MAKE_VARS+= \
+       V=1
+else ifeq (${V}, sc)
+MAKE_VARS+= \
+       V=2
+endif
+
 MAKE_FLAGS:= \
        $(TARGET_CONFIGURE_OPTS) \
        CPU_CFLAGS="$(TARGET_CFLAGS)" \