readline: disable shared library for host
authorRosen Penev <rosenp@gmail.com>
Tue, 19 Oct 2021 07:52:03 +0000 (00:52 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 20 Nov 2021 20:08:24 +0000 (21:08 +0100)
Allows to avoid rpath hacks with at least softethervpn.

--with-pic is needed as it's not default with static libraries, only
shared ones.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/libs/readline/Makefile

index d41a6d74f4da63bbfea81d312ddf0667f42177a3..d14f058eabae02f1cc02603618f076bf27a851f1 100644 (file)
@@ -45,6 +45,7 @@ define Package/libreadline/description
        history expansion on previous commands.
 endef
 
+HOST_CONFIGURE_ARGS += --disable-shared --with-pic
 CONFIGURE_ARGS += --with-curses --disable-install-examples
 
 CONFIGURE_VARS += \