toolchain: glibc: Increase min kernel version to 5.10
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 Aug 2022 23:09:42 +0000 (01:09 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 15 Aug 2022 17:30:11 +0000 (19:30 +0200)
This removes all compatibility code normally compiled into glibc for
kernel < 5.10 from our build. The build glibc version will only work
with Linux kernel >= 5.10.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
toolchain/glibc/common.mk

index 5acb13b5dc127eaa58287ed83497e17016852791..107245472aac10945b3750b0314ce57aa3b1ab3a 100644 (file)
@@ -64,7 +64,7 @@ GLIBC_CONFIGURE:= \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),--enable-stack-protector=yes) \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_STRONG),--enable-stack-protector=strong) \
                  $(if $(CONFIG_PKG_RELRO_FULL),--enable-bind-now) \
-               --enable-kernel=5.4.0
+               --enable-kernel=5.10.0
 
 export libc_cv_ssp=no
 export libc_cv_ssp_strong=no