kernel: bump 5.4 to 5.4.145
authorJohn Audia <graysky@archlinux.us>
Mon, 13 Sep 2021 12:26:19 +0000 (08:26 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 13 Sep 2021 15:08:17 +0000 (17:08 +0200)
Removed upstreamed:
  generic-backport/040-ARM-8918-2-only-build-return_address-if-needed.patch

All other patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/apm821xx/patches-5.4/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/bcm27xx/patches-5.4/950-0264-xhci-add-quirk-for-host-controllers-that-don-t-updat.patch
target/linux/bcm27xx/patches-5.4/950-0293-xhci-Use-more-event-ring-segment-table-entries.patch
target/linux/bcm27xx/patches-5.4/950-0993-xhci-quirks-add-link-TRB-quirk-for-VL805.patch
target/linux/bcm53xx/patches-5.4/180-usb-xhci-add-support-for-performing-fake-doorbell.patch
target/linux/generic/backport-5.4/040-ARM-8918-2-only-build-return_address-if-needed.patch [deleted file]
target/linux/generic/backport-5.4/782-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
target/linux/layerscape/patches-5.4/820-usb-0015-MLK-17380-4-usb-host-xhci-add-EH-SINGLE_STEP_SET_FEA.patch
target/linux/layerscape/patches-5.4/820-usb-0016-MLK-16735-usb-host-add-XHCI_CDNS_HOST-flag.patch
target/linux/layerscape/patches-5.4/820-usb-0018-MLK-18794-1-usb-host-xhci-add-.bus_suspend-override.patch

index 10ceedffa55733edb923803ad84e7855b6460f48..00f7c90313b303dedd05c7b9df3512b7addab4f0 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .144
+LINUX_VERSION-5.4 = .145
 LINUX_VERSION-5.10 = .64
 
-LINUX_KERNEL_HASH-5.4.144 = bc43b98271ab3885a41c2413bed26b5a6d38795731b9c194f6e72dde45b85885
+LINUX_KERNEL_HASH-5.4.145 = 5cf7782ec2e91417edf0d5e6555da6d556962c8985e33ba9e7dadba5cbdc68f9
 LINUX_KERNEL_HASH-5.10.64 = 3eb84bd24a2de2b4749314e34597c02401c5d6831b055ed5224adb405c35e30a
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 3c33253ec4245fbf7172c7de0f88b0129c73ab7c..4217a1e9492c135fc441b9c11ad4c2a42625dd85 100644 (file)
@@ -43,7 +43,7 @@ produce a noisy warning.
                hcd->msi_enabled = 1;
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1884,6 +1884,7 @@ struct xhci_hcd {
+@@ -1887,6 +1887,7 @@ struct xhci_hcd {
        struct xhci_hub         usb2_rhub;
        struct xhci_hub         usb3_rhub;
        /* support xHCI 1.0 spec USB2 hardware LPM */
index 0c3f290ea211e09622cfb2ec91f5ac07452a2a4e..947b00b398e45cdbe473d52bbd34949d400dcfc3 100644 (file)
@@ -80,7 +80,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
        /*
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1874,6 +1874,7 @@ struct xhci_hcd {
+@@ -1877,6 +1877,7 @@ struct xhci_hcd {
  #define XHCI_DEFAULT_PM_RUNTIME_ALLOW BIT_ULL(33)
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
index 1758e4976138cdad70c72861558be5ef4e333320..edddd313a8cee14c3f73f3b12874db1280316cc0 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
                        val);
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1650,8 +1650,8 @@ struct urb_priv {
+@@ -1653,8 +1653,8 @@ struct urb_priv {
   * Each segment table entry is 4*32bits long.  1K seems like an ok size:
   * (1K bytes * 8bytes/bit) / (4*32 bits) = 64 segment entries in the table,
   * meaning 64 ring segments.
index 149fd08d0642c285dfbe7b406e3e8529b1e97c3d..627ec30f06c9b0984edb609b58bff200742181df 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
  
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1877,6 +1877,7 @@ struct xhci_hcd {
+@@ -1880,6 +1880,7 @@ struct xhci_hcd {
  #define XHCI_EP_CTX_BROKEN_DCS        BIT_ULL(36)
  #define XHCI_SKIP_PHY_INIT    BIT_ULL(37)
  #define XHCI_DISABLE_SPARSE   BIT_ULL(38)
index 72ea0cbd3b2b03b51886ad0e35dba004b62cc2b9..5469beb53f0c715e339b3de80cd882ee09c76c4c 100644 (file)
@@ -127,7 +127,7 @@ it on BCM4708 family.
  /*
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1874,6 +1874,7 @@ struct xhci_hcd {
+@@ -1877,6 +1877,7 @@ struct xhci_hcd {
  #define XHCI_DEFAULT_PM_RUNTIME_ALLOW BIT_ULL(33)
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
diff --git a/target/linux/generic/backport-5.4/040-ARM-8918-2-only-build-return_address-if-needed.patch b/target/linux/generic/backport-5.4/040-ARM-8918-2-only-build-return_address-if-needed.patch
deleted file mode 100644 (file)
index c9301f9..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-From fb033c95c94ca1ee3d16e04ebdb85d65fb55fff8 Mon Sep 17 00:00:00 2001
-From: Ben Dooks <ben-linux@fluff.org>
-Date: Mon, 4 Nov 2019 18:15:15 +0100
-Subject: [PATCH] ARM: 8918/2: only build return_address() if needed
-
-The system currently warns if the config conditions for
-building return_address in arch/arm/kernel/return_address.c
-are not met, leaving just an EXPORT_SYMBOL_GPL(return_address)
-of a function defined to be 'static linline'.
-This is a result of aeea3592a13b ("ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h").
-
-Since we're not going to build anything other than an exported
-symbol for something that is already being defined to be an
-inline-able return of NULL, just avoid building the code to
-remove the following warning:
-
-Fixes: aeea3592a13b ("ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h")
-Signed-off-by: Ben Dooks <ben.dooks@codethink.co.uk>
-Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
----
- arch/arm/kernel/Makefile         | 6 +++++-
- arch/arm/kernel/return_address.c | 4 ----
- 2 files changed, 5 insertions(+), 5 deletions(-)
-
---- a/arch/arm/kernel/Makefile
-+++ b/arch/arm/kernel/Makefile
-@@ -17,10 +17,14 @@ CFLAGS_REMOVE_return_address.o = -pg
- # Object file lists.
- obj-y         := elf.o entry-common.o irq.o opcodes.o \
--                 process.o ptrace.o reboot.o return_address.o \
-+                 process.o ptrace.o reboot.o \
-                  setup.o signal.o sigreturn_codes.o \
-                  stacktrace.o sys_arm.o time.o traps.o
-+ifneq ($(CONFIG_ARM_UNWIND),y)
-+obj-$(CONFIG_FRAME_POINTER)   += return_address.o
-+endif
-+
- obj-$(CONFIG_ATAGS)           += atags_parse.o
- obj-$(CONFIG_ATAGS_PROC)      += atags_proc.o
- obj-$(CONFIG_DEPRECATED_PARAM_STRUCT) += atags_compat.o
---- a/arch/arm/kernel/return_address.c
-+++ b/arch/arm/kernel/return_address.c
-@@ -7,8 +7,6 @@
-  */
- #include <linux/export.h>
- #include <linux/ftrace.h>
--
--#if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND)
- #include <linux/sched.h>
- #include <asm/stacktrace.h>
-@@ -53,6 +51,4 @@ void *return_address(unsigned int level)
-               return NULL;
- }
--#endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) */
--
- EXPORT_SYMBOL_GPL(return_address);
index ba5a068ec79be5927fc5be3b06798564cf9b5dc9..17c5242483a70a10a0f3708089e90c53cb8fabb5 100644 (file)
@@ -1470,7 +1470,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (!is_valid_ether_addr(ndev->dev_addr))
                eth_hw_addr_random(ndev);
        temac_do_set_mac_address(ndev);
-@@ -1298,7 +1298,7 @@ static int temac_probe(struct platform_d
+@@ -1296,7 +1296,7 @@ static int temac_probe(struct platform_d
        struct temac_local *lp;
        struct net_device *ndev;
        struct resource *res;
@@ -1479,7 +1479,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        __be32 *p;
        bool little_endian;
        int rc = 0;
-@@ -1494,8 +1494,8 @@ static int temac_probe(struct platform_d
+@@ -1492,8 +1492,8 @@ static int temac_probe(struct platform_d
  
        if (temac_np) {
                /* Retrieve the MAC address */
index ffe429929b9e0319776bb81344aeb641ebdb39d5..5f0c44f95376892db57f625617b23d0d0d7849a8 100644 (file)
@@ -184,7 +184,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
  void xhci_init_driver(struct hc_driver *drv,
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -2151,6 +2151,16 @@ int xhci_find_raw_port_number(struct usb
+@@ -2154,6 +2154,16 @@ int xhci_find_raw_port_number(struct usb
  struct xhci_hub *xhci_get_rhub(struct usb_hcd *hcd);
  
  void xhci_hc_died(struct xhci_hcd *xhci);
index e866bef1dfda9f225eec10986f86437fdac811da..617374a26bec267db8b7111b082176ddf02c3f65 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
        ret = xhci_handshake(&xhci->op_regs->command,
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1874,6 +1874,7 @@ struct xhci_hcd {
+@@ -1877,6 +1877,7 @@ struct xhci_hcd {
  #define XHCI_DEFAULT_PM_RUNTIME_ALLOW BIT_ULL(33)
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
index 2fc5ba3f06dfec51f0a4cadcc73f9b1981ab7af9..f82c3accad0d54859e0886d59f4f315d2936e277 100644 (file)
@@ -35,7 +35,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
  EXPORT_SYMBOL_GPL(xhci_init_driver);
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1917,6 +1917,7 @@ struct xhci_driver_overrides {
+@@ -1920,6 +1920,7 @@ struct xhci_driver_overrides {
        int (*start)(struct usb_hcd *hcd);
        int (*check_bandwidth)(struct usb_hcd *, struct usb_device *);
        void (*reset_bandwidth)(struct usb_hcd *, struct usb_device *);