build: filter out more autogenerated kernel config options
authorFelix Fietkau <nbd@nbd.name>
Tue, 20 Oct 2020 19:36:52 +0000 (21:36 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 13 Nov 2020 12:18:20 +0000 (13:18 +0100)
Define wildcard patterns for filtering in target/linux/generic/config-filter
Preparation for supporting newer kernels

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/kernel-build.mk
include/target.mk
target/linux/generic/config-filter [new file with mode: 0644]

index 600cf1d771b8937dedb8df4c264028645c148acb..a698deec3ca441385c5ebefc208e0f4f36650853 100644 (file)
@@ -170,9 +170,7 @@ define BuildKernel
                ) \
                YACC=$(STAGING_DIR_HOST)/bin/bison \
                $$@
-       $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config | \
-               grep -vE '(CONFIG_CC_(HAS_ASM_GOTO|IS_GCC|IS_CLANG)|GCC_VERSION)=' \
-               > $(LINUX_RECONFIG_TARGET)
+       $(call LINUX_RECONF_DIFF,$(LINUX_DIR)/.config) > $(LINUX_RECONFIG_TARGET)
 
   install: $(LINUX_DIR)/.image
        +$(MAKE) -C image compile install TARGET_BUILD=
index a2e76f8149b739ddd3880faf7bb7103410f7a3ec..edc6a146de0f76acd66fe00d86b2142e33711e10 100644 (file)
@@ -185,11 +185,11 @@ ifeq ($(CONFIG_TARGET),env)
   LINUX_RECONFIG_TARGET = $(TOPDIR)/env/kernel-config
 endif
 
-__linux_confcmd = $(SCRIPT_DIR)/kconfig.pl $(2) $(patsubst %,+,$(wordlist 2,9999,$(1))) $(1)
+__linux_confcmd = $(2) $(patsubst %,+,$(wordlist 2,9999,$(1))) $(1)
 
-LINUX_CONF_CMD = $(call __linux_confcmd,$(LINUX_KCONFIG_LIST),)
-LINUX_RECONF_CMD = $(call __linux_confcmd,$(LINUX_RECONFIG_LIST),)
-LINUX_RECONF_DIFF = $(call __linux_confcmd,$(filter-out $(LINUX_RECONFIG_TARGET),$(LINUX_RECONFIG_LIST)),'>')
+LINUX_CONF_CMD = $(SCRIPT_DIR)/kconfig.pl $(call __linux_confcmd,$(LINUX_KCONFIG_LIST))
+LINUX_RECONF_CMD = $(SCRIPT_DIR)/kconfig.pl $(call __linux_confcmd,$(LINUX_RECONFIG_LIST))
+LINUX_RECONF_DIFF = $(SCRIPT_DIR)/kconfig.pl - '>' $(call __linux_confcmd,$(filter-out $(LINUX_RECONFIG_TARGET),$(LINUX_RECONFIG_LIST))) $(1) $(GENERIC_PLATFORM_DIR)/config-filter
 
 ifeq ($(DUMP),1)
   BuildTarget=$(BuildTargets/DumpCurrent)
diff --git a/target/linux/generic/config-filter b/target/linux/generic/config-filter
new file mode 100644 (file)
index 0000000..0d53ed9
--- /dev/null
@@ -0,0 +1,7 @@
+# CONFIG_ARCH_(ENABLE|HAS|HAVE|INLINE|SUPPORTS|USE|WANT)_.* is not set
+# CONFIG_AS_.* is not set
+# CONFIG_CC_(CAN|HAS|IS|VERSION)_.* is not set
+# CONFIG_LD_.* is not set
+# CONFIG_GCC_VERSION is not set
+# CONFIG_INLINE_.* is not set
+# CONFIG_HAVE_(?!(ARCH_TIMER|TCM|SMP)).* is not set