bcm53xx: always use 4 MiB for TRX kernel partition to simplify upgrades
authorRafał Miłecki <zajec5@gmail.com>
Tue, 21 Apr 2015 08:19:53 +0000 (08:19 +0000)
committerRafał Miłecki <zajec5@gmail.com>
Tue, 21 Apr 2015 08:19:53 +0000 (08:19 +0000)
Signed-off-by: Dan Haab <dhaab@luxul.com>
SVN-Revision: 45540

target/linux/bcm53xx/image/Makefile

index 4720aaf309ab1fdbcf724ee97f57fc0986506d4b..b3f2cd8127afccc44d335aecac15f8ed1d2a41a4 100644 (file)
@@ -31,12 +31,14 @@ define Build/mkfs/squashfs
 endef
 
 define Build/trx-nand
+       # kernel: always use 4 MiB (-28 B or TRX header) to allow upgrades even
+       #         if it grows up between releases
        $(STAGING_DIR_HOST)/bin/trx \
                -o $@ \
                -m 33554432 \
-               -f $(word 1,$^) \
-               -a 0x20000 -f $(KDIR)/root-block-0x20000-min-0x800.ubi \
-               -a 0x20000 -A $(KDIR)/fs_mark
+               -f $(word 1,$^) -a 0x20000 -b 0x400000 \
+               -f $(KDIR)/root-block-0x20000-min-0x800.ubi -a 0x20000 \
+               -A $(KDIR)/fs_mark
 endef
 
 define Build/netgear-chk