libjson-c: also install .pc file for compatibility libjson
authorJohn Crispin <john@openwrt.org>
Sun, 12 Jan 2014 12:06:57 +0000 (12:06 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 12 Jan 2014 12:06:57 +0000 (12:06 +0000)
Older packages, which did not follow the renaming yet, do not
find the library otherwise via pkgconfig.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 39228

package/libs/libjson-c/Makefile

index 3a8a41b515e3036126315cff640ab0f6ef4916f6..4e0c47da3c4b32bb46a20eed5a2b52e8b61bc6ee 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -61,6 +61,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-c.{a,so*} $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/json-c.pc $(1)/usr/lib/pkgconfig/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/json.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libjson-c/install