allow targets to define a default subtarget when using automatic subtarget detection...
authorJohn Crispin <john@openwrt.org>
Mon, 4 Jul 2011 11:21:37 +0000 (11:21 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 4 Jul 2011 11:21:37 +0000 (11:21 +0000)
SVN-Revision: 27444

include/target.mk
scripts/metadata.pl

index cfd7c9f3c345a239494b2852a443ecb4274d7267..af3230925c8a85ba79bc6121e50664ef8df56094 100644 (file)
@@ -215,6 +215,7 @@ define BuildTargets/DumpCurrent
         echo 'Linux-Version: $(LINUX_VERSION)'; \
         echo 'Linux-Release: $(LINUX_RELEASE)'; \
         echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \
+       $(if $(SUBTARGET),,$(if $(DEFAULT_SUBTARGET), echo 'Default-Subtarget: $(DEFAULT_SUBTARGET)'; ))
         echo 'Target-Description:'; \
         $(SH_FUNC) getvar $(call shvar,Target/Description); \
         echo '@@'; \
index 3acdb16a82fa7fca8d338ad3f8a6e7bc9053b5be..0f4ae9fe0aa125a5a5ea5b87b529241eda4f12d4 100755 (executable)
@@ -56,6 +56,7 @@ sub parse_target_metadata() {
                /^Linux-Version:\s*(.+)\s*$/ and $target->{version} = $1;
                /^Linux-Release:\s*(.+)\s*$/ and $target->{release} = $1;
                /^Linux-Kernel-Arch:\s*(.+)\s*$/ and $target->{karch} = $1;
+               /^Default-Subtarget:\s*(.+)\s*$/ and $target->{def_subtarget} = $1;
                /^Default-Packages:\s*(.+)\s*$/ and $target->{packages} = [ split(/\s+/, $1) ];
                /^Target-Profile:\s*(.+)\s*$/ and do {
                        $profile = {
@@ -282,6 +283,14 @@ endchoice
 
 choice
        prompt "Subtarget" if HAS_SUBTARGETS
+EOF
+       foreach my $target (@target) {
+               next unless $target->{def_subtarget};
+               print <<EOF;
+       default TARGET_$target->{conf}_$target->{def_subtarget} if TARGET_$target->{conf}
+EOF
+       }
+       print <<EOF;
 
 EOF
        foreach my $target (@target) {