uclibc++: add hack to fix failing patch
authorJo-Philipp Wich <jo@mein.io>
Thu, 14 Apr 2016 16:27:12 +0000 (18:27 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 14 Apr 2016 16:27:12 +0000 (18:27 +0200)
One of the patched files, include/unwind-cxx.h, contains windows newlines
which lead to the following failure:

  Applying ./patches/006-eabi_fix.patch using plaintext:
  patching file include/typeinfo
  patching file include/unwind-cxx.h
  Hunk #1 FAILED at 173 (different line endings).
  Hunk #2 FAILED at 181 (different line endings).

Add a fixup command to the prepare phase which normalizes the line endings
before applying source patches.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/libs/uclibc++/Makefile

index a4dceb7a3be3e250d8127ee8b6ff1831d42f0aab..4c7c7678e3ace5d0c5bd93c76ce5190857c59ca3 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (c) 2016 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uclibc++
 PKG_VERSION:=0.2.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=uClibc++-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://cxx.uclibc.org/src/
@@ -66,6 +67,12 @@ MAKE_FLAGS:= \
 
 # check_as_needed overrides dependency on libgcc_s
 
+define Build/Prepare
+       $(PKG_UNPACK)
+       $(SED) 's/\r$$$$//' $(PKG_BUILD_DIR)/include/unwind-cxx.h
+       $(Build/Patch)
+endef
+
 define Build/Configure
        if [ -f ./files/config.$(UCLIBC_TARGET_ARCH) ]; then \
                cp ./files/config.$(UCLIBC_TARGET_ARCH) $(PKG_BUILD_DIR)/.config; \