toolchain/binutils: use default Host/Configure rule
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 22 Apr 2019 12:22:40 +0000 (15:22 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 11 May 2019 21:10:10 +0000 (23:10 +0200)
This seems to have been omitted over-time.
Using the default Host/Configure seems to work fine.

The last patches to have touched this in a major way were ~10 years ago:
33a0eb3613d ("cosmetic & coherency fixes")
7eb15898755 ("build system refactoring in preparation for allowing
              packages to do host-build steps")

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
toolchain/binutils/Makefile

index 1a0b1bce0535c77bd10a86818fc42f7dfc4a392f..24eaf705664219978c90b89b2e47c81919530daf 100644 (file)
@@ -33,34 +33,33 @@ PATCH_DIR:=./patches/$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 
-BINUTILS_CONFIGURE:= \
-       ./configure \
-               --prefix=$(TOOLCHAIN_DIR) \
-               --build=$(GNU_HOST_NAME) \
-               --host=$(GNU_HOST_NAME) \
-               --target=$(REAL_GNU_TARGET_NAME) \
-               --with-sysroot=$(TOOLCHAIN_DIR) \
-               --enable-deterministic-archives \
-               --enable-plugins \
-               --disable-multilib \
-               --disable-werror \
-               --disable-nls \
-               --disable-sim \
-               --disable-gdb \
-               $(GRAPHITE_CONFIGURE) \
-               $(SOFT_FLOAT_CONFIG_OPTION) \
-               $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) 
+HOST_CONFIGURE_ARGS = \
+       --prefix=$(TOOLCHAIN_DIR) \
+       --build=$(GNU_HOST_NAME) \
+       --host=$(GNU_HOST_NAME) \
+       --target=$(REAL_GNU_TARGET_NAME) \
+       --with-sysroot=$(TOOLCHAIN_DIR) \
+       --enable-deterministic-archives \
+       --enable-plugins \
+       --disable-multilib \
+       --disable-werror \
+       --disable-nls \
+       --disable-sim \
+       --disable-gdb \
+       $(GRAPHITE_CONFIGURE) \
+       $(SOFT_FLOAT_CONFIG_OPTION) \
+       $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS))
 
 ifneq ($(CONFIG_SSP_SUPPORT),)
-  BINUTILS_CONFIGURE+= \
+  HOST_CONFIGURE_ARGS+= \
                --enable-libssp
 else
-  BINUTILS_CONFIGURE+= \
+  HOST_CONFIGURE_ARGS+= \
                --disable-libssp
 endif
 
 ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
-  BINUTILS_CONFIGURE+= \
+  HOST_CONFIGURE_ARGS+= \
                --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
 endif
 
@@ -71,12 +70,6 @@ define Host/Prepare
        $(SED) 's, " Linaro.*,,' $(HOST_BUILD_DIR)/bfd/version.h
 endef
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-               $(BINUTILS_CONFIGURE) \
-       );
-endef
-
 define Host/Compile
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) all
 endef