6in4: sync with HE.net endpoint update changes
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 17 Oct 2011 12:45:07 +0000 (12:45 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 17 Oct 2011 12:45:07 +0000 (12:45 +0000)
SVN-Revision: 28475

package/6in4/Makefile
package/6in4/files/6in4.hotplug

index 14b7eac8165f0d7da5762e74a7e2be1c0556a0b7..fb0803a8a69f724d71c3835dfaf47ffaafddd91b 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=9
-PKG_RELEASE:=2
+PKG_VERSION:=10
+PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
 
index 9df993498a1f6ae5fad21e37687d50ff90674473..3d9def448e9fdba4c2c58580f4467ba123b0ada1 100644 (file)
@@ -37,12 +37,12 @@ if [ "$ACTION" = ifup ]; then
                        uci_set_state network "$cfg" ipaddr "$wanip"
 
                        [ -n "$tunnelid" ] && [ -n "$username" ] && [ -n "$password" ] && {
-                               [ "${#password}" == 32 -a -z "${password//[a-f0-9]/}" ] || {
+                               [ "${#password}" == 32 -a -z "${password//[a-fA-F0-9]/}" ] || {
                                        password="$(echo -n "$password" | md5sum)"; password="${password%% *}"
                                }
 
                                (
-                                       local url="http://ipv4.tunnelbroker.net/ipv4_end.php?ipv4b=AUTO&user_id=$username&pass=$password&tunnel_id=$tunnelid"
+                                       local url="http://ipv4.tunnelbroker.net/ipv4_end.php?ip=AUTO&apikey=$username&pass=$password&tid=$tunnelid"
                                        local try=0
                                        local max=3