treewide: simplify inclusion of subtarget image files
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 7 Jun 2020 11:11:15 +0000 (13:11 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 10 Jun 2020 23:44:13 +0000 (01:44 +0200)
Many target use a repetitive if-include scheme for their subtarget
image files, though their names are consistent with the subtarget
names.

This patch removes these redundant conditions and just uses the
variable for the include where the target setup allows it.

For sunxi, this includes a trivial rename of the subtarget image
Makefiles.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
14 files changed:
target/linux/at91/image/Makefile
target/linux/ath79/image/Makefile
target/linux/layerscape/image/Makefile
target/linux/mvebu/image/Makefile
target/linux/oxnas/image/Makefile
target/linux/rockchip/image/Makefile
target/linux/sunxi/image/Makefile
target/linux/sunxi/image/cortex-a53.mk [deleted file]
target/linux/sunxi/image/cortex-a7.mk [deleted file]
target/linux/sunxi/image/cortex-a8.mk [deleted file]
target/linux/sunxi/image/cortexa53.mk [new file with mode: 0644]
target/linux/sunxi/image/cortexa7.mk [new file with mode: 0644]
target/linux/sunxi/image/cortexa8.mk [new file with mode: 0644]
target/linux/x86/image/Makefile

index adb7c6d0ba5c30bda3efc3308973a9c51af4cb78..ff801dae862ebe7e17f3a789d09d4199bcc65945 100644 (file)
@@ -13,12 +13,7 @@ define Build/at91-install-zImage
     $(CP) $(KDIR)/zImage $@
 endef
 
-ifeq ($(SUBTARGET),sam9x)
-include ./sam9x.mk
-endif
-ifeq ($(SUBTARGET),sama5)
-include ./sama5.mk
-endif
+include $(SUBTARGET).mk
 
 AT91_SD_BOOT_PARTSIZE:=64
 FAT32_BLOCK_SIZE:=1024
index 529baf8f571d037720f046e2ce30309e9869fff6..a555cfc6d50c20c4db54f38824c921b861d0b7cb 100644 (file)
@@ -68,20 +68,16 @@ define Device/Default
        append-rootfs | pad-rootfs | append-metadata | check-size
 endef
 
+include $(SUBTARGET).mk
+
 ifeq ($(SUBTARGET),generic)
-include ./generic.mk
-include ./generic-tp-link.mk
-include ./generic-ubnt.mk
-endif
-ifeq ($(SUBTARGET),mikrotik)
-include ./mikrotik.mk
-endif
-ifeq ($(SUBTARGET),nand)
-include ./nand.mk
+include generic-tp-link.mk
+include generic-ubnt.mk
 endif
+
 ifeq ($(SUBTARGET),tiny)
-include ./tiny.mk
-include ./tiny-netgear.mk
-include ./tiny-tp-link.mk
+include tiny-netgear.mk
+include tiny-tp-link.mk
 endif
+
 $(eval $(call BuildImage))
index bc65748853f9ca4e75aba279ddec1fa4bfeff9eb..f5a5ad99804f62c6de736aeab556051cc619a5d5 100644 (file)
@@ -43,12 +43,6 @@ define Build/traverse-fit
        @mv -f $@.new $@
 endef
 
-ifeq ($(SUBTARGET),armv8_64b)
-include armv8_64b.mk
-endif
-
-ifeq ($(SUBTARGET),armv7)
-include armv7.mk
-endif
+include $(SUBTARGET).mk
 
 $(eval $(call BuildImage))
index 3a478780693d31023fae0a62b2152c3dc4e79ce7..cbf34c1bc86e16930c0ed4c9316c5c62f42e1244 100644 (file)
@@ -138,16 +138,6 @@ define Device/NAND-512K
   PAGESIZE := 4096
 endef
 
-ifeq ($(SUBTARGET),cortexa9)
-include cortexa9.mk
-endif
-
-ifeq ($(SUBTARGET),cortexa53)
-include cortexa53.mk
-endif
-
-ifeq ($(SUBTARGET),cortexa72)
-include cortexa72.mk
-endif
+include $(SUBTARGET).mk
 
 $(eval $(call BuildImage))
index 644c2b87955e49bee3edfb5190bf3caae7967a12..abf83caa1accc59a9e95ee8541e3c4e1c24b8d5e 100644 (file)
@@ -4,12 +4,6 @@ include $(INCLUDE_DIR)/image.mk
 VMLINUX:=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux
 UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
 
-ifeq ($(SUBTARGET),ox810se)
-include ox810se.mk
-endif
-
-ifeq ($(SUBTARGET),ox820)
-include ox820.mk
-endif
+include $(SUBTARGET).mk
 
 $(eval $(call BuildImage))
index 5f605ebfe5ebba4f93ebc772e8ef5616ea303fd9..22854d9d02df519376503c922514bdad9e2c8584 100644 (file)
@@ -56,8 +56,6 @@ define Device/Default
   DEVICE_DTS = rockchip/$$(SOC)-$(lastword $(subst _, ,$(1)))
 endef
 
-ifeq ($(SUBTARGET),armv8)
-  include armv8.mk
-endif
+include $(SUBTARGET).mk
 
 $(eval $(call BuildImage))
index 1b98849a5048dd1353864b86d51bf29e77a1d0a3..01e9742b4602a4e72d086a868fe995c98201d70a 100644 (file)
@@ -42,16 +42,6 @@ define Device/Default
   SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
 endef
 
-ifeq ($(SUBTARGET),cortexa7)
-include cortex-a7.mk
-endif
-
-ifeq ($(SUBTARGET),cortexa8)
-include cortex-a8.mk
-endif
-
-ifeq ($(SUBTARGET),cortexa53)
-include cortex-a53.mk
-endif
+include $(SUBTARGET).mk
 
 $(eval $(call BuildImage))
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
deleted file mode 100644 (file)
index 7a70de4..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-#
-# Copyright (C) 2013-2016 OpenWrt.org
-# Copyright (C) 2016 Yousong Zhou
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Device/sun50i
-  SUNXI_DTS_DIR := allwinner/
-  KERNEL_NAME := Image
-  KERNEL := kernel-bin
-endef
-
-define Device/sun50i-h5
-  SOC := sun50i-h5
-  $(Device/sun50i)
-endef
-
-define Device/sun50i-a64
-  SOC := sun50i-a64
-  $(Device/sun50i)
-endef
-
-define Device/friendlyarm_nanopi-neo-plus2
-  DEVICE_VENDOR := FriendlyARM
-  DEVICE_MODEL := NanoPi NEO Plus2
-  SUPPORTED_DEVICES:=nanopi-neo-plus2
-  $(Device/sun50i-h5)
-endef
-TARGET_DEVICES += friendlyarm_nanopi-neo-plus2
-
-define Device/friendlyarm_nanopi-neo2
-  DEVICE_VENDOR := FriendlyARM
-  DEVICE_MODEL := NanoPi NEO2
-  SUPPORTED_DEVICES:=nanopi-neo2
-  $(Device/sun50i-h5)
-endef
-TARGET_DEVICES += friendlyarm_nanopi-neo2
-
-define Device/olimex_a64-olinuxino
-  DEVICE_VENDOR := Olimex
-  DEVICE_MODEL := A64-Olinuxino
-  DEVICE_PACKAGES := kmod-rtl8723bs rtl8723bs-firmware
-  $(Device/sun50i-a64)
-  SUNXI_DTS := $$(SUNXI_DTS_DIR)$$(SOC)-olinuxino
-endef
-TARGET_DEVICES += olimex_a64-olinuxino
-
-define Device/olimex_a64-olinuxino-emmc
-  DEVICE_VENDOR := Olimex
-  DEVICE_MODEL := A64-Olinuxino
-  DEVICE_VARIANT := eMMC
-  DEVICE_PACKAGES := kmod-rtl8723bs rtl8723bs-firmware
-  $(Device/sun50i-a64)
-  SUNXI_DTS := $$(SUNXI_DTS_DIR)$$(SOC)-olinuxino-emmc
-endef
-TARGET_DEVICES += olimex_a64-olinuxino-emmc
-
-define Device/pine64_pine64-plus
-  DEVICE_VENDOR := Pine64
-  DEVICE_MODEL := Pine64+
-  $(Device/sun50i-a64)
-endef
-TARGET_DEVICES += pine64_pine64-plus
-
-define Device/pine64_sopine-baseboard
-  DEVICE_VENDOR := Pine64
-  DEVICE_MODEL := SoPine
-  $(Device/sun50i-a64)
-endef
-TARGET_DEVICES += pine64_sopine-baseboard
-
-define Device/xunlong_orangepi-pc2
-  DEVICE_VENDOR := Xunlong
-  DEVICE_MODEL := Orange Pi PC 2
-  $(Device/sun50i-h5)
-endef
-TARGET_DEVICES += xunlong_orangepi-pc2
-
-define Device/xunlong_orangepi-zero-plus
-  DEVICE_VENDOR := Xunlong
-  DEVICE_MODEL := Orange Pi Zero Plus
-  $(Device/sun50i-h5)
-endef
-TARGET_DEVICES += xunlong_orangepi-zero-plus
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
deleted file mode 100644 (file)
index 8fa6481..0000000
+++ /dev/null
@@ -1,195 +0,0 @@
-#
-# Copyright (C) 2013-2019 OpenWrt.org
-# Copyright (C) 2016 Yousong Zhou
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Device/cubietech_cubieboard2
-  DEVICE_VENDOR := Cubietech
-  DEVICE_MODEL := Cubieboard2
-  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
-  SOC := sun7i-a20
-endef
-TARGET_DEVICES += cubietech_cubieboard2
-
-define Device/cubietech_cubietruck
-  DEVICE_VENDOR := Cubietech
-  DEVICE_MODEL := Cubietruck
-  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi kmod-brcmfmac
-  SOC := sun7i-a20
-endef
-TARGET_DEVICES += cubietech_cubietruck
-
-define Device/friendlyarm_nanopi-m1-plus
-  DEVICE_VENDOR := FriendlyARM
-  DEVICE_MODEL := NanoPi M1 Plus
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
-       kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
-  SOC := sun8i-h3
-endef
-TARGET_DEVICES += friendlyarm_nanopi-m1-plus
-
-define Device/friendlyarm_nanopi-neo
-  DEVICE_VENDOR := FriendlyARM
-  DEVICE_MODEL := NanoPi NEO
-  SOC := sun8i-h3
-endef
-TARGET_DEVICES += friendlyarm_nanopi-neo
-
-define Device/friendlyarm_nanopi-neo-air
-  DEVICE_VENDOR := FriendlyARM
-  DEVICE_MODEL := NanoPi NEO Air
-  DEVICE_PACKAGES := kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
-       kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
-  SOC := sun8i-h3
-endef
-TARGET_DEVICES += friendlyarm_nanopi-neo-air
-
-define Device/lamobo_lamobo-r1
-  DEVICE_VENDOR := Lamobo
-  DEVICE_MODEL := Lamobo R1
-  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtl8192cu swconfig wpad-basic
-  SOC := sun7i-a20
-endef
-TARGET_DEVICES += lamobo_lamobo-r1
-
-define Device/lemaker_bananapi
-  DEVICE_VENDOR := LeMaker
-  DEVICE_MODEL := Banana Pi
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi
-  SOC := sun7i-a20
-endef
-TARGET_DEVICES += lemaker_bananapi
-
-define Device/lemaker_bananapi-m2-ultra
-  DEVICE_VENDOR := LeMaker
-  DEVICE_MODEL := Banana Pi M2 Ultra
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi
-  SOC := sun8i-r40
-endef
-TARGET_DEVICES += lemaker_bananapi-m2-ultra
-
-define Device/lemaker_bananapro
-  DEVICE_VENDOR := LeMaker
-  DEVICE_MODEL := Banana Pro
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi kmod-brcmfmac
-  SOC := sun7i-a20
-endef
-TARGET_DEVICES += lemaker_bananapro
-
-define Device/linksprite_pcduino3
-  DEVICE_VENDOR := LinkSprite
-  DEVICE_MODEL := pcDuino3
-  DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-ata-sunxi kmod-rtl8xxxu \
-       rtl8188eu-firmware
-  SOC := sun7i-a20
-endef
-TARGET_DEVICES += linksprite_pcduino3
-
-define Device/mele_m9
-  DEVICE_VENDOR := Mele
-  DEVICE_MODEL := M9
-  DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
-  SOC := sun6i-a31
-endef
-TARGET_DEVICES += mele_m9
-
-define Device/olimex_a20-olinuxino-lime
-  DEVICE_VENDOR := Olimex
-  DEVICE_MODEL := A20-OLinuXino-LIME
-  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi
-  SOC := sun7i
-endef
-TARGET_DEVICES += olimex_a20-olinuxino-lime
-
-define Device/olimex_a20-olinuxino-lime2
-  DEVICE_VENDOR := Olimex
-  DEVICE_MODEL := A20-OLinuXino-LIME2
-  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
-  SOC := sun7i
-endef
-TARGET_DEVICES += olimex_a20-olinuxino-lime2
-
-define Device/olimex_a20-olinuxino-lime2-emmc
-  DEVICE_VENDOR := Olimex
-  DEVICE_MODEL := A20-OLinuXino-LIME2
-  DEVICE_VARIANT := eMMC
-  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
-  SOC := sun7i
-endef
-TARGET_DEVICES += olimex_a20-olinuxino-lime2-emmc
-
-define Device/olimex_a20-olinuxino-micro
-  DEVICE_VENDOR := Olimex
-  DEVICE_MODEL := A20-OLinuXino-MICRO
-  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
-  SOC := sun7i
-endef
-TARGET_DEVICES += olimex_a20-olinuxino-micro
-
-define Device/sinovoip_bananapi-m2-plus
-  DEVICE_VENDOR := Sinovoip
-  DEVICE_MODEL := Banana Pi M2+
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
-       kmod-brcmfmac brcmfmac-firmware-43430a0-sdio wpad-basic
-  SOC := sun8i-h3
-endef
-TARGET_DEVICES += sinovoip_bananapi-m2-plus
-
-define Device/xunlong_orangepi-one
-  DEVICE_VENDOR := Xunlong
-  DEVICE_MODEL := Orange Pi One
-  DEVICE_PACKAGES:=kmod-rtc-sunxi
-  SOC := sun8i-h3
-endef
-TARGET_DEVICES += xunlong_orangepi-one
-
-define Device/xunlong_orangepi-pc
-  DEVICE_VENDOR := Xunlong
-  DEVICE_MODEL := Orange Pi PC
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
-  SOC := sun8i-h3
-endef
-TARGET_DEVICES += xunlong_orangepi-pc
-
-define Device/xunlong_orangepi-pc-plus
-  DEVICE_VENDOR := Xunlong
-  DEVICE_MODEL := Orange Pi PC Plus
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
-  SOC := sun8i-h3
-endef
-TARGET_DEVICES += xunlong_orangepi-pc-plus
-
-define Device/xunlong_orangepi-plus
-  DEVICE_VENDOR := Xunlong
-  DEVICE_MODEL := Orange Pi Plus
-  DEVICE_PACKAGES:=kmod-rtc-sunxi
-  SOC := sun8i-h3
-endef
-TARGET_DEVICES += xunlong_orangepi-plus
-
-define Device/xunlong_orangepi-r1
-  DEVICE_VENDOR := Xunlong
-  DEVICE_MODEL := Orange Pi R1
-  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152
-  SOC := sun8i-h2-plus
-endef
-TARGET_DEVICES += xunlong_orangepi-r1
-
-define Device/xunlong_orangepi-zero
-  DEVICE_VENDOR := Xunlong
-  DEVICE_MODEL := Orange Pi Zero
-  DEVICE_PACKAGES:=kmod-rtc-sunxi
-  SOC := sun8i-h2-plus
-endef
-TARGET_DEVICES += xunlong_orangepi-zero
-
-define Device/xunlong_orangepi-2
-  DEVICE_VENDOR := Xunlong
-  DEVICE_MODEL := Orange Pi 2
-  DEVICE_PACKAGES:=kmod-rtc-sunxi
-  SOC := sun8i-h3
-endef
-TARGET_DEVICES += xunlong_orangepi-2
diff --git a/target/linux/sunxi/image/cortex-a8.mk b/target/linux/sunxi/image/cortex-a8.mk
deleted file mode 100644 (file)
index 643b3d4..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-#
-# Copyright (C) 2013-2016 OpenWrt.org
-# Copyright (C) 2016 Yousong Zhou
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Device/cubietech_a10-cubieboard
-  DEVICE_VENDOR := Cubietech
-  DEVICE_MODEL := Cubieboard
-  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
-  SOC := sun4i
-endef
-TARGET_DEVICES += cubietech_a10-cubieboard
-
-define Device/linksprite_a10-pcduino
-  DEVICE_VENDOR := LinkSprite
-  DEVICE_MODEL := pcDuino
-  DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
-  SOC := sun4i
-endef
-TARGET_DEVICES += linksprite_a10-pcduino
-
-define Device/marsboard_a10-marsboard
-  DEVICE_VENDOR := HAOYU Electronics
-  DEVICE_MODEL := MarsBoard A10
-  DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi \
-       sound-soc-sunxi
-  SOC := sun4i
-endef
-TARGET_DEVICES += marsboard_a10-marsboard
-
-define Device/olimex_a10-olinuxino-lime
-  DEVICE_VENDOR := Olimex
-  DEVICE_MODEL := A10-OLinuXino-LIME
-  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
-  SOC := sun4i
-endef
-TARGET_DEVICES += olimex_a10-olinuxino-lime
-
-define Device/olimex_a13-olimex-som
-  DEVICE_VENDOR := Olimex
-  DEVICE_MODEL := A13-SOM
-  DEVICE_PACKAGES:=kmod-rtl8192cu
-  SUPPORTED_DEVICES:=olimex,a13-olinuxino
-  SOC := sun5i-a13
-  SUNXI_DTS := sun5i-a13-olinuxino
-endef
-TARGET_DEVICES += olimex_a13-olimex-som
-
-define Device/olimex_a13-olinuxino
-  DEVICE_VENDOR := Olimex
-  DEVICE_MODEL := A13-OLinuXino
-  DEVICE_PACKAGES:=kmod-rtl8192cu
-  SOC := sun5i
-endef
-TARGET_DEVICES += olimex_a13-olinuxino
diff --git a/target/linux/sunxi/image/cortexa53.mk b/target/linux/sunxi/image/cortexa53.mk
new file mode 100644 (file)
index 0000000..7a70de4
--- /dev/null
@@ -0,0 +1,86 @@
+#
+# Copyright (C) 2013-2016 OpenWrt.org
+# Copyright (C) 2016 Yousong Zhou
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Device/sun50i
+  SUNXI_DTS_DIR := allwinner/
+  KERNEL_NAME := Image
+  KERNEL := kernel-bin
+endef
+
+define Device/sun50i-h5
+  SOC := sun50i-h5
+  $(Device/sun50i)
+endef
+
+define Device/sun50i-a64
+  SOC := sun50i-a64
+  $(Device/sun50i)
+endef
+
+define Device/friendlyarm_nanopi-neo-plus2
+  DEVICE_VENDOR := FriendlyARM
+  DEVICE_MODEL := NanoPi NEO Plus2
+  SUPPORTED_DEVICES:=nanopi-neo-plus2
+  $(Device/sun50i-h5)
+endef
+TARGET_DEVICES += friendlyarm_nanopi-neo-plus2
+
+define Device/friendlyarm_nanopi-neo2
+  DEVICE_VENDOR := FriendlyARM
+  DEVICE_MODEL := NanoPi NEO2
+  SUPPORTED_DEVICES:=nanopi-neo2
+  $(Device/sun50i-h5)
+endef
+TARGET_DEVICES += friendlyarm_nanopi-neo2
+
+define Device/olimex_a64-olinuxino
+  DEVICE_VENDOR := Olimex
+  DEVICE_MODEL := A64-Olinuxino
+  DEVICE_PACKAGES := kmod-rtl8723bs rtl8723bs-firmware
+  $(Device/sun50i-a64)
+  SUNXI_DTS := $$(SUNXI_DTS_DIR)$$(SOC)-olinuxino
+endef
+TARGET_DEVICES += olimex_a64-olinuxino
+
+define Device/olimex_a64-olinuxino-emmc
+  DEVICE_VENDOR := Olimex
+  DEVICE_MODEL := A64-Olinuxino
+  DEVICE_VARIANT := eMMC
+  DEVICE_PACKAGES := kmod-rtl8723bs rtl8723bs-firmware
+  $(Device/sun50i-a64)
+  SUNXI_DTS := $$(SUNXI_DTS_DIR)$$(SOC)-olinuxino-emmc
+endef
+TARGET_DEVICES += olimex_a64-olinuxino-emmc
+
+define Device/pine64_pine64-plus
+  DEVICE_VENDOR := Pine64
+  DEVICE_MODEL := Pine64+
+  $(Device/sun50i-a64)
+endef
+TARGET_DEVICES += pine64_pine64-plus
+
+define Device/pine64_sopine-baseboard
+  DEVICE_VENDOR := Pine64
+  DEVICE_MODEL := SoPine
+  $(Device/sun50i-a64)
+endef
+TARGET_DEVICES += pine64_sopine-baseboard
+
+define Device/xunlong_orangepi-pc2
+  DEVICE_VENDOR := Xunlong
+  DEVICE_MODEL := Orange Pi PC 2
+  $(Device/sun50i-h5)
+endef
+TARGET_DEVICES += xunlong_orangepi-pc2
+
+define Device/xunlong_orangepi-zero-plus
+  DEVICE_VENDOR := Xunlong
+  DEVICE_MODEL := Orange Pi Zero Plus
+  $(Device/sun50i-h5)
+endef
+TARGET_DEVICES += xunlong_orangepi-zero-plus
diff --git a/target/linux/sunxi/image/cortexa7.mk b/target/linux/sunxi/image/cortexa7.mk
new file mode 100644 (file)
index 0000000..8fa6481
--- /dev/null
@@ -0,0 +1,195 @@
+#
+# Copyright (C) 2013-2019 OpenWrt.org
+# Copyright (C) 2016 Yousong Zhou
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Device/cubietech_cubieboard2
+  DEVICE_VENDOR := Cubietech
+  DEVICE_MODEL := Cubieboard2
+  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+  SOC := sun7i-a20
+endef
+TARGET_DEVICES += cubietech_cubieboard2
+
+define Device/cubietech_cubietruck
+  DEVICE_VENDOR := Cubietech
+  DEVICE_MODEL := Cubietruck
+  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi kmod-brcmfmac
+  SOC := sun7i-a20
+endef
+TARGET_DEVICES += cubietech_cubietruck
+
+define Device/friendlyarm_nanopi-m1-plus
+  DEVICE_VENDOR := FriendlyARM
+  DEVICE_MODEL := NanoPi M1 Plus
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
+       kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
+  SOC := sun8i-h3
+endef
+TARGET_DEVICES += friendlyarm_nanopi-m1-plus
+
+define Device/friendlyarm_nanopi-neo
+  DEVICE_VENDOR := FriendlyARM
+  DEVICE_MODEL := NanoPi NEO
+  SOC := sun8i-h3
+endef
+TARGET_DEVICES += friendlyarm_nanopi-neo
+
+define Device/friendlyarm_nanopi-neo-air
+  DEVICE_VENDOR := FriendlyARM
+  DEVICE_MODEL := NanoPi NEO Air
+  DEVICE_PACKAGES := kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
+       kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
+  SOC := sun8i-h3
+endef
+TARGET_DEVICES += friendlyarm_nanopi-neo-air
+
+define Device/lamobo_lamobo-r1
+  DEVICE_VENDOR := Lamobo
+  DEVICE_MODEL := Lamobo R1
+  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtl8192cu swconfig wpad-basic
+  SOC := sun7i-a20
+endef
+TARGET_DEVICES += lamobo_lamobo-r1
+
+define Device/lemaker_bananapi
+  DEVICE_VENDOR := LeMaker
+  DEVICE_MODEL := Banana Pi
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi
+  SOC := sun7i-a20
+endef
+TARGET_DEVICES += lemaker_bananapi
+
+define Device/lemaker_bananapi-m2-ultra
+  DEVICE_VENDOR := LeMaker
+  DEVICE_MODEL := Banana Pi M2 Ultra
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi
+  SOC := sun8i-r40
+endef
+TARGET_DEVICES += lemaker_bananapi-m2-ultra
+
+define Device/lemaker_bananapro
+  DEVICE_VENDOR := LeMaker
+  DEVICE_MODEL := Banana Pro
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi kmod-brcmfmac
+  SOC := sun7i-a20
+endef
+TARGET_DEVICES += lemaker_bananapro
+
+define Device/linksprite_pcduino3
+  DEVICE_VENDOR := LinkSprite
+  DEVICE_MODEL := pcDuino3
+  DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-ata-sunxi kmod-rtl8xxxu \
+       rtl8188eu-firmware
+  SOC := sun7i-a20
+endef
+TARGET_DEVICES += linksprite_pcduino3
+
+define Device/mele_m9
+  DEVICE_VENDOR := Mele
+  DEVICE_MODEL := M9
+  DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
+  SOC := sun6i-a31
+endef
+TARGET_DEVICES += mele_m9
+
+define Device/olimex_a20-olinuxino-lime
+  DEVICE_VENDOR := Olimex
+  DEVICE_MODEL := A20-OLinuXino-LIME
+  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi
+  SOC := sun7i
+endef
+TARGET_DEVICES += olimex_a20-olinuxino-lime
+
+define Device/olimex_a20-olinuxino-lime2
+  DEVICE_VENDOR := Olimex
+  DEVICE_MODEL := A20-OLinuXino-LIME2
+  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
+  SOC := sun7i
+endef
+TARGET_DEVICES += olimex_a20-olinuxino-lime2
+
+define Device/olimex_a20-olinuxino-lime2-emmc
+  DEVICE_VENDOR := Olimex
+  DEVICE_MODEL := A20-OLinuXino-LIME2
+  DEVICE_VARIANT := eMMC
+  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
+  SOC := sun7i
+endef
+TARGET_DEVICES += olimex_a20-olinuxino-lime2-emmc
+
+define Device/olimex_a20-olinuxino-micro
+  DEVICE_VENDOR := Olimex
+  DEVICE_MODEL := A20-OLinuXino-MICRO
+  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+  SOC := sun7i
+endef
+TARGET_DEVICES += olimex_a20-olinuxino-micro
+
+define Device/sinovoip_bananapi-m2-plus
+  DEVICE_VENDOR := Sinovoip
+  DEVICE_MODEL := Banana Pi M2+
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-leds-gpio kmod-ledtrig-heartbeat \
+       kmod-brcmfmac brcmfmac-firmware-43430a0-sdio wpad-basic
+  SOC := sun8i-h3
+endef
+TARGET_DEVICES += sinovoip_bananapi-m2-plus
+
+define Device/xunlong_orangepi-one
+  DEVICE_VENDOR := Xunlong
+  DEVICE_MODEL := Orange Pi One
+  DEVICE_PACKAGES:=kmod-rtc-sunxi
+  SOC := sun8i-h3
+endef
+TARGET_DEVICES += xunlong_orangepi-one
+
+define Device/xunlong_orangepi-pc
+  DEVICE_VENDOR := Xunlong
+  DEVICE_MODEL := Orange Pi PC
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
+  SOC := sun8i-h3
+endef
+TARGET_DEVICES += xunlong_orangepi-pc
+
+define Device/xunlong_orangepi-pc-plus
+  DEVICE_VENDOR := Xunlong
+  DEVICE_MODEL := Orange Pi PC Plus
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
+  SOC := sun8i-h3
+endef
+TARGET_DEVICES += xunlong_orangepi-pc-plus
+
+define Device/xunlong_orangepi-plus
+  DEVICE_VENDOR := Xunlong
+  DEVICE_MODEL := Orange Pi Plus
+  DEVICE_PACKAGES:=kmod-rtc-sunxi
+  SOC := sun8i-h3
+endef
+TARGET_DEVICES += xunlong_orangepi-plus
+
+define Device/xunlong_orangepi-r1
+  DEVICE_VENDOR := Xunlong
+  DEVICE_MODEL := Orange Pi R1
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152
+  SOC := sun8i-h2-plus
+endef
+TARGET_DEVICES += xunlong_orangepi-r1
+
+define Device/xunlong_orangepi-zero
+  DEVICE_VENDOR := Xunlong
+  DEVICE_MODEL := Orange Pi Zero
+  DEVICE_PACKAGES:=kmod-rtc-sunxi
+  SOC := sun8i-h2-plus
+endef
+TARGET_DEVICES += xunlong_orangepi-zero
+
+define Device/xunlong_orangepi-2
+  DEVICE_VENDOR := Xunlong
+  DEVICE_MODEL := Orange Pi 2
+  DEVICE_PACKAGES:=kmod-rtc-sunxi
+  SOC := sun8i-h3
+endef
+TARGET_DEVICES += xunlong_orangepi-2
diff --git a/target/linux/sunxi/image/cortexa8.mk b/target/linux/sunxi/image/cortexa8.mk
new file mode 100644 (file)
index 0000000..643b3d4
--- /dev/null
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2013-2016 OpenWrt.org
+# Copyright (C) 2016 Yousong Zhou
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Device/cubietech_a10-cubieboard
+  DEVICE_VENDOR := Cubietech
+  DEVICE_MODEL := Cubieboard
+  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+  SOC := sun4i
+endef
+TARGET_DEVICES += cubietech_a10-cubieboard
+
+define Device/linksprite_a10-pcduino
+  DEVICE_VENDOR := LinkSprite
+  DEVICE_MODEL := pcDuino
+  DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
+  SOC := sun4i
+endef
+TARGET_DEVICES += linksprite_a10-pcduino
+
+define Device/marsboard_a10-marsboard
+  DEVICE_VENDOR := HAOYU Electronics
+  DEVICE_MODEL := MarsBoard A10
+  DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi \
+       sound-soc-sunxi
+  SOC := sun4i
+endef
+TARGET_DEVICES += marsboard_a10-marsboard
+
+define Device/olimex_a10-olinuxino-lime
+  DEVICE_VENDOR := Olimex
+  DEVICE_MODEL := A10-OLinuXino-LIME
+  DEVICE_PACKAGES:=kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+  SOC := sun4i
+endef
+TARGET_DEVICES += olimex_a10-olinuxino-lime
+
+define Device/olimex_a13-olimex-som
+  DEVICE_VENDOR := Olimex
+  DEVICE_MODEL := A13-SOM
+  DEVICE_PACKAGES:=kmod-rtl8192cu
+  SUPPORTED_DEVICES:=olimex,a13-olinuxino
+  SOC := sun5i-a13
+  SUNXI_DTS := sun5i-a13-olinuxino
+endef
+TARGET_DEVICES += olimex_a13-olimex-som
+
+define Device/olimex_a13-olinuxino
+  DEVICE_VENDOR := Olimex
+  DEVICE_MODEL := A13-OLinuXino
+  DEVICE_PACKAGES:=kmod-rtl8192cu
+  SOC := sun5i
+endef
+TARGET_DEVICES += olimex_a13-olinuxino
index 174c272a515e946875c824babcdc0041ffdb2ecb..85c850c1281d6db16d645373f62ea5992f7f508f 100644 (file)
@@ -146,21 +146,7 @@ define Device/Default
   ARTIFACTS := $$(ARTIFACTS-y)
 endef
 
-ifeq ($(SUBTARGET),64)
-  include 64.mk
-endif
-
-ifeq ($(SUBTARGET),generic)
-  include generic.mk
-endif
-
-ifeq ($(SUBTARGET),geode)
-  include geode.mk
-endif
-
-ifeq ($(SUBTARGET),legacy)
-  include legacy.mk
-endif
+include $(SUBTARGET).mk
 
 $(eval $(call BuildImage))