kernel: bump 5.4 to 5.4.136
authorJohn Audia <graysky@archlinux.us>
Wed, 28 Jul 2021 12:29:03 +0000 (08:29 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 31 Jul 2021 17:13:00 +0000 (19:13 +0200)
All patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
18 files changed:
include/kernel-version.mk
target/linux/apm821xx/patches-5.4/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/bcm27xx/patches-5.4/950-0037-Add-dwc_otg-driver.patch
target/linux/bcm27xx/patches-5.4/950-0208-bcmgenet-Better-coalescing-parameter-defaults.patch
target/linux/bcm27xx/patches-5.4/950-0264-xhci-add-quirk-for-host-controllers-that-don-t-updat.patch
target/linux/bcm27xx/patches-5.4/950-0292-net-bcmgenet-Workaround-2-for-Pi4-Ethernet-fail.patch
target/linux/bcm27xx/patches-5.4/950-0293-xhci-Use-more-event-ring-segment-table-entries.patch
target/linux/bcm27xx/patches-5.4/950-0336-drm-v3d-The-third-IRQ-is-optional.patch
target/linux/bcm27xx/patches-5.4/950-0973-net-bcmgenet-Reset-RBUF-on-first-open.patch
target/linux/bcm27xx/patches-5.4/950-0993-xhci-quirks-add-link-TRB-quirk-for-VL805.patch
target/linux/bcm53xx/patches-5.4/180-usb-xhci-add-support-for-performing-fake-doorbell.patch
target/linux/layerscape/patches-5.4/820-usb-0015-MLK-17380-4-usb-host-xhci-add-EH-SINGLE_STEP_SET_FEA.patch
target/linux/layerscape/patches-5.4/820-usb-0016-MLK-16735-usb-host-add-XHCI_CDNS_HOST-flag.patch
target/linux/layerscape/patches-5.4/820-usb-0017-MLK-19153-2-usb-host-xhci-do-not-return-error-status.patch
target/linux/layerscape/patches-5.4/820-usb-0018-MLK-18794-1-usb-host-xhci-add-.bus_suspend-override.patch
target/linux/layerscape/patches-5.4/820-usb-0019-MLK-9829-usb-core-print-suggested-message-if-failed-.patch
target/linux/layerscape/patches-5.4/820-usb-0021-MLK-22099-usb-host-xhci-do-warm-reset-for-link-state.patch
target/linux/octeontx/patches-5.4/0004-PCI-add-quirk-for-Gateworks-PLX-PEX860x-switch-with-.patch

index 0ec155de2d5767a8dac6c4fd0236a1a28b90d3d3..c95a2e83255e713eb52260ba464264b20aefcd9a 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .135
+LINUX_VERSION-5.4 = .136
 LINUX_VERSION-5.10 = .54
 
-LINUX_KERNEL_HASH-5.4.135 = 83efa4c8c725bd2a5e66e2db5612d0ee586449d36661d13889b9ddf0203efdf1
+LINUX_KERNEL_HASH-5.4.136 = 4322dd36bf86b82d410fb2d4df196d1f3b78819aa9dd78b555703bcbf49bad16
 LINUX_KERNEL_HASH-5.10.54 = bf50c63261847187eca4a1793e5df5c1355b21697409589f6ca03e32b629be44
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 9a0bab5c4b0b86052e5428f734f6a6f56a7579f2..3c33253ec4245fbf7172c7de0f88b0129c73ab7c 100644 (file)
@@ -43,7 +43,7 @@ produce a noisy warning.
                hcd->msi_enabled = 1;
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1883,6 +1883,7 @@ struct xhci_hcd {
+@@ -1884,6 +1884,7 @@ struct xhci_hcd {
        struct xhci_hub         usb2_rhub;
        struct xhci_hub         usb3_rhub;
        /* support xHCI 1.0 spec USB2 hardware LPM */
index 9280ab3f17f55bb809bd878a836e57d3046905e9..ea3c8abd20d3f10f6e0b2f5b21cf1dd26f23651e 100644 (file)
@@ -1040,7 +1040,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5321,7 +5321,7 @@ static void port_event(struct usb_hub *h
+@@ -5369,7 +5369,7 @@ static void port_event(struct usb_hub *h
                port_dev->over_current_count++;
                port_over_current_notify(port_dev);
  
index 1d3765b93c9649ce333864768f773db36d3e343d..b245fbbbfd17fb73992e685e3297bb87d1afe469 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/ethernet/broadcom/genet/bcmgenet.c
 +++ b/drivers/net/ethernet/broadcom/genet/bcmgenet.c
-@@ -2149,7 +2149,7 @@ static void bcmgenet_init_tx_ring(struct
+@@ -2150,7 +2150,7 @@ static void bcmgenet_init_tx_ring(struct
  
        bcmgenet_tdma_ring_writel(priv, index, 0, TDMA_PROD_INDEX);
        bcmgenet_tdma_ring_writel(priv, index, 0, TDMA_CONS_INDEX);
@@ -27,7 +27,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        /* Disable rate control for now */
        bcmgenet_tdma_ring_writel(priv, index, flow_period_val,
                                  TDMA_FLOW_PERIOD);
-@@ -3579,9 +3579,12 @@ static int bcmgenet_probe(struct platfor
+@@ -3574,9 +3574,12 @@ static int bcmgenet_probe(struct platfor
        netif_set_real_num_rx_queues(priv->dev, priv->hw_params->rx_queues + 1);
  
        /* Set default coalescing parameters */
index e60468c848d4ae0271d3259b7748f5a00ef14515..0c3f290ea211e09622cfb2ec91f5ac07452a2a4e 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
                pdev->device == PCI_DEVICE_ID_ASMEDIA_1042_XHCI)
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -527,7 +527,10 @@ void xhci_find_new_dequeue_state(struct
+@@ -550,7 +550,10 @@ void xhci_find_new_dequeue_state(struct
        struct xhci_virt_ep *ep = &dev->eps[ep_index];
        struct xhci_ring *ep_ring;
        struct xhci_segment *new_seg;
@@ -48,7 +48,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
        dma_addr_t addr;
        u64 hw_dequeue;
        bool cycle_found = false;
-@@ -565,7 +568,28 @@ void xhci_find_new_dequeue_state(struct
+@@ -588,7 +591,28 @@ void xhci_find_new_dequeue_state(struct
        hw_dequeue = xhci_get_hw_deq(xhci, dev, ep_index, stream_id);
        new_seg = ep_ring->deq_seg;
        new_deq = ep_ring->dequeue;
@@ -80,7 +80,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
        /*
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1873,6 +1873,7 @@ struct xhci_hcd {
+@@ -1874,6 +1874,7 @@ struct xhci_hcd {
  #define XHCI_DEFAULT_PM_RUNTIME_ALLOW BIT_ULL(33)
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
index db1866d6e70d7ce8fe36dca2e1f86469ee130d2a..321cdb548c125ed56d89d53096092c92395a581d 100644 (file)
@@ -38,7 +38,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  static inline void bcmgenet_writel(u32 value, void __iomem *offset)
  {
        /* MIPS chips strapped for BE will automagically configure the
-@@ -1995,6 +1999,11 @@ static void reset_umac(struct bcmgenet_p
+@@ -1996,6 +2000,11 @@ static void reset_umac(struct bcmgenet_p
        bcmgenet_rbuf_ctrl_set(priv, 0);
        udelay(10);
  
index 25c23a8257d7729352d73a8fc554836105bb40b2..1758e4976138cdad70c72861558be5ef4e333320 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
                        val);
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1649,8 +1649,8 @@ struct urb_priv {
+@@ -1650,8 +1650,8 @@ struct urb_priv {
   * Each segment table entry is 4*32bits long.  1K seems like an ok size:
   * (1K bytes * 8bytes/bit) / (4*32 bits) = 64 segment entries in the table,
   * meaning 64 ring segments.
index ab3c053c3f02c5b789e3053cdf8445dd6741445d..2f9eb20addb867f54c1740682ace623fd201512c 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/ethernet/broadcom/genet/bcmgenet.c
 +++ b/drivers/net/ethernet/broadcom/genet/bcmgenet.c
-@@ -3480,7 +3480,7 @@ static int bcmgenet_probe(struct platfor
+@@ -3475,7 +3475,7 @@ static int bcmgenet_probe(struct platfor
        priv = netdev_priv(dev);
        priv->irq0 = platform_get_irq(pdev, 0);
        priv->irq1 = platform_get_irq(pdev, 1);
index 60505cf4ed0cdf386c4e72a3293fa013c993ad9a..706244f5c894c944e9c9d7568d996272b07eb163 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
 
 --- a/drivers/net/ethernet/broadcom/genet/bcmgenet.c
 +++ b/drivers/net/ethernet/broadcom/genet/bcmgenet.c
-@@ -2790,7 +2790,7 @@ static void bcmgenet_set_hw_addr(struct
+@@ -2791,7 +2791,7 @@ static void bcmgenet_set_hw_addr(struct
  }
  
  /* Returns a reusable dma control register value */
@@ -33,7 +33,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
  {
        unsigned int i;
        u32 reg;
-@@ -2815,6 +2815,14 @@ static u32 bcmgenet_dma_disable(struct b
+@@ -2816,6 +2816,14 @@ static u32 bcmgenet_dma_disable(struct b
        udelay(10);
        bcmgenet_umac_writel(priv, 0, UMAC_TX_FLUSH);
  
@@ -48,9 +48,9 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
        return dma_ctrl;
  }
  
-@@ -2916,8 +2924,8 @@ static int bcmgenet_open(struct net_devi
-               bcmgenet_ext_writel(priv, reg, EXT_EXT_PWR_MGMT);
-       }
+@@ -2911,8 +2919,8 @@ static int bcmgenet_open(struct net_devi
+       bcmgenet_set_hw_addr(priv, dev->dev_addr);
  
 -      /* Disable RX/TX DMA and flush TX queues */
 -      dma_ctrl = bcmgenet_dma_disable(priv);
@@ -59,7 +59,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
  
        /* Reinitialize TDMA and RDMA and SW housekeeping */
        ret = bcmgenet_init_dma(priv);
-@@ -3677,7 +3685,7 @@ static int bcmgenet_resume(struct device
+@@ -3665,7 +3673,7 @@ static int bcmgenet_resume(struct device
                bcmgenet_power_up(priv, GENET_POWER_WOL_MAGIC);
  
        /* Disable RX/TX DMA and flush TX queues */
index 355421ee268cb13d5ebd514e5de942389b8b595c..149fd08d0642c285dfbe7b406e3e8529b1e97c3d 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
        if (pdev->vendor == PCI_VENDOR_ID_ASMEDIA &&
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -624,6 +624,16 @@ void xhci_find_new_dequeue_state(struct
+@@ -647,6 +647,16 @@ void xhci_find_new_dequeue_state(struct
  
        } while (!cycle_found || !td_last_trb_found);
  
@@ -51,7 +51,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
  
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1876,6 +1876,7 @@ struct xhci_hcd {
+@@ -1877,6 +1877,7 @@ struct xhci_hcd {
  #define XHCI_EP_CTX_BROKEN_DCS        BIT_ULL(36)
  #define XHCI_SKIP_PHY_INIT    BIT_ULL(37)
  #define XHCI_DISABLE_SPARSE   BIT_ULL(38)
index 5427d7368ec511527dc71edc5aa634f80c37a5ec..72ea0cbd3b2b03b51886ad0e35dba004b62cc2b9 100644 (file)
@@ -127,7 +127,7 @@ it on BCM4708 family.
  /*
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1873,6 +1873,7 @@ struct xhci_hcd {
+@@ -1874,6 +1874,7 @@ struct xhci_hcd {
  #define XHCI_DEFAULT_PM_RUNTIME_ALLOW BIT_ULL(33)
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
index 58cccfff5e52987816d9b8a60164978bf88f3117..ffe429929b9e0319776bb81344aeb641ebdb39d5 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
                        retval = xhci_enter_test_mode(xhci, test_mode, wIndex,
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -3592,6 +3592,129 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
+@@ -3624,6 +3624,129 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
        return 0;
  }
  
@@ -184,7 +184,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
  void xhci_init_driver(struct hc_driver *drv,
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -2150,6 +2150,16 @@ int xhci_find_raw_port_number(struct usb
+@@ -2151,6 +2151,16 @@ int xhci_find_raw_port_number(struct usb
  struct xhci_hub *xhci_get_rhub(struct usb_hcd *hcd);
  
  void xhci_hc_died(struct xhci_hcd *xhci);
index 40d63994397745133127d37c459ecd5dd0ae5e83..e866bef1dfda9f225eec10986f86437fdac811da 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
        ret = xhci_handshake(&xhci->op_regs->command,
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1873,6 +1873,7 @@ struct xhci_hcd {
+@@ -1874,6 +1874,7 @@ struct xhci_hcd {
  #define XHCI_DEFAULT_PM_RUNTIME_ALLOW BIT_ULL(33)
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
index b08633eb883eaccf3120f3e66af2bd8031ecd129..637d514d76d89fee1f34a76d0279077151550194 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
 
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -2058,12 +2058,9 @@ static int process_ctrl_td(struct xhci_h
+@@ -2091,12 +2091,9 @@ static int process_ctrl_td(struct xhci_h
  
        switch (trb_comp_code) {
        case COMP_SUCCESS:
index 3f805756fac6e0929d6483aa2ec44338c7962fc2..2fc5ba3f06dfec51f0a4cadcc73f9b1981ab7af9 100644 (file)
@@ -35,7 +35,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
  EXPORT_SYMBOL_GPL(xhci_init_driver);
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1916,6 +1916,7 @@ struct xhci_driver_overrides {
+@@ -1917,6 +1917,7 @@ struct xhci_driver_overrides {
        int (*start)(struct usb_hcd *hcd);
        int (*check_bandwidth)(struct usb_hcd *, struct usb_device *);
        void (*reset_bandwidth)(struct usb_hcd *, struct usb_device *);
index e444af408a84a4e4ee0ea17d474d72a3fe4282ea..e02f08579cfc91d14fdd6d5a3d6771ddbe67360c 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Li Jun <jun.li@freescale.com>
 
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -4731,7 +4731,8 @@ hub_port_init(struct usb_hub *hub, struc
+@@ -4779,7 +4779,8 @@ hub_port_init(struct usb_hub *hub, struc
                        }
                        if (r) {
                                if (r != -ENODEV)
index fd64f2f10bcc394f4b35e7f8b2e608c2b50df6c9..00034e38f347151b17ac52845e2415fc533d3560 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Li Jun <jun.li@nxp.com>
 
 --- a/drivers/usb/host/xhci-hub.c
 +++ b/drivers/usb/host/xhci-hub.c
-@@ -1737,7 +1737,8 @@ static bool xhci_port_missing_cas_quirk(
+@@ -1738,7 +1738,8 @@ static bool xhci_port_missing_cas_quirk(
                return false;
  
        if (((portsc & PORT_PLS_MASK) != XDEV_POLLING) &&
index 086fc0ab967c37297fb9877a90efc65c51949293..1c51ca5841baa967d5a7054b03728bb85f2e3324 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
  #include <linux/platform_data/x86/apple.h>
  #include <linux/pm_runtime.h>
  #include <linux/suspend.h>
-@@ -5725,3 +5726,34 @@ static void apex_pci_fixup_class(struct
+@@ -5727,3 +5728,34 @@ static void apex_pci_fixup_class(struct
  }
  DECLARE_PCI_FIXUP_CLASS_HEADER(0x1ac1, 0x089a,
                               PCI_CLASS_NOT_DEFINED, 8, apex_pci_fixup_class);