ramips: add support for Beeline SmartBox GIGA
authorMikhail Zhilkin <csharper2005@gmail.com>
Fri, 18 Mar 2022 18:09:45 +0000 (18:09 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 3 Jul 2022 18:25:38 +0000 (20:25 +0200)
Beeline SmartBox GIGA is a wireless WiFi 5 router manufactured by
Sercomm company.

Device specification
--------------------
SoC Type: MediaTek MT7621AT
RAM: 256 MiB, Nanya NT5CC128M16JR-EK
Flash: 128 MiB, Macronix MX30LF1G18AC
Wireless 2.4 GHz (MT7603EN): b/g/n, 2x2
Wireless 5 GHz (MT7613BE): a/n/ac, 2x2
Ethernet: 3 ports - 2xGbE (WAN, LAN1), 1xFE (LAN2)
USB ports: 1xUSB3.0
Button: 1 button (Reset/WPS)
PCB ID: DBE00B-1.6MM
LEDs: 1 RGB LED
Power: 12 VDC, 1.5 A
Connector type: barrel
Bootloader: U-Boot

Installation
-----------------
1. Downgrade stock (Beeline) firmware to v.1.0.02;
2. Give factory OpenWrt image a shorter name, e.g. 1001.img;
3. Upload and update the firmware via the original web interface.

Remark: You might need make the 3rd step twice if your running firmware
is booted from the Slot 1 (Sercomm0 bootflag). The stock firmware
reverses the bootflag (Sercomm0 / Sercomm1) on each firmware update.

Revert to stock
---------------
1. Change the bootflag to Sercomm1 in OpenWrt CLI and then reboot:
      printf 1 | dd bs=1 seek=7 count=1 of=/dev/mtdblock3
2. Optional: Update with any stock (Beeline) firmware if you want to
   overwrite OpenWrt in Slot 0 completely.

MAC Addresses
-------------
+-----+-----------+---------+
| use | address   | example |
+-----+-----------+---------+
| LAN | label     | *:16    |
| WAN | label + 1 | *:17    |
| 2g  | label + 4 | *:1a    |
| 5g  | label + 5 | *:1b    |
+-----+-----------+---------+
The label MAC address was found in Factory 0x21000

Notes
-----
1. The following scripts are required for the build:
      sercomm-crypto.py - already exists in OpenWrt
      sercomm-partition-tag.py - already exists in OpenWrt
      sercomm-payload.py - already exists in OpenWrt
      sercomm-pid.py - new, the part of this pull request
      sercomm-kernel-header.py - new, the part of this pull request
2. This device (same as other Sercomm S2,S3-based devices) requires
   special LZMA and LOADADDR settings for successful boot:
      LZMA_TEXT_START=0x82800000
      KERNEL_LOADADDR=0x81001000
      LOADADDR=0x80001000
3. This device (same as several other Sercomm-based devices - Beeline,
   Netgear, Etisalat, Rostelecom) has partition map (mtd1) containing
   real partition offsets, which may differ from device to device
   depending on the number and location of bad blocks on NAND.
   "fixed-partitions" is used if the partition map is not found or
   corrupted. This behavour (it's the same as on stock firmware) is
   provided by MTD_SERCOMM_PARTS module.

Signed-off-by: Mikhail Zhilkin <csharper2005@gmail.com>
package/boot/uboot-envtools/files/ramips
target/linux/ramips/dts/mt7621_beeline_smartbox-giga.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/image/common-sercomm.mk [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
target/linux/ramips/mt7621/base-files/etc/board.d/02_network
target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
target/linux/ramips/mt7621/config-5.10
target/linux/ramips/mt7621/config-5.15

index eebc08d65d352a7fa8c993e64dd4f6511aa15e22..2034749832cb497158e0535ce420bb4a968a8169 100644 (file)
@@ -31,6 +31,9 @@ ampedwireless,ally-00x19k|\
 ampedwireless,ally-r1900k)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x1000" "0x20000" "4"
        ;;
+beeline,smartbox-giga)
+       ubootenv_add_uci_config "/dev/mtd0" "0x80000" "0x1000" "0x20000"
+       ;;
 buffalo,wsr-1166dhp|\
 buffalo,wsr-600dhp|\
 mediatek,linkit-smart-7688|\
diff --git a/target/linux/ramips/dts/mt7621_beeline_smartbox-giga.dts b/target/linux/ramips/dts/mt7621_beeline_smartbox-giga.dts
new file mode 100644 (file)
index 0000000..efea79e
--- /dev/null
@@ -0,0 +1,237 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/leds/common.h>
+
+/ {
+       compatible = "beeline,smartbox-giga", "mediatek,mt7621-soc";
+       model = "Beeline SmartBox GIGA";
+
+       aliases {
+               label-mac-device = &gmac0;
+
+               led-boot = &led_status_green;
+               led-failsafe = &led_status_red;
+               led-running = &led_status_green;
+               led-upgrade = &led_status_red;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status_green: led-0 {
+                       label = "green:status";
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_STATUS;
+                       gpios = <&gpio 13 GPIO_ACTIVE_HIGH>;
+               };
+
+               led-1 {
+                       label = "blue:wan";
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_WAN;
+                       gpios = <&gpio 14 GPIO_ACTIVE_HIGH>;
+               };
+
+               led_status_red: led-2 {
+                       label = "red:status";
+                       color = <LED_COLOR_ID_RED>;
+                       function = LED_FUNCTION_STATUS;
+                       gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       ubi-concat {
+               compatible = "mtd-concat";
+               devices = <&ubiconcat0 &ubiconcat1 &ubiconcat2 \
+                       &ubiconcat3>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "ubi";
+                               reg = <0x0 0x5400000>;
+                       };
+               };
+       };
+};
+
+&nand {
+       status = "okay";
+
+       partitions {
+               compatible = "sercomm,sc-partitions", "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x100000>;
+                       sercomm,scpart-id = <0>;
+                       read-only;
+               };
+
+               partition@100000 {
+                       label = "dynamic partition map";
+                       reg = <0x100000 0x100000>;
+                       sercomm,scpart-id = <1>;
+               };
+
+               factory: partition@200000 {
+                       label = "Factory";
+                       reg = <0x200000 0x100000>;
+                       sercomm,scpart-id = <2>;
+                       read-only;
+
+                       compatible = "nvmem-cells";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       macaddr_factory_21000: macaddr@21000 {
+                               reg = <0x21000 0x6>;
+                       };
+               };
+
+               partition@300000 {
+                       label = "Boot Flag";
+                       reg = <0x300000 0x100000>;
+                       sercomm,scpart-id = <3>;
+               };
+
+               partition@400000 {
+                       label = "kernel";
+                       reg = <0x400000 0x600000>;
+                       sercomm,scpart-id = <4>;
+               };
+
+               partition@a00000 {
+                       label = "Kernel 2";
+                       reg = <0xa00000 0x600000>;
+                       sercomm,scpart-id = <5>;
+                       read-only;
+               };
+
+               ubiconcat0: partition@1000000 {
+                       label = "File System 1";
+                       reg = <0x1000000 0x1800000>;
+                       sercomm,scpart-id = <6>;
+               };
+
+               partition@2800000 {
+                       label = "File System 2";
+                       reg = <0x2800000 0x1800000>;
+                       sercomm,scpart-id = <7>;
+                       read-only;
+               };
+
+               ubiconcat1: partition@4000000 {
+                       label = "Configuration/log";
+                       reg = <0x4000000 0x800000>;
+                       sercomm,scpart-id = <8>;
+               };
+
+               ubiconcat2: partition@4800000 {
+                       label = "application tmp buffer (Ftool)";
+                       reg = <0x4800000 0xc00000>;
+                       sercomm,scpart-id = <9>;
+               };
+
+               ubiconcat3: partition@5400000 {
+                       label = "container";
+                       reg = <0x5400000 0x2800000>;
+                       sercomm,scpart-id = <10>;
+               };
+
+               partition@7c00000 {
+                       label = "bad block reserved";
+                       reg = <0x7c00000 0x380000>;
+                       sercomm,scpart-id = <11>;
+                       read-only;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+
+               nvmem-cells = <&macaddr_factory_21000>;
+               nvmem-cell-names = "mac-address";
+               mac-address-increment = <(5)>;
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0>;
+               ieee80211-freq-limit = <2400000 2500000>;
+
+               nvmem-cells = <&macaddr_factory_21000>;
+               nvmem-cell-names = "mac-address";
+               mac-address-increment = <(4)>;
+       };
+};
+
+&gmac0 {
+       nvmem-cells = <&macaddr_factory_21000>;
+       nvmem-cell-names = "mac-address";
+};
+
+&switch0 {
+       ports {
+               port@0 {
+                       status = "okay";
+                       label = "wan";
+
+                       nvmem-cells = <&macaddr_factory_21000>;
+                       nvmem-cell-names = "mac-address";
+                       mac-address-increment = <(1)>;
+               };
+
+               port@1 {
+                       status = "okay";
+                       label = "lan1";
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan2";
+               };
+       };
+};
+
+&uartlite3 {
+       status = "okay";
+};
+
+&state_default {
+       gpio {
+               groups = "i2c", "jtag";
+               function = "gpio";
+       };
+};
index f481e6e447599b630dddd0c2ae0b837e3e0d36dd..d48b22023115ea79f4f9e9d788389aa0204b1095 100644 (file)
@@ -5,7 +5,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-DEVICE_VARS += LOADER_TYPE LOADER_FLASH_OFFS
+DEVICE_VARS += LOADER_TYPE LOADER_FLASH_OFFS LZMA_TEXT_START
 DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
 DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
 DEVICE_VARS += SEAMA_SIGNATURE SEAMA_MTDBLOCK
@@ -22,6 +22,7 @@ ldrplatform-$(CONFIG_TARGET_ramips_mt7621) := mt7621
 ldrflashstart-y := 0x1c000000
 ldrflashstart-$(CONFIG_TARGET_ramips_mt7621) := 0x1fc00000
 
+LOADADDR := $(loadaddr-y)
 LOADER_PLATFORM := $(ldrplatform-y)
 LOADER_FLASH_START := $(ldrflashstart-y)
 
@@ -45,7 +46,8 @@ define Build/loader-common
                PKG_BUILD_DIR="$@.src" \
                TARGET_DIR="$(dir $@)" LOADER_NAME="$(notdir $@)" \
                BOARD="$(BOARDNAME)" PLATFORM="$(LOADER_PLATFORM)" \
-               LZMA_TEXT_START=0x81800000 LOADADDR=$(KERNEL_LOADADDR) \
+               LZMA_TEXT_START=$(LZMA_TEXT_START) \
+               LOADADDR=$(LOADADDR) \
                $(1) compile loader.$(LOADER_TYPE)
        mv "$@.$(LOADER_TYPE)" "$@"
        rm -rf $@.src
@@ -176,6 +178,7 @@ define Device/Default
   PROFILES = Default
   KERNEL := $(KERNEL_DTB) | uImage lzma
   KERNEL_LOADADDR := $(loadaddr-y)
+  LZMA_TEXT_START := 0x81800000
   SOC := $(DEFAULT_SOC)
   DEVICE_DTS_DIR := ../dts
   DEVICE_DTS = $$(SOC)_$(1)
diff --git a/target/linux/ramips/image/common-sercomm.mk b/target/linux/ramips/image/common-sercomm.mk
new file mode 100644 (file)
index 0000000..e96cba8
--- /dev/null
@@ -0,0 +1,87 @@
+DEVICE_VARS += SERCOMM_KERNEL_OFFSET SERCOMM_ROOTFS_OFFSET
+
+define Build/sercomm-crypto
+       $(TOPDIR)/scripts/sercomm-crypto.py \
+               --input-file $@ \
+               --key-file $@.key \
+               --output-file $@.ser \
+               --version $(SERCOMM_SWVER)
+       $(STAGING_DIR_HOST)/bin/openssl enc -md md5 -aes-256-cbc \
+               -in $@ \
+               -out $@.enc \
+               -K `cat $@.key` \
+               -iv 00000000000000000000000000000000
+       dd if=$@.enc >> $@.ser 2>/dev/null
+       mv $@.ser $@
+       rm -f $@.enc $@.key
+endef
+
+define Build/sercomm-kernel
+       $(TOPDIR)/scripts/sercomm-kernel-header.py \
+               --kernel-image $@ \
+               --kernel-offset $(SERCOMM_KERNEL_OFFSET) \
+               --rootfs-offset $(SERCOMM_ROOTFS_OFFSET) \
+               --output-header $@.hdr
+       dd if=$@ >> $@.hdr 2>/dev/null
+       mv $@.hdr $@
+endef
+
+define Build/sercomm-part-tag
+       $(call Build/sercomm-part-tag-common,$(word 1,$(1)) $@)
+endef
+
+define Build/sercomm-part-tag-common
+       $(eval file=$(word 2,$(1)))
+       $(TOPDIR)/scripts/sercomm-partition-tag.py \
+               --input-file $(file) \
+               --output-file $(file).tmp \
+               --part-name $(word 1,$(1)) \
+               --part-version $(SERCOMM_SWVER)
+       mv $(file).tmp $(file)
+endef
+
+define Build/sercomm-payload
+       $(TOPDIR)/scripts/sercomm-pid.py \
+               --hw-version $(SERCOMM_HWVER) \
+               --hw-id $(SERCOMM_HWID) \
+               --sw-version $(SERCOMM_SWVER) \
+               --pid-file $@.pid \
+               --extra-padding-size 0x10 \
+               --extra-padding-first-byte 0x0a
+       $(TOPDIR)/scripts/sercomm-payload.py \
+               --input-file $@ \
+               --output-file $@.tmp \
+               --pid "$$(cat $@.pid | od -t x1 -An -v | tr -d '\n')"
+       mv $@.tmp $@
+       rm $@.pid
+endef
+
+define Build/sercomm-prepend-tagged-kernel
+       $(CP) $(IMAGE_KERNEL) $(IMAGE_KERNEL).tagged
+       $(call Build/sercomm-part-tag-common,$(word 1,$(1)) \
+               $(IMAGE_KERNEL).tagged)
+       dd if=$@ >> $(IMAGE_KERNEL).tagged 2>/dev/null
+       mv $(IMAGE_KERNEL).tagged $@
+endef
+
+define Device/sercomm_dxx
+  $(Device/dsa-migration)
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  KERNEL_SIZE := 6144k
+  UBINIZE_OPTS := -E 5
+  LOADER_TYPE := bin
+  KERNEL_LOADADDR := 0x81001000
+  LZMA_TEXT_START := 0x82800000
+  KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | lzma -a0 | \
+       uImage lzma | sercomm-kernel
+  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel | \
+       lzma -a0 | uImage lzma
+  IMAGES += factory.img
+  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+  IMAGE/factory.img := append-ubi | sercomm-part-tag rootfs | \
+       sercomm-prepend-tagged-kernel kernel | gzip | sercomm-payload | \
+       sercomm-crypto
+  SERCOMM_KERNEL_OFFSET := 0x400100
+  SERCOMM_ROOTFS_OFFSET := 0x1000000
+endef
index aa7adeee605afca2700e69ccfbdbde565e7eff34..f79ba5fb5a49aa5cd4c429fcc0fac649c5c6dade 100644 (file)
@@ -2,6 +2,7 @@
 # MT7621 Profiles
 #
 
+include ./common-sercomm.mk
 include ./common-tp-link.mk
 
 DEFAULT_SOC := mt7621
@@ -285,6 +286,19 @@ define Device/beeline_smartbox-flash
 endef
 TARGET_DEVICES += beeline_smartbox-flash
 
+define Device/beeline_smartbox-giga
+  $(Device/sercomm_dxx)
+  IMAGE_SIZE := 24576k
+  SERCOMM_HWID := DBE
+  SERCOMM_HWVER := 10100
+  SERCOMM_SWVER := 1001
+  DEVICE_VENDOR := Beeline
+  DEVICE_MODEL := SmartBox GIGA
+  DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
+       kmod-usb3 uboot-envtools
+endef
+TARGET_DEVICES += beeline_smartbox-giga
+
 define Device/buffalo_wsr-1166dhp
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)
index 37207a52d360bd1d35079aac154eca0f9f871701..0caa23feacc67c59509595e88ca17242a455babf 100644 (file)
@@ -23,7 +23,8 @@ asus,rt-n56u-b1)
        ucidef_set_led_netdev "lan" "LAN link" "blue:lan" "br-lan"
        ucidef_set_led_netdev "wan" "WAN link" "blue:wan" "wan"
        ;;
-beeline,smartbox-flash)
+beeline,smartbox-flash|\
+beeline,smartbox-giga)
        ucidef_set_led_netdev "wan" "wan" "blue:wan" "wan"
        ;;
 cudy,wr2100)
index 29336bad680363f60bfea4e602f1921e792067ad..8abee198a5ba8b1b8c10b6274f7f34cfd3e4d054 100644 (file)
@@ -42,6 +42,7 @@ ramips_setup_interfaces()
                ;;
        asiarf,ap7621-nv1|\
        beeline,smartbox-flash|\
+       beeline,smartbox-giga|\
        glinet,gl-mt1300|\
        iptime,a3002mesh|\
        jcg,q20|\
index b4dc34fbecc3d95785e6d3575cdcdd15c0f6bbce..7d44fcf90f0df2560d6b4a0c37bedb60c3f39edb 100755 (executable)
@@ -55,6 +55,7 @@ platform_do_upgrade() {
        asus,rt-ac85p|\
        asus,rt-ax53u|\
        beeline,smartbox-flash|\
+       beeline,smartbox-giga|\
        dlink,dir-1960-a1|\
        dlink,dir-2640-a1|\
        dlink,dir-2660-a1|\
index 804dbe3edbbf0d941213a775df70586b6af21d42..182da755cf2b7c57951a7d71dc6ccbede463c834 100644 (file)
@@ -162,6 +162,7 @@ CONFIG_MTD_NAND_MTK_BMT=y
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MTD_RAW_NAND=y
 CONFIG_MTD_ROUTERBOOT_PARTS=y
+CONFIG_MTD_SERCOMM_PARTS=y
 CONFIG_MTD_SPI_NOR=y
 CONFIG_MTD_SPI_NOR_USE_VARIABLE_ERASE=y
 CONFIG_MTD_SPLIT_FIT_FW=y
index 02d934e11b07b212703ccbbe6df7928d602f4742..3072a5177eebcf930fad6651114f169bdadc5955 100644 (file)
@@ -169,6 +169,7 @@ CONFIG_MTD_NAND_MTK_BMT=y
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MTD_RAW_NAND=y
 CONFIG_MTD_ROUTERBOOT_PARTS=y
+CONFIG_MTD_SERCOMM_PARTS=y
 CONFIG_MTD_SPI_NOR=y
 CONFIG_MTD_SPI_NOR_USE_VARIABLE_ERASE=y
 CONFIG_MTD_SPLIT_FIT_FW=y