Convert kismet to new packaging style
authorNicolas Thill <nico@openwrt.org>
Sun, 15 May 2005 13:36:31 +0000 (13:36 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 15 May 2005 13:36:31 +0000 (13:36 +0000)
SVN-Revision: 910

openwrt/package/kismet/Config.in
openwrt/package/kismet/Makefile
openwrt/package/kismet/ipkg/kismet-client.conffiles [new file with mode: 0644]
openwrt/package/kismet/ipkg/kismet-client.control [new file with mode: 0644]
openwrt/package/kismet/ipkg/kismet-drone.conffiles [new file with mode: 0644]
openwrt/package/kismet/ipkg/kismet-drone.control [new file with mode: 0644]
openwrt/package/kismet/ipkg/kismet-server.conffiles [new file with mode: 0644]
openwrt/package/kismet/ipkg/kismet-server.control [new file with mode: 0644]
openwrt/package/kismet/kismet-client.control [deleted file]
openwrt/package/kismet/kismet-drone.control [deleted file]
openwrt/package/kismet/kismet-server.control [deleted file]

index ca8fe0a16c1353a8526a211bb22bd38d42fba223..02e212abc94410757c3696179c086d4118555b91 100644 (file)
@@ -1,30 +1,29 @@
 config BR2_PACKAGE_KISMET
-       tristate
-       depends BR2_PACKAGE_SERVER || BR2_PACKAGE_CLIENT || BR2_PACKAGE_DRONE
+       bool "kismet - an 802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
+       default y if CONFIG_DEVEL
        select BR2_PACKAGE_LIBPCAP
        select BR2_PACKAGE_UCLIBCXX
        default n
-
-config BR2_PACKAGE_KISMET_SERVER
-       tristate "Kismet server"
-       select BR2_PACKAGE_KISMET
-       default m if CONFIG_DEVEL
        help
-         The Kismet server
+         An 802.11 layer2 wireless network detector, sniffer, and intrusion detection system.
+         
+         http://www.kismetwireless.net/
+         
+         Depends: libpcap, uClibc++
+         
 
 config BR2_PACKAGE_KISMET_CLIENT
-       tristate "Kismet client"
-       select BR2_PACKAGE_KISMET
+       tristate "kismet-client - the Kismet client"
        default m if CONFIG_DEVEL
-       help
-         The Kismet client
+       depends BR2_PACKAGE_KISMET
 
 config BR2_PACKAGE_KISMET_DRONE
-       tristate "Kismet drone"
-       select BR2_PACKAGE_KISMET
+       tristate "kismet-drone - the Kismet drone"
        default m if CONFIG_DEVEL
-       help
-         The Kismet drone
-
+       depends BR2_PACKAGE_KISMET
 
+config BR2_PACKAGE_KISMET_SERVER
+       tristate "kismet-server - the Kismet server"
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_KISMET
 
index 7675b90b331881cd22651c10763f1c790c640ed1..3f6aa6b4fcec47caeb8f88a31c8e4d7fdf78ad93 100644 (file)
@@ -12,143 +12,79 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-IPKG_SERVER:=$(PACKAGE_DIR)/$(PKG_NAME)-server_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-IDIR_SERVER:=$(PKG_BUILD_DIR)/ipkg/$(PKG_NAME)-server
-INFO_SERVER:=$(IPKG_STATE_DIR)/info/$(PKG_NAME)-server.list
+include $(TOPDIR)/package/rules.mk
 
-IPKG_DRONE:=$(PACKAGE_DIR)/$(PKG_NAME)-drone_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-IDIR_DRONE:=$(PKG_BUILD_DIR)/ipkg/$(PKG_NAME)-drone
-INFO_DRONE:=$(IPKG_STATE_DIR)/info/$(PKG_NAME)-drone.list
+$(eval $(call PKG_template,KISMET_CLIENT,kismet-client,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,KISMET_DRONE,kismet-drone,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,KISMET_SERVER,kismet-server,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-IPKG_CLIENT:=$(PACKAGE_DIR)/$(PKG_NAME)-client_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-IDIR_CLIENT:=$(PKG_BUILD_DIR)/ipkg/$(PKG_NAME)-client
-INFO_CLIENT:=$(IPKG_STATE_DIR)/info/$(PKG_NAME)-client.list
-
-COMPILE_TARGETS:=
-INSTALL_TARGETS:=
-ifneq ($(BR2_PACKAGE_KISMET_SERVER),)
-COMPILE_TARGETS+=$(IPKG_SERVER)
-endif
-ifeq ($(BR2_PACLAGE_KISMET_SERVER),y)
-INSTALL_TARGETS+=$(INFO_SERVER)
-endif
-ifneq ($(BR2_PACKAGE_KISMET_CLIENT),)
-COMPILE_TARGETS+=$(IPKG_CLIENT)
-endif
-ifeq ($(BR2_PACLAGE_KISMET_CLIENT),y)
-INSTALL_TARGETS+=$(INFO_CLIENT)
-endif
-ifneq ($(BR2_PACKAGE_KISMET_DRONE),)
-COMPILE_TARGETS+=$(IPKG_DRONE)
-endif
-ifeq ($(BR2_PACLAGE_KISMET_DRONE),y)
-INSTALL_TARGETS+=$(INFO_DRONE)
-endif
-
-
-
-$(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
-
-$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(PATCH) $(PKG_BUILD_DIR) ./patches
-       touch $(PKG_BUILD_DIR)/.prepared
-
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)"  \
                CXXFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include  -fno-builtin -nostdinc++ -nodefaultlibs"  \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(LINUX_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --program-prefix="" \
-               --program-suffix="" \
-               --prefix=/usr \
-               --exec-prefix=/usr \
-               --bindir=/usr/bin \
-               --datadir=/usr/share \
-               --includedir=/usr/include \
-               --infodir=/usr/share/info \
-               --libdir=/usr/lib \
-               --libexecdir=/usr/lib \
-               --localstatedir=/var \
-               --mandir=/usr/share/man \
-               --sbindir=/usr/sbin \
-               --sysconfdir=/etc \
-               --enable-syspcap=yes \
-               --disable-wsp100 \
-               $(DISABLE_NLS) \
-               $(DISABLE_LARGEFILE) \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-syspcap=yes \
+                 --disable-wsp100 \
        );
        touch $(PKG_BUILD_DIR)/.configured
 
-$(PKG_BUILD_DIR)/kismet_server $(PKG_BUILD_DIR)/kismet_drone $(PKG_BUILD_DIR)/kismet_client: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC=$(TARGET_CC) \
                LIBS="-L$(STAGING_DIR)/lib -fno-builtin -nostdinc++ -nodefaultlibs -luClibc++ -lc -lm" \
                CPPFLAGS="-I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include -I$(LINUX_DIR)/include" 
+       touch $(PKG_BUILD_DIR)/.built
+
+$(IPKG_KISMET_CLIENT):
+       install -d -m0755 $(IDIR_KISMET_CLIENT)/etc
+       install -m0644 ./files/ap_manuf $(IDIR_KISMET_CLIENT)/etc/
+       install -m0644 ./files/client_manuf $(IDIR_KISMET_CLIENT)/etc/
+       install -m0644 ./files/kismet.conf $(IDIR_KISMET_CLIENT)/etc/
+       install -m0644 ./files/kismet_ui.conf $(IDIR_KISMET_CLIENT)/etc/
+       install -d -m0755 $(IDIR_KISMET_CLIENT)/usr/sbin
+       cp -fpR $(PKG_BUILD_DIR)/kismet_client $(IDIR_KISMET_CLIENT)/usr/sbin/
+       $(RSTRIP) $(IDIR_KISMET_CLIENT)
+       $(IPKG_BUILD) $(IDIR_KISMET_CLIENT) $(PACKAGE_DIR)
+
+$(IPKG_KISMET_DRONE):
+       install -d -m0755 $(IDIR_KISMET_DRONE)/etc
+       install -m0644 ./files/kismet_drone.conf $(IDIR_KISMET_DRONE)/etc/
+       install -d -m0755 $(IDIR_KISMET_DRONE)/usr/sbin
+       cp -fpR $(PKG_BUILD_DIR)/kismet_drone $(IDIR_KISMET_DRONE)/usr/sbin/
+       $(RSTRIP) $(IDIR_KISMET_DRONE)
+       $(IPKG_BUILD) $(IDIR_KISMET_DRONE) $(PACKAGE_DIR)
+
+$(IPKG_KISMET_SERVER):
+       install -d -m0755 $(IDIR_KISMET_SERVER)/etc
+       install -m0644 ./files/ap_manuf $(IDIR_KISMET_SERVER)/etc/
+       install -m0644 ./files/client_manuf $(IDIR_KISMET_SERVER)/etc/
+       install -m0644 ./files/kismet.conf $(IDIR_KISMET_SERVER)/etc/
+       mkdir -p $(IDIR_KISMET_SERVER)/usr/sbin
+       cp -fpR  $(PKG_BUILD_DIR)/kismet_server $(IDIR_KISMET_SERVER)/usr/sbin/
+       $(RSTRIP) $(IDIR_KISMET_SERVER)
+       $(IPKG_BUILD) $(IDIR_KISMET_SERVER) $(PACKAGE_DIR)
 
-$(IPKG_SERVER): $(PKG_BUILD_DIR)/kismet_server
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_SERVER) kismet-server.control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(IDIR_SERVER)/etc
-       cp ./files/ap_manuf $(IDIR_SERVER)/etc/
-       cp ./files/client_manuf $(IDIR_SERVER)/etc/
-       cp ./files/kismet.conf $(IDIR_SERVER)/etc/
-       echo '/etc/kismet.conf' > $(IDIR_SERVER)/CONTROL/conffiles
-       echo '/etc/ap_manuf' >> $(IDIR_SERVER)/CONTROL/conffiles
-       echo '/etc/client_manuf' >> $(IDIR_SERVER)/CONTROL/conffiles
-       mkdir -p $(IDIR_SERVER)/usr/sbin
-       cp $< $(IDIR_SERVER)/usr/sbin/
-       $(STRIP) $(IDIR_SERVER)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
-       $(IPKG_BUILD) $(IDIR_SERVER) $(PACKAGE_DIR)
-
-$(INFO_SERVER): $(IPKG_SERVER)
-       $(IPKG) install $(IPKG_SERVER)
-
-$(IPKG_DRONE): $(PKG_BUILD_DIR)/kismet_drone
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_DRONE) kismet-drone.control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(IDIR_DRONE)/etc
-       cp ./files/kismet_drone.conf $(IDIR_DRONE)/etc/
-       echo '/etc/kismet_drone.conf' > $(IDIR_DRONE)/CONTROL/conffiles
-       mkdir -p $(IDIR_DRONE)/usr/sbin
-       cp $< $(IDIR_DRONE)/usr/sbin/
-       $(STRIP) $(IDIR_DRONE)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
-       $(IPKG_BUILD) $(IDIR_DRONE) $(PACKAGE_DIR)
-
-$(INFO_DRONE): $(IPKG_DRONE)
-       $(IPKG) install $(IPKG_DRONE)
-
-$(IPKG_CLIENT): $(PKG_BUILD_DIR)/kismet_client
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_CLIENT) kismet-client.control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(IDIR_CLIENT)/etc
-       cp ./files/ap_manuf $(IDIR_CLIENT)/etc/
-       cp ./files/client_manuf $(IDIR_CLIENT)/etc/
-       cp ./files/kismet.conf $(IDIR_CLIENT)/etc/
-       cp ./files/kismet_ui.conf $(IDIR_CLIENT)/etc/
-       echo '/etc/kismet.conf' > $(IDIR_CLIENT)/CONTROL/conffiles
-       echo '/etc/kismet_ui.conf' >> $(IDIR_CLIENT)/CONTROL/conffiles
-       echo '/etc/ap_manuf' >> $(IDIR_CLIENT)/CONTROL/conffiles
-       echo '/etc/client_manuf' >> $(IDIR_CLIENT)/CONTROL/conffiles
-       mkdir -p $(IDIR_CLIENT)/usr/sbin
-       cp $< $(IDIR_CLIENT)/usr/sbin/
-       $(STRIP) $(IDIR_CLIENT)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
-       $(IPKG_BUILD) $(IDIR_CLIENT) $(PACKAGE_DIR)
-
-$(INFO_CLIENT): $(IPKG_CLIENT)
-       $(IPKG) install $(IPKG_CLIENT)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.prepared
-compile: $(COMPILE_TARGETS)
-install: $(INSTALL_TARGETS)
-
-clean:
-       rm -rf $(PKG_BUILD_DIR) $(IPKG_KISMET)
diff --git a/openwrt/package/kismet/ipkg/kismet-client.conffiles b/openwrt/package/kismet/ipkg/kismet-client.conffiles
new file mode 100644 (file)
index 0000000..5973f34
--- /dev/null
@@ -0,0 +1,4 @@
+/etc/ap_manuf
+/etc/client_manuf
+/etc/kismet.conf
+/etc/kismet_ui.conf
\ No newline at end of file
diff --git a/openwrt/package/kismet/ipkg/kismet-client.control b/openwrt/package/kismet/ipkg/kismet-client.control
new file mode 100644 (file)
index 0000000..2e4c7fc
--- /dev/null
@@ -0,0 +1,11 @@
+Package: kismet-client
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Depends: uclibc++, libncurses
+Description: The kismet client
+ Kismet is an 802.11 layer2 wireless network detector,
+ sniffer, and intrusion detection system. Kismet will work with any
+ wireless card which supports raw monitoring (rfmon) mode, and can
+ sniff 802.11b, 802.11a, and 802.11g traffic. 
diff --git a/openwrt/package/kismet/ipkg/kismet-drone.conffiles b/openwrt/package/kismet/ipkg/kismet-drone.conffiles
new file mode 100644 (file)
index 0000000..2814f81
--- /dev/null
@@ -0,0 +1 @@
+/etc/kismet_drone.conf
diff --git a/openwrt/package/kismet/ipkg/kismet-drone.control b/openwrt/package/kismet/ipkg/kismet-drone.control
new file mode 100644 (file)
index 0000000..53c9ea5
--- /dev/null
@@ -0,0 +1,11 @@
+Package: kismet-drone
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Depends: uclibc++, libpcap
+Description: The kismet drone
+ Kismet is an 802.11 layer2 wireless network detector,
+ sniffer, and intrusion detection system. Kismet will work with any
+ wireless card which supports raw monitoring (rfmon) mode, and can
+ sniff 802.11b, 802.11a, and 802.11g traffic. 
diff --git a/openwrt/package/kismet/ipkg/kismet-server.conffiles b/openwrt/package/kismet/ipkg/kismet-server.conffiles
new file mode 100644 (file)
index 0000000..e2c46e5
--- /dev/null
@@ -0,0 +1,3 @@
+/etc/ap_manuf
+/etc/client_manuf
+/etc/kismet.conf
diff --git a/openwrt/package/kismet/ipkg/kismet-server.control b/openwrt/package/kismet/ipkg/kismet-server.control
new file mode 100644 (file)
index 0000000..22b8e74
--- /dev/null
@@ -0,0 +1,11 @@
+Package: kismet-server
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Depends: uclibc++, libpcap
+Description: The kismet server
+ Kismet is an 802.11 layer2 wireless network detector,
+ sniffer, and intrusion detection system. Kismet will work with any
+ wireless card which supports raw monitoring (rfmon) mode, and can
+ sniff 802.11b, 802.11a, and 802.11g traffic. 
diff --git a/openwrt/package/kismet/kismet-client.control b/openwrt/package/kismet/kismet-client.control
deleted file mode 100644 (file)
index 2e4c7fc..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-Package: kismet-client
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Depends: uclibc++, libncurses
-Description: The kismet client
- Kismet is an 802.11 layer2 wireless network detector,
- sniffer, and intrusion detection system. Kismet will work with any
- wireless card which supports raw monitoring (rfmon) mode, and can
- sniff 802.11b, 802.11a, and 802.11g traffic. 
diff --git a/openwrt/package/kismet/kismet-drone.control b/openwrt/package/kismet/kismet-drone.control
deleted file mode 100644 (file)
index 53c9ea5..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-Package: kismet-drone
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Depends: uclibc++, libpcap
-Description: The kismet drone
- Kismet is an 802.11 layer2 wireless network detector,
- sniffer, and intrusion detection system. Kismet will work with any
- wireless card which supports raw monitoring (rfmon) mode, and can
- sniff 802.11b, 802.11a, and 802.11g traffic. 
diff --git a/openwrt/package/kismet/kismet-server.control b/openwrt/package/kismet/kismet-server.control
deleted file mode 100644 (file)
index 22b8e74..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-Package: kismet-server
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Depends: uclibc++, libpcap
-Description: The kismet server
- Kismet is an 802.11 layer2 wireless network detector,
- sniffer, and intrusion detection system. Kismet will work with any
- wireless card which supports raw monitoring (rfmon) mode, and can
- sniff 802.11b, 802.11a, and 802.11g traffic.