ath79: add support for Telco T1
authorNicholas Smith <nicholas.smith@telcoantennas.com.au>
Fri, 3 Jul 2020 23:09:08 +0000 (09:09 +1000)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 10 Aug 2020 10:49:29 +0000 (12:49 +0200)
Description:
    2x 100Mbps Etherent ports
    24V passive PoE
    64MB RAM
    16MB Flash
    2.4GHz WiFi
    1x WiFi antenna (RP-SMA connector)
    1x LTE antenna (SMA connector)
    Sierra Wireless MC7430 LTE modem

Flash instructions:
    Original firmware is based on OpenWrt.
    Flash using sysupgrade -n

SUPPORTED_DEVICES is added to support factory firmware.

Signed-off-by: Nicholas Smith <nicholas.smith@telcoantennas.com.au>
[add missing led_rssi0 DT label, add SUPPORTED_DEVICES]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/dts/qca9531_telco_t1.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches
target/linux/ath79/image/generic.mk

diff --git a/target/linux/ath79/dts/qca9531_telco_t1.dts b/target/linux/ath79/dts/qca9531_telco_t1.dts
new file mode 100644 (file)
index 0000000..25a97ed
--- /dev/null
@@ -0,0 +1,144 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca953x.dtsi"
+
+/ {
+       compatible = "telco,t1", "qca,qca9531";
+       model = "Telco T1";
+
+       aliases {
+               label-mac-device = &eth0;
+               led-boot = &led_rssi0;
+               led-failsafe = &led_rssi0;
+               led-running = &led_rssi0;
+               led-upgrade = &led_rssi0;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+               pinctrl-names = "default";
+               pinctrl-0 = <&jtag_disable_pins &pinmux_led_wan_pin>;
+
+               wan {
+                       label = "t1:blue:wan";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+
+               lan {
+                       label = "t1:blue:lan";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "t1:blue:wlan";
+                       gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               led_rssi0: rssi0 {
+                       label = "t1:blue:rssi0";
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+               };
+
+               rssi1 {
+                       label = "t1:blue:rssi1";
+                       gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+               };
+
+               rssi2 {
+                       label = "t1:blue:rssi2";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&usb0 {
+       status = "okay";
+};
+
+&usb_phy {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x010000>;
+                               read-only;
+                       };
+
+                       art: partition@10000 {
+                               label = "art";
+                               reg = <0x010000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x020000 0xfd0000>;
+                       };
+
+                       partition@ff0000 {
+                               label = "art-backup";
+                               reg = <0xff0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&art 0x0>;
+
+       phy-handle = <&swphy4>;
+};
+
+&eth1 {
+       mtd-mac-address = <&art 0x6>;
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+};
+
+&pinmux {
+       pinmux_led_wan_pin: led_wan_pin {
+               pinctrl-single,bits = <0x4 0x0 0xff>;
+       };
+};
index 1dff5acc38f53c2749124159263f7a0e8f695a85..4f1b76a65a2b77805b827fe16db81bb1905e68b0 100755 (executable)
@@ -106,7 +106,8 @@ comfast,cf-e560ac)
        ucidef_set_led_switch "lan3" "LAN3" "$boardname:blue:lan3" "switch0" "0x08"
        ucidef_set_led_switch "lan4" "LAN4" "$boardname:blue:lan4" "switch0" "0x10"
        ;;
-comfast,cf-ew72)
+comfast,cf-ew72|\
+telco,t1)
        ucidef_set_led_switch "lan" "LAN" "$boardname:blue:lan" "switch0" "0x02"
        ucidef_set_led_netdev "wan" "WAN" "$boardname:blue:wan" "eth1"
        ;;
index cc1b8ff41263f7c3119940c6865fe6fad5df7b47..cf30bb405a26f24edcca7684aadc3490a57fa553 100755 (executable)
@@ -25,7 +25,8 @@ adtran,bsap1840)
        ucidef_add_gpio_switch "wifi0_ext_c" "2.4GHz External Antenna C" "509" "1"
        ucidef_add_gpio_switch "wifi0_int_c" "2.4GHz Internal Antenna C" "510"
        ;;
-comfast,cf-e5)
+comfast,cf-e5|\
+telco,t1)
        ucidef_add_gpio_switch "lte_power" "LTE Power" "14" "1"
        ucidef_add_gpio_switch "lte_wakeup" "LTE Wakeup" "11" "1"
        ucidef_add_gpio_switch "lte_poweroff" "LTE Poweroff" "1" "1"
index 6b7bfb4639e9c2d2d60245613ab9b99315535b53..ee798bf321ff8ba2f6b280c54e07758578e45515 100644 (file)
@@ -1367,6 +1367,17 @@ define Device/sitecom_wlr-8100
 endef
 TARGET_DEVICES += sitecom_wlr-8100
 
+define Device/telco_t1
+  SOC := qca9531
+  DEVICE_VENDOR := Telco
+  DEVICE_MODEL := T1
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-net-qmi-wwan \
+       kmod-usb-serial-option uqmi -swconfig -uboot-envtools
+  IMAGE_SIZE := 16192k
+  SUPPORTED_DEVICES += telco_electronics,tel-t1
+endef
+TARGET_DEVICES += telco_t1
+
 define Device/teltonika_rut955
   SOC := ar9344
   DEVICE_VENDOR := Teltonika