kernel-headers: install isa-rev.h on mips to fix lzma-lader on linux 6.1
authorJonas Gorski <jonas.gorski@gmail.com>
Thu, 6 Jul 2023 19:01:06 +0000 (21:01 +0200)
committerJonas Gorski <jonas.gorski@gmail.com>
Thu, 6 Jul 2023 19:03:11 +0000 (21:03 +0200)
Since kernel 5.17+ the mips asm.h includes isa-rev.h, which itself was
added 4.17. Without it, lzma-loader will fail to build:

     make[3] -C target/linux compile
    make[5]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
    In file included from head.S:22:
    .../staging_dir/toolchain-mips_mips32_gcc-12.3.0_musl/include/asm/asm.h:22:10: fatal error: asm/isa-rev.h: No such file or directory
       22 | #include <asm/isa-rev.h>
          |          ^~~~~~~~~~~~~~~
    compilation terminated.
    make[6]: *** [Makefile:64: head.o] Error 1
    make[5]: *** [Makefile:345: compile] Error 2
    make[4]: *** [Makefile:24: compile] Error 2
    make[3]: *** [Makefile:11: compile] Error 2
        ERROR: target/linux failed to build.

So add the file to the files to install. We can do that unconditionally,
since the oldest supported kernel 5.15 already includes it, even it if
does not need it.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
toolchain/kernel-headers/Makefile

index eea0ffbde0713c2175bbc5954ff029942fd2e938..c1a8710a4fbe59f9908a09127e9447a9ab0202db 100644 (file)
@@ -68,6 +68,7 @@ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
                $(HOST_BUILD_DIR)/arch/mips/include/asm/asm.h \
                $(HOST_BUILD_DIR)/arch/mips/include/asm/regdef.h \
                $(HOST_BUILD_DIR)/arch/mips/include/asm/asm-eva.h \
+               $(HOST_BUILD_DIR)/arch/mips/include/asm/isa-rev.h \
                $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/
   endef
 endif