hostapd: remove hostapd-hs20 variant
authorDaniel Golle <daniel@makrotopia.org>
Thu, 29 Oct 2020 12:50:47 +0000 (12:50 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 30 Oct 2020 00:39:09 +0000 (00:39 +0000)
Hotspot 2.0 AP features have been made available in the -full variants
of hostapd and wpad. Hence we no longer need a seperate package for
that.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/network/services/hostapd/Makefile

index f340cb1ebb9180d7ac61a7547e003cffcbf58213..c03ec6bdc4f316ac48aa8d6fba3e1d3b9b75e532 100644 (file)
@@ -68,9 +68,6 @@ CONFIG_VARIANT:=$(LOCAL_VARIANT)
 ifeq ($(LOCAL_VARIANT),mesh)
   CONFIG_VARIANT:=full
 endif
-ifeq ($(LOCAL_VARIANT),hs20)
-  CONFIG_VARIANT:=full
-endif
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -111,10 +108,6 @@ ifeq ($(SSL_VARIANT),openssl)
   ifeq ($(LOCAL_VARIANT),full)
     DRIVER_MAKEOPTS += CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y
   endif
-  ifeq ($(LOCAL_VARIANT),hs20)
-    DRIVER_MAKEOPTS += CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y CONFIG_DPP=y CONFIG_HS20=y CONFIG_INTERWORKING=y
-  endif
-
 endif
 
 ifeq ($(SSL_VARIANT),wolfssl)
@@ -175,15 +168,6 @@ endef
 
 Package/hostapd-openssl/description = $(Package/hostapd/description)
 
-define Package/hostapd-hs20
-$(call Package/hostapd/Default,$(1))
-  TITLE+= (OpenSSL with Hotspot 2.0)
-  VARIANT:=hs20-openssl
-  DEPENDS+=+libopenssl
-endef
-
-Package/hostapd-hs20/description = $(Package/hostapd/description)
-
 define Package/hostapd-wolfssl
 $(call Package/hostapd/Default,$(1))
   TITLE+= (wolfSSL full)
@@ -608,7 +592,6 @@ define Package/hostapd/install
 endef
 Package/hostapd-basic/install = $(Package/hostapd/install)
 Package/hostapd-basic-openssl/install = $(Package/hostapd/install)
-Package/hostapd-hs20/install = $(Package/hostapd/install)
 Package/hostapd-mini/install = $(Package/hostapd/install)
 Package/hostapd-openssl/install = $(Package/hostapd/install)
 Package/hostapd-wolfssl/install = $(Package/hostapd/install)
@@ -679,7 +662,6 @@ endif
 $(eval $(call BuildPackage,hostapd))
 $(eval $(call BuildPackage,hostapd-basic))
 $(eval $(call BuildPackage,hostapd-basic-openssl))
-$(eval $(call BuildPackage,hostapd-hs20))
 $(eval $(call BuildPackage,hostapd-mini))
 $(eval $(call BuildPackage,hostapd-openssl))
 $(eval $(call BuildPackage,hostapd-wolfssl))