image: fix build with SELinux
authorDaniel Golle <daniel@makrotopia.org>
Thu, 19 Aug 2021 00:23:41 +0000 (01:23 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 19 Aug 2021 00:37:35 +0000 (01:37 +0100)
The option '-xattr' for mksquashfs4 should be '-xattrs' which lead to
build failure with SELinux enabled. Add the missing 's'.

Fixes: 4baf47b9a8 ("images: squashfs: xattrs should not depend on buld host")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/image.mk

index d2b34d25a790ab39fdf305d3631154fae241db03..6298e3085eb9fd4e4952b4980e1d25e23d94a38b 100644 (file)
@@ -75,7 +75,7 @@ JFFS2OPTS += $(MKFS_DEVTABLE_OPT)
 SQUASHFS_BLOCKSIZE := $(CONFIG_TARGET_SQUASHFS_BLOCK_SIZE)k
 SQUASHFSOPT := -b $(SQUASHFS_BLOCKSIZE)
 SQUASHFSOPT += -p '/dev d 755 0 0' -p '/dev/console c 600 0 0 5 1'
-SQUASHFSOPT += $(if $(CONFIG_SELINUX),-xattr,-no-xattrs)
+SQUASHFSOPT += $(if $(CONFIG_SELINUX),-xattrs,-no-xattrs)
 SQUASHFSCOMP := gzip
 LZMA_XZ_OPTIONS := -Xpreset 9 -Xe -Xlc 0 -Xlp 2 -Xpb 2
 ifeq ($(CONFIG_SQUASHFS_XZ),y)