comgt: Install hotplug and netifd files as 600
authorRosen Penev <rosenp@gmail.com>
Wed, 19 Sep 2018 19:03:30 +0000 (12:03 -0700)
committerJohn Crispin <john@phrozen.org>
Thu, 11 Oct 2018 06:06:28 +0000 (08:06 +0200)
procd and netifd both run as root. These files are not used elsewhere.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/network/utils/comgt/Makefile

index 3b7f4b9022c420c3ccd7a372a9431d8afa8517b1..d4d673e783a521c4e4e0cf7874c74dcb19bc0997 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=30
+PKG_RELEASE:=31
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
@@ -80,9 +80,9 @@ define Package/comgt/install
        $(INSTALL_DATA) ./files/getcnum.gcom $(1)/etc/gcom/getcnum.gcom
        $(INSTALL_DATA) ./files/getimsi.gcom $(1)/etc/gcom/getimsi.gcom
        $(INSTALL_DIR) $(1)/etc/hotplug.d/tty
-       $(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
+       $(INSTALL_CONF) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
        $(INSTALL_DIR) $(1)/lib/netifd/proto
-       $(INSTALL_BIN) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
+       $(INSTALL_CONF) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
 endef
 
 define Package/comgt-directip/install