uboot-sunxi: add ATF variable for specifying which flavour to use
authorZoltan HERPAI <wigyori@uid0.hu>
Wed, 29 Apr 2020 09:02:27 +0000 (11:02 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Sun, 11 Apr 2021 21:14:52 +0000 (23:14 +0200)
In preparation for H6 support (which requires a separate ATF blob), add
an envvar to the A64 boards specifying which ATF blob to use.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/boot/arm-trusted-firmware-sunxi/Makefile
package/boot/uboot-sunxi/Makefile

index 0211e5e03049812e8c0ac54571763ba18e2b2e6e..ed2390a36ce12582e3cb35f2d10f9aef4bf6b64d 100644 (file)
@@ -42,7 +42,7 @@ MAKE_FLAGS += \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
-       $(CP) $(PKG_BUILD_DIR)/build/sun50i_a64/release/bl31.bin $(STAGING_DIR_IMAGE)/bl31.bin
+       $(CP) $(PKG_BUILD_DIR)/build/sun50i_a64/release/bl31.bin $(STAGING_DIR_IMAGE)/bl31_a64.bin
 endef
 
 define Package/arm-trusted-firmware-sunxi/install
index 38147339a4edd5efa5d7bad8764bcde8f52ef483..19c158e230b752259be32a266038b84323cbc875 100644 (file)
@@ -31,6 +31,7 @@ define U-Boot/a64-olinuxino
   BUILD_DEVICES:=olimex_a64-olinuxino
   DEPENDS:=+PACKAGE_u-boot-olimex_a64-olinuxino:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/a64-olinuxino-emmc
@@ -39,6 +40,7 @@ define U-Boot/a64-olinuxino-emmc
   BUILD_DEVICES:=olimex_a64-olinuxino-emmc
   DEPENDS:=+PACKAGE_u-boot-olimex_a64-olinuxino-emmc:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/A10-OLinuXino-Lime
@@ -238,6 +240,7 @@ define U-Boot/libretech_all_h3_cc_h5
   BUILD_DEVICES:=libretech_all-h3-cc-h5
   DEPENDS:=+PACKAGE_u-boot-libretech_all_h3_cc_h5:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/nanopi_neo_plus2
@@ -246,6 +249,7 @@ define U-Boot/nanopi_neo_plus2
   BUILD_DEVICES:=friendlyarm_nanopi-neo-plus2
   DEPENDS:=+PACKAGE_u-boot-nanopi_neo_plus2:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/nanopi_neo2
@@ -254,6 +258,7 @@ define U-Boot/nanopi_neo2
   BUILD_DEVICES:=friendlyarm_nanopi-neo2
   DEPENDS:=+PACKAGE_u-boot-nanopi_neo2:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/pine64_plus
@@ -262,6 +267,7 @@ define U-Boot/pine64_plus
   BUILD_DEVICES:=pine64_pine64-plus
   DEPENDS:=+PACKAGE_u-boot-pine64_plus:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/bananapi_m2_plus_h3
@@ -276,6 +282,7 @@ define U-Boot/sopine_baseboard
   BUILD_DEVICES:=pine64_sopine-baseboard
   DEPENDS:=+PACKAGE_u-boot-sopine_baseboard:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 
@@ -285,6 +292,7 @@ define U-Boot/orangepi_zero_plus
   BUILD_DEVICES:=xunlong_orangepi-zero-plus
   DEPENDS:=+PACKAGE_u-boot-orangepi_zero_plus:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/orangepi_pc2
@@ -293,6 +301,7 @@ define U-Boot/orangepi_pc2
   BUILD_DEVICES:=xunlong_orangepi-pc2
   DEPENDS:=+PACKAGE_u-boot-orangepi_pc2:arm-trusted-firmware-sunxi
   UENV:=a64
+  ATF:=a64
 endef
 
 define U-Boot/Bananapi_M2_Ultra
@@ -349,7 +358,7 @@ UBOOT_TARGETS := \
 UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
 
 UBOOT_MAKE_FLAGS += \
-       BL31=$(STAGING_DIR_IMAGE)/bl31.bin
+       BL31=$(STAGING_DIR_IMAGE)/bl31_$(ATF).bin
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)