ar71xx: switch to kmod-gpio-button-hotplug
authorFelix Fietkau <nbd@openwrt.org>
Mon, 20 Feb 2012 10:51:48 +0000 (10:51 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 20 Feb 2012 10:51:48 +0000 (10:51 +0000)
SVN-Revision: 30660

target/linux/ar71xx/Makefile
target/linux/ar71xx/base-files/lib/preinit/05_enable_reset_button_ar71xx

index 96201eeb0af1272626462029e333c8a32bdb9f5b..8e9931de0ceaf9cb3ee297d8066ee6c540bfce6f 100644 (file)
@@ -18,8 +18,7 @@ LINUX_VERSION:=3.2.5
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug swconfig \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
        kmod-ath9k wpad-mini uboot-envtools
 
 define Target/Description
index 305fe0018be7d23143cb9af292e058e75e4a68c7..317c8d15a6a2e876c485da04b63633ccbf458f39 100644 (file)
@@ -6,10 +6,7 @@
 
 
 preinit_enable_reset_button() {
-       insmod input-core
-       insmod input-polldev
-       insmod gpio_keys_polled
-       insmod button-hotplug
+       insmod gpio-button-hotplug
 }
 
 boot_hook_add preinit_main preinit_enable_reset_button