nghttp2: Fix pkgconfig file
authorRosen Penev <rosenp@gmail.com>
Sun, 3 Nov 2019 02:54:04 +0000 (19:54 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 9 Nov 2019 13:33:42 +0000 (14:33 +0100)
lib and includedir point to the host, not staging_dir.

Note that prefix and exec_prefix is overriden to point to staging_dir.

As CMAKE_INSTTALL is passed, switched InstallDev to use cmake.mk's rule.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/libs/nghttp2/Makefile

index 4fb26319adc6a83e52afe1d1bf12785b0414a167..1d364c7023425cd3ff1f8225ef04c30a61a7176e 100644 (file)
@@ -2,9 +2,9 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nghttp2
 PKG_VERSION:=1.39.2
-PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_RELEASE:=2
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/nghttp2/nghttp2/releases/download/v$(PKG_VERSION)
 PKG_HASH:=a2d216450abd2beaf4e200c168957968e89d602ca4119338b9d7ab059fd4ce8b
 
@@ -31,11 +31,9 @@ CMAKE_OPTIONS += \
         -DENABLE_LIB_ONLY=ON
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/nghttp2
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/nghttp2/*.h $(1)/usr/include/nghttp2/
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc $(1)/usr/lib/pkgconfig/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnghttp2.so* $(1)/usr/lib/
+       $(call Build/InstallDev/cmake,$(1))
+       $(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/libnghttp2.pc
+       $(SED) 's,/usr/lib,$$$${prefix}/lib,g' $(1)/usr/lib/pkgconfig/libnghttp2.pc
 endef
 
 define Package/libnghttp2/install