fstools: add direct dependencies on libblobmsg-json and libjson-c
authorPetr Štetiar <ynezz@true.cz>
Sun, 14 Jul 2019 20:10:37 +0000 (22:10 +0200)
committerPetr Štetiar <ynezz@true.cz>
Sun, 14 Jul 2019 22:38:24 +0000 (00:38 +0200)
The OpenWrt buildroot ABI version rebuild tracker does not handle
transient dependencies, therefore add all libraries linked by
block-mount and blockd as direct dependencies to the corresponding
binary package definition.

This ensures that block-mount and blockd is automatically rebuilt and
relinked if any of these libraries has its ABI_VERSION updated in the
future.

Fixes: FS#2373
[jow: similar fix for procd and 98.42% of commit message]
Signed-off-by: Jo-Philip Wich <jow@mein.io>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/system/fstools/Makefile

index 3aa250f7d4d39a7efc0cc2a81b7d2a6d77436e8c..4bc59150da9697acaede514a4a162c4d27e673f2 100644 (file)
@@ -79,14 +79,14 @@ define Package/block-mount
   SECTION:=base
   CATEGORY:=Base system
   TITLE:=Block device mounting and checking
-  DEPENDS:=+ubox +libubox +libuci
+  DEPENDS:=+ubox +libubox +libuci +libblobmsg-json +libjson-c
 endef
 
 define Package/blockd
   SECTION:=base
   CATEGORY:=Base system
   TITLE:=Block device automounting
-  DEPENDS:=+block-mount +fstools +libubus +kmod-fs-autofs4
+  DEPENDS:=+block-mount +fstools +libubus +kmod-fs-autofs4 +libblobmsg-json +libjson-c
 endef
 
 define Package/fstools/install