mac80211: use hostapd PID returned from config_add
authorDaniel Golle <daniel@makrotopia.org>
Mon, 7 Dec 2020 13:46:43 +0000 (13:46 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 10 Jan 2021 19:18:29 +0000 (19:18 +0000)
Use PID returned from config_add instead of querying procd when adding
configuration to hostapd.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/mac80211/Makefile
package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh

index 35a7651d1da497dc0a1c2aa224a003c2def0522a..e03c91e9c4a938d951f82e06a76f7e0e3051786a 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=5.8.18-1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.8.18/
 PKG_HASH:=f04a8172423c6a945fc7d9844b04f33fda9ae574e552f8f18ee3bdfcfb494563
 
index 95b6c817ffc1e397a0992c4268b5a485f4638135..7eea198cd91501a99655aabece2a9982efeca930 100644 (file)
@@ -1019,8 +1019,7 @@ drv_mac80211_setup() {
                if [ "$no_reload" != "0" ]; then
                        add_ap=1
                        ubus wait_for hostapd
-                       ubus call hostapd config_add "{\"iface\":\"$primary_ap\", \"config\":\"${hostapd_conf_file}\"}"
-                       local hostapd_pid=$(ubus call service list '{"name": "wpad"}' | jsonfilter -l 1 -e "@['wpad'].instances['hostapd'].pid")
+                       local hostapd_pid=$(ubus call hostapd config_add "{\"iface\":\"$primary_ap\", \"config\":\"${hostapd_conf_file}\"}" | jsonfilter -l 1 -e @.pid)
                        wireless_add_process "$hostapd_pid" "/usr/sbin/hostapd" 1 1
                fi
                ret="$?"