treewide: call check-size before append-metadata
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 20 Jun 2021 16:54:36 +0000 (18:54 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 10 Jul 2021 17:40:10 +0000 (19:40 +0200)
sysupgrade metadata is not flashed to the device, so check-size
should be called _before_ adding metadata to the image.

While at it, do some obvious wrapping improvements.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Acked-by: Paul Spooren <mail@aparcar.org>
23 files changed:
target/linux/ath79/image/Makefile
target/linux/ath79/image/common-mikrotik.mk
target/linux/ath79/image/common-netgear.mk
target/linux/ath79/image/common-tp-link.mk
target/linux/ath79/image/generic-tp-link.mk
target/linux/ath79/image/generic-ubnt.mk
target/linux/ath79/image/generic.mk
target/linux/ath79/image/nand.mk
target/linux/ath79/image/tiny.mk
target/linux/ipq40xx/image/generic.mk
target/linux/ipq40xx/image/mikrotik.mk
target/linux/ipq806x/image/Makefile
target/linux/lantiq/image/Makefile
target/linux/lantiq/image/ar9.mk
target/linux/lantiq/image/tp-link.mk
target/linux/lantiq/image/vr9.mk
target/linux/ramips/image/Makefile
target/linux/ramips/image/common-tp-link.mk
target/linux/ramips/image/mt7620.mk
target/linux/ramips/image/mt7621.mk
target/linux/ramips/image/rt305x.mk
target/linux/ramips/image/rt3883.mk
target/linux/realtek/image/Makefile

index aa8665fbb2bf74ec5e523d29212e7e815e7293b2..aee4ddf9632eaed7dcad81f85cceabee32c3b9d1 100644 (file)
@@ -81,7 +81,7 @@ define Device/Default
   COMPILE :=
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \
-       append-rootfs | pad-rootfs | append-metadata | check-size
+       append-rootfs | pad-rootfs | check-size | append-metadata
 endef
 
 include $(SUBTARGET).mk
index 6e739f2d85be2ef4df97228dfd3a3a714a7610c3..5f5fa7899a079737444263786a72f9794d9dcc5f 100644 (file)
@@ -9,7 +9,7 @@ define Device/mikrotik_nor
   $(Device/mikrotik)
   IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 -e | \
        pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
 endef
 
 define Device/mikrotik_nand
index 8a74fdc0c9d9fe9ac3dba625ddda707b77d4f2cc..5a61caf1f6424931361e2fc28ce0dd6aeecac8b6 100644 (file)
@@ -32,10 +32,8 @@ define Device/netgear_generic
   KERNEL := kernel-bin | append-dtb | lzma -d20 | uImage lzma
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | uImage lzma
   IMAGES += factory.img
-  IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | \
-       append-rootfs | pad-rootfs
-  IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
-       check-size
-  IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | \
-       check-size
+  IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+       netgear-squashfs | append-rootfs | pad-rootfs
+  IMAGE/sysupgrade.bin := $$(IMAGE/default) | check-size | append-metadata
+  IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | check-size
 endef
index 0b7b0e1935aee95f2bd108aec5e5aef6e764c969..f1d5614aa7561639f6b4ce977578e89b6503f023 100644 (file)
@@ -22,8 +22,7 @@ define Device/tplink-v2
   TPLINK_HVERSION := 3
   KERNEL := kernel-bin | append-dtb | lzma
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | tplink-v2-header
-  IMAGE/sysupgrade.bin := tplink-v2-image -s | append-metadata | \
-       check-size
+  IMAGE/sysupgrade.bin := tplink-v2-image -s | check-size | append-metadata
 endef
 
 define Device/tplink-nolzma
@@ -74,7 +73,7 @@ define Device/tplink-safeloader
   KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header -O
   KERNEL_INITRAMFS := $$(KERNEL)
   IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
-       append-metadata | check-size
+       check-size | append-metadata
   IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
 endef
 
index daeac8341f4bd0b390b2f1436a5e620201f83451..9c4920b4e66c5b0ce26825fd51406deccbd4e65b 100644 (file)
@@ -692,7 +692,7 @@ define Device/tplink_tl-wr2543-v1
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
   TPLINK_HWID := 0x25430001
   IMAGE/sysupgrade.bin := tplink-v1-image sysupgrade -v 3.13.99 | \
-       append-metadata | check-size
+       check-size | append-metadata
   IMAGE/factory.bin := tplink-v1-image factory -v 3.13.99
   SUPPORTED_DEVICES += tl-wr2543n
 endef
index e8ea06a07a46a411b92dca106a822cb45d71174d..01e8533fd6a258047b7d1540d3d22b74184da0df 100644 (file)
@@ -128,7 +128,7 @@ define Device/ubnt-unifi-jffs2
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | jffs2 kernel0
   IMAGES := sysupgrade.bin factory.bin
   IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs |\
-       pad-rootfs | append-metadata | check-size
+       pad-rootfs | check-size | append-metadata
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage2
 endef
 
@@ -373,7 +373,7 @@ define Device/ubnt_routerstation_common
   IMAGE/factory.bin := append-rootfs | pad-rootfs | mkubntimage | \
        check-size
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | \
-       append-metadata | check-size
+       check-size | append-metadata
   KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
   KERNEL_INITRAMFS := kernel-bin | append-dtb
 endef
index 0db9987d708a4fe8b2f17daa858a1d8afc6f2917..fbcc9d186a6b567aebebd10b1b97fa97d5c52df7 100644 (file)
@@ -172,7 +172,7 @@ define Device/seama
   # - 36 bytes of META data (4-bytes aligned)
   IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
   IMAGE/sysupgrade.bin := $$(IMAGE/default) | seama | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   IMAGE/factory.bin := $$(IMAGE/default) | pad-rootfs -x 64 | seama | \
        seama-seal | check-size
   SEAMA_SIGNATURE :=
@@ -336,7 +336,7 @@ define Device/avm
   KERNEL_INITRAMFS := $$(KERNEL)
   IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | \
        append-squashfs-fakeroot-be | pad-to 256 | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_PACKAGES := fritz-tffs
 endef
 
@@ -777,7 +777,7 @@ define Device/dlink_dap-2xxx
   IMAGE/factory.img := append-kernel | pad-offset 6144k 160 | \
        append-rootfs | wrgg-pad-rootfs | mkwrggimg | check-size
   IMAGE/sysupgrade.bin := append-kernel | mkwrggimg | \
-       pad-to $$$$(BLOCKSIZE) | append-rootfs | append-metadata | check-size
+       pad-to $$$$(BLOCKSIZE) | append-rootfs | check-size | append-metadata
   KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
   KERNEL_INITRAMFS := $$(KERNEL) | mkwrggimg
 endef
@@ -829,7 +829,7 @@ define Device/dlink_dap-2695-a1
   IMAGE/factory.img := $$(IMAGE/default) | append-rootfs | wrgg-pad-rootfs | \
        mkwrggimg | check-size
   IMAGE/sysupgrade.bin := $$(IMAGE/default) | mkwrggimg | append-rootfs | \
-       wrgg-pad-rootfs | append-metadata |  check-size
+       wrgg-pad-rootfs | check-size | append-metadata
   KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
   KERNEL_INITRAMFS := $$(KERNEL) | mkwrggimg
   DAP_SIGNATURE := wapac02_dkbs_dap2695
@@ -891,7 +891,7 @@ define Device/dlink_dir-825-b1
   DEVICE_VARIANT := B1
   IMAGE_SIZE := 6208k
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
        kmod-leds-reset kmod-owl-loader
   SUPPORTED_DEVICES += dir-825-b1
@@ -912,8 +912,7 @@ define Device/dlink_dir-825-c1
        pad-rootfs
   IMAGE/factory.bin := $$(IMAGE/default) | pad-offset $$$$(IMAGE_SIZE) 26 | \
        append-string 00DB120AR9344-RT-101214-00 | check-size
-  IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
-       check-size
+  IMAGE/sysupgrade.bin := $$(IMAGE/default) | check-size | append-metadata
 endef
 TARGET_DEVICES += dlink_dir-825-c1
 
@@ -930,8 +929,7 @@ define Device/dlink_dir-835-a1
        pad-rootfs
   IMAGE/factory.bin := $$(IMAGE/default) | pad-offset $$$$(IMAGE_SIZE) 26 | \
        append-string 00DB120AR9344-RT-101214-00 | check-size
-  IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
-       check-size
+  IMAGE/sysupgrade.bin := $$(IMAGE/default) | check-size | append-metadata
 endef
 TARGET_DEVICES += dlink_dir-835-a1
 
@@ -950,7 +948,7 @@ define Device/dlink_dir-842-c
   IMAGE/default := append-kernel | uImage lzma | \
        pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
   IMAGE/sysupgrade.bin := $$(IMAGE/default) | seama | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   IMAGE/factory.bin := $$(IMAGE/default) | pad-rootfs -x 64 | seama | \
        seama-seal | check-size
   IMAGE_SIZE := 15680k
@@ -1363,7 +1361,7 @@ define Device/jjplus_ja76pf2
   IMAGE/kernel.bin := append-kernel
   IMAGE/rootfs.bin := append-rootfs | pad-rootfs
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | \
-       append-metadata | check-size
+       check-size | append-metadata
   KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
   KERNEL_INITRAMFS := kernel-bin | append-dtb
   IMAGE_SIZE := 16000k
@@ -1430,7 +1428,7 @@ define Device/nec_wx1200cr
   DEVICE_VENDOR := NEC
   IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
   IMAGE/sysupgrade.bin := $$(IMAGE/default) | seama | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
 endef
 
@@ -1482,10 +1480,8 @@ define Device/netgear_ex6400_ex7300
   IMAGE_SIZE := 15552k
   IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
        netgear-rootfs | pad-rootfs
-  IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
-       check-size
-  IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | \
-       check-size
+  IMAGE/sysupgrade.bin := $$(IMAGE/default) | check-size | append-metadata
+  IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | check-size
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca99x0-ct
 endef
 
@@ -1868,7 +1864,7 @@ define Device/phicomm_k2t
   DEVICE_MODEL := K2T
   IMAGE_SIZE := 15744k
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_PACKAGES := kmod-leds-reset kmod-ath10k-ct-smallbuffers ath10k-firmware-qca9888-ct
 endef
 TARGET_DEVICES += phicomm_k2t
@@ -2230,8 +2226,7 @@ define Device/teltonika_rut955
        pad-rootfs | teltonika-fw-fake-checksum 20 | append-string master |\
        append-md5sum-bin | check-size
   IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
-       append-rootfs | pad-rootfs | append-metadata |\
-       check-size
+       append-rootfs | pad-rootfs | check-size | append-metadata
 endef
 TARGET_DEVICES += teltonika_rut955
 
@@ -2254,8 +2249,7 @@ define Device/trendnet_tew-823dru
        pad-rootfs
   IMAGE/factory.bin := $$(IMAGE/default) | pad-offset $$$$(IMAGE_SIZE) 26 | \
        append-string 00AP135AR9558-RT-131129-00 | check-size
-  IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
-       check-size
+  IMAGE/sysupgrade.bin := $$(IMAGE/default) | check-size | append-metadata
 endef
 TARGET_DEVICES += trendnet_tew-823dru
 
index caaa01c92d37e14f6355e4fdeb061bd48de1cd0b..20cb2f60fab30d775aecf116c20ca9923c7436ce 100644 (file)
@@ -166,8 +166,7 @@ define Device/netgear_ath79_nand
   IMAGES := sysupgrade.bin factory.img
   IMAGE/factory.img := append-kernel | append-ubi | netgear-dni | \
        check-size
-  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata | \
-       check-size
+  IMAGE/sysupgrade.bin := sysupgrade-tar | check-size | append-metadata
   UBINIZE_OPTS := -E 5
 endef
 
index 29e411c058da8417ac2a2bd0d2df1591276e792a..f4a03e284010787a259cee2a9233422d8a0857e9 100644 (file)
@@ -21,8 +21,7 @@ define Device/dlink_dir-615-e4
   FACTORY_IMAGE_SIZE := 3456k
   IMAGES += factory.bin
   IMAGE/default := append-kernel | append-rootfs | pad-rootfs
-  IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
-       check-size
+  IMAGE/sysupgrade.bin := $$(IMAGE/default) | check-size | append-metadata
   IMAGE/factory.bin := $$(IMAGE/default) | \
        check-size $$$$(FACTORY_IMAGE_SIZE) | pad-to $$$$(FACTORY_IMAGE_SIZE) | \
        append-string "AP99-AR7240-RT-091105-05"
index 68e565594dadfc524097f4bda735052719634f43..9dee742eb4cd83b98b1de4e694ccfce838d546d7 100644 (file)
@@ -35,7 +35,7 @@ define Device/DniImage
        IMAGES += factory.img
        IMAGE/factory.img := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | append-rootfs | pad-rootfs | netgear-dni
        IMAGE/sysupgrade.bin := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | \
-               append-rootfs | pad-rootfs | append-metadata | check-size
+               append-rootfs | pad-rootfs | check-size | append-metadata
 endef
 
 define Build/append-rootfshdr
@@ -106,7 +106,7 @@ define Device/8dev_habanero-dvk
        IMAGE_SIZE := 30976k
        SOC := qcom-ipq4019
        DEVICE_PACKAGES := ipq-wifi-8dev_habanero-dvk
-       IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | append-metadata | check-size
+       IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | check-size | append-metadata
 endef
 TARGET_DEVICES += 8dev_habanero-dvk
 
@@ -207,7 +207,7 @@ define Device/avm_fritzbox-4040
        UBOOT_PARTITION_SIZE := 524288
        IMAGES += eva.bin
        IMAGE/eva.bin := append-uboot | pad-to $$$$(UBOOT_PARTITION_SIZE) | append-kernel | append-rootfs | pad-rootfs
-       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
        DEVICE_PACKAGES := fritz-tffs fritz-caldata
 endef
 TARGET_DEVICES += avm_fritzbox-4040
@@ -822,7 +822,7 @@ define Device/zyxel_wre6606
        DEVICE_DTS_CONFIG := config@4
        SOC := qcom-ipq4018
        IMAGE_SIZE := 13184k
-       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
        DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef
 TARGET_DEVICES += zyxel_wre6606
index 7c2fa52738f77ec39cf542a2f89010ea0dfccadf..31497608bed9c7c4aaf087b8d48e09a05613fa33 100644 (file)
@@ -7,7 +7,7 @@ define Device/mikrotik_nor
        IMAGES = sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 | \
                pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \
-               append-metadata | check-size
+               check-size | append-metadata
 endef
 
 define Device/mikrotik_hap-ac2
index e53fba1e1d4396fbeba62143104b0b0ef4efac33..93e7ba315112044e95e15b1949d09ba931692ec7 100644 (file)
@@ -401,7 +401,7 @@ define Device/ubnt_unifi-ac-hd
        BLOCKSIZE := 64k
        IMAGE_SIZE := 14784k
        DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
-       IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata | check-size
+       IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size | append-metadata
 endef
 TARGET_DEVICES += ubnt_unifi-ac-hd
 
index c90975d098518bdb470d8fdf8ad1e65933e2aa75..ec10cd882a01cd7067b292f9b47294f030661c5d 100644 (file)
@@ -63,7 +63,7 @@ define Device/Default
   SOC := $(DEFAULT_SOC)
   DEVICE_DTS = $$(SOC)_$(1)
   IMAGES := sysupgrade.bin
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
 endef
 
 define Device/NAND/xway
@@ -102,7 +102,7 @@ define Device/AVM
   KERNEL := kernel-bin | append-dtb | lzma | eva-image
   KERNEL_INITRAMFS := $$(KERNEL)
   IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-avm-fakeroot | \
-       append-rootfs | pad-rootfs | append-metadata | check-size
+       append-rootfs | pad-rootfs | check-size | append-metadata
 endef
 
 ifeq ($(SUBTARGET),ase)
index ea3836ea9de46c4fc2761e3b62af00138b12beaa..a68868f0d9c5278d768ab2746741fee57de5f36d 100644 (file)
@@ -90,10 +90,10 @@ define Device/netgear_dgn3500
        factory-na.img factory.img
   IMAGE/sysupgrade-na.bin := \
        append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "NA" | \
-       pad-rootfs | append-metadata | check-size
+       pad-rootfs | check-size | append-metadata
   IMAGE/sysupgrade.bin := \
        append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "WW" | \
-       pad-rootfs | append-metadata | check-size
+       pad-rootfs | check-size | append-metadata
   IMAGE/factory-na.img := \
        pad-extra $(DGN3500_KERNEL_OFFSET_DEC) | append-kernel | append-rootfs | \
        dgn3500-sercom-footer $(DGN3500_KERNEL_OFFSET_HEX) "NA" | pad-rootfs | \
@@ -119,7 +119,7 @@ define Device/netgear_dgn3500b
   IMAGES += factory.img
   IMAGE/sysupgrade.bin := \
        append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "DE" | \
-       pad-rootfs | append-metadata | check-size
+       pad-rootfs | check-size | append-metadata
   IMAGE/factory.img := \
        pad-extra $(DGN3500_KERNEL_OFFSET_DEC) | append-kernel | append-rootfs | \
        dgn3500-sercom-footer $(DGN3500_KERNEL_OFFSET_HEX) "DE" | pad-rootfs | \
index e269aacd0243987c906d4cf7d2b4009039c09e34..756105b94c7f844439132ab57837c9ac87d231ca 100644 (file)
@@ -14,7 +14,7 @@ define Device/lantiqTpLink
        tplink-v2-header -s -V "ver. 1.0"
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := tplink-v2-image -s -V "ver. 1.0" | \
-       append-metadata | check-size
+       check-size | append-metadata
 endef
 
 define Device/tplink_tdw8970
index 5bc31314f80bc056025a4aca5628cd86df7ca3e1..d9978665687d71c704e77ce534e5e691f20adf8e 100644 (file)
@@ -253,7 +253,7 @@ define Device/netgear_dm200
   IMAGE/sysupgrade.bin := append-kernel | \
        pad-offset 64k 64 | append-uImage-fakehdr filesystem | \
        pad-offset 64k 64 | append-uImage-fakehdr filesystem | \
-       append-rootfs | pad-rootfs | append-metadata | check-size
+       append-rootfs | pad-rootfs | check-size | append-metadata
   IMAGE/factory.img := $$(IMAGE/sysupgrade.bin) | netgear-dni
   IMAGE_SIZE := 7872k
   NETGEAR_BOARD_ID := DM200
index fc5223f3a4e0d562d708682c49a46e19d2ee0a73..cd2c425cefaaa9f934c726f5660b9075967bfa75 100644 (file)
@@ -166,7 +166,7 @@ define Device/Default
   IMAGES := sysupgrade.bin
   COMPILE :=
   sysupgrade_bin := append-kernel | append-rootfs | pad-rootfs
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
 endef
 
 define Device/netgear_sercomm_nor
@@ -175,7 +175,7 @@ define Device/netgear_sercomm_nor
   IMAGES += factory.img
   IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
        pad-rootfs
-  IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size
+  IMAGE/sysupgrade.bin := $$(IMAGE/default) | check-size | append-metadata
   IMAGE/factory.img := pad-extra $$$$(SERCOMM_PAD) | $$(IMAGE/default) | \
        pad-to $$$$(BLOCKSIZE) | sercom-footer | pad-to 128 | \
        zip $$$$(SERCOMM_HWNAME).bin | sercom-seal
@@ -190,7 +190,7 @@ define Device/seama
   # - 36 bytes of META data (4-bytes aligned)
   IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
   IMAGE/sysupgrade.bin := \
-       $$(IMAGE/default) | seama | pad-rootfs | append-metadata | check-size
+       $$(IMAGE/default) | seama | pad-rootfs | check-size | append-metadata
   IMAGE/factory.bin := \
        $$(IMAGE/default) | pad-rootfs -x 64 | seama | seama-seal | check-size
   SEAMA_SIGNATURE :=
index 07ad1ea25025280b7f2e196042594b6aba1ed40f..915a086f98b4c2acc07d5e2581837402bd7a44cb 100644 (file)
@@ -11,8 +11,8 @@ define Device/tplink-v1
   KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-v1-header -e -O
   IMAGES += factory.bin
   IMAGE/factory.bin := tplink-v1-image factory -e -O
-  IMAGE/sysupgrade.bin := tplink-v1-image sysupgrade -e -O | append-metadata | \
-       check-size
+  IMAGE/sysupgrade.bin := tplink-v1-image sysupgrade -e -O | check-size | \
+       append-metadata
 endef
 
 define Device/tplink-v2
@@ -26,8 +26,8 @@ define Device/tplink-v2
   KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-v2-header -e
   IMAGES += factory.bin
   IMAGE/factory.bin := tplink-v2-image -e
-  IMAGE/sysupgrade.bin := tplink-v2-image -s -e | append-metadata | \
-       check-size
+  IMAGE/sysupgrade.bin := tplink-v2-image -s -e | check-size | \
+       append-metadata
 endef
 
 define Device/tplink-safeloader
@@ -39,6 +39,6 @@ define Device/tplink-safeloader
   KERNEL := $(KERNEL_DTB) | tplink-v1-header -e -O
   IMAGES += factory.bin
   IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
-       append-metadata | check-size
+       check-size | append-metadata
   IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
 endef
index 849bd31ef8acddbe21b9fc772e9dbdc360b03fe5..c3b9bc9f6baa26cc85b786527a6d430bdae7817f 100644 (file)
@@ -327,7 +327,7 @@ define Device/edimax_br-6478ac-v2
   IMAGE_SIZE := 7744k
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m RN68 -f 0x70000 -S 0x01100000 | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci \
        kmod-usb-ledtrig-usbport
 endef
@@ -341,7 +341,7 @@ define Device/edimax_ew-7476rpc
   IMAGE_SIZE := 7744k
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m RN79 -f 0x70000 -S 0x01100000 | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_PACKAGES := kmod-mt76x2 kmod-phy-realtek
 endef
 TARGET_DEVICES += edimax_ew-7476rpc
@@ -354,7 +354,7 @@ define Device/edimax_ew-7478ac
   IMAGE_SIZE := 7744k
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m RN70 -f 0x70000 -S 0x01100000 | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_PACKAGES := kmod-mt76x2 kmod-phy-realtek
 endef
 TARGET_DEVICES += edimax_ew-7478ac
@@ -367,7 +367,7 @@ define Device/edimax_ew-7478apc
   IMAGE_SIZE := 7744k
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m RN75 -f 0x70000 -S 0x01100000 | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci \
        kmod-usb-ledtrig-usbport
 endef
@@ -407,7 +407,7 @@ define Device/fon_fon2601
   DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci
   KERNEL_INITRAMFS := $$(KERNEL) | uimage-padhdr
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | uimage-padhdr | \
-       pad-rootfs | append-metadata | check-size
+       pad-rootfs | check-size | append-metadata
 endef
 TARGET_DEVICES += fon_fon2601
 
index cf3225dc81ec3d3f38a0febbc1f78276e1212ec8..a11fa21fb480d3490367909bacd28ba680b37608 100644 (file)
@@ -289,7 +289,7 @@ define Device/dlink_dir-8xx-a1
   KERNEL_INITRAMFS := $$(KERNEL) | uimage-padhdr 96
   IMAGES += factory.bin
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | uimage-padhdr 96 |\
-       pad-rootfs | append-metadata | check-size
+       pad-rootfs | check-size | append-metadata
   IMAGE/factory.bin := append-kernel | append-rootfs | uimage-padhdr 96 |\
        check-size
 endef
@@ -440,7 +440,7 @@ define Device/edimax_re23s
   DEVICE_ALT0_MODEL := Gemini RE23S
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m RN76 -f 0x70000 -S 0x01100000 | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   IMAGES += factory.bin
   IMAGE/factory.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m RN76 -f 0x70000 -S 0x01100000 | pad-rootfs | \
@@ -824,7 +824,7 @@ define Device/linksys_ea7xxx
        uboot-envtools
   UBINIZE_OPTS := -E 5
   IMAGES := sysupgrade.bin factory.bin
-  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata | check-size
+  IMAGE/sysupgrade.bin := sysupgrade-tar | check-size | append-metadata
   IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
        append-ubi | check-size | linksys-image type=$$$$(LINKSYS_HWNAME)
 endef
@@ -901,8 +901,8 @@ define Device/MikroTik
   KERNEL_NAME := vmlinuz
   KERNEL := kernel-bin | append-dtb-elf
   IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 | \
-       pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata | \
-       check-size
+       pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size | \
+       append-metadata
 endef
 
 define Device/mikrotik_routerboard-750gr3
index 4edc2eb3c4b7b5ade5f301467f8dbcdf569a3945..6c339dcba1885b547c2a9699c25183db49940e70 100644 (file)
@@ -500,7 +500,7 @@ define Device/edimax_3g-6200n
   IMAGE_SIZE := 3648k
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m 3G62 -f 0x50000 -S 0x01100000 | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_VENDOR := Edimax
   DEVICE_MODEL := 3g-6200n
   SUPPORTED_DEVICES += 3g-6200n
@@ -513,7 +513,7 @@ define Device/edimax_3g-6200nl
   IMAGE_SIZE := 3648k
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m 3G62 -f 0x50000 -S 0x01100000 | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_VENDOR := Edimax
   DEVICE_MODEL := 3g-6200nl
   SUPPORTED_DEVICES += 3g-6200nl
@@ -1047,7 +1047,7 @@ define Device/trendnet_tew-638apb-v2
   BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   IMAGE/sysupgrade.bin := $$(sysupgrade_bin) | umedia-header 0x026382 | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_VENDOR := TRENDnet
   DEVICE_MODEL := TEW-638APB
   DEVICE_VARIANT := v2
index 1b46d570fd945dffa41b1455c7b31c2bc0377e86..148bfbbe4458dd5e6c055bb7ab3dd3f7a6f4e123 100644 (file)
@@ -52,7 +52,7 @@ define Device/edimax_br-6475nd
   IMAGE_SIZE := 7744k
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m RN54 -f 0x70000 -S 0x01100000 | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_VENDOR := Edimax
   DEVICE_MODEL := BR-6475nD
   SUPPORTED_DEVICES += br-6475nd
index ebc0c0a784807c778c7283e6cc823b9d6de79f73..cf0d58885148fcdd7de66a46fcdbe24428c6c2e8 100644 (file)
@@ -24,7 +24,7 @@ define Device/Default
   DEVICE_DTS = $$(SOC)_$(1)
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
 endef
 
 # "NGE" refers to the uImage magic