uclient: update to Git version 2020-12-10
authorPetr Štetiar <ynezz@true.cz>
Thu, 10 Dec 2020 14:31:26 +0000 (15:31 +0100)
committerPetr Štetiar <ynezz@true.cz>
Mon, 14 Dec 2020 08:41:39 +0000 (09:41 +0100)
2c843b2bc04c Add initial GitLab CI support
073f89f567c0 uclient-fetch: wolfSSL: fix certificate validation
086c292160ac uclient-fetch: init_ca_cert: fix memory leak
a3c1a88b031a cmake: enable extra compiler checks
32ff717ed316 uclient-http: fix extra compiler warnings on mips_24kc and cortex-a9+neon
86a2ac6ac46f uclient-fetch: fix potential memory leaks
158dd9dd289c uclient: fix initialized but never read variable
66b4420856a7 uclient-fetch: fix statement may fallt hrough
436f9b3af2ad uclient-http: fix freeing of stack allocated memory
e6b5b8a98ce2 Fix extra compiler warnings
12df67e45bb0 Add basic cram based unit tests
b6e34845124f cmake: fix building out of the tree

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/libs/uclient/Makefile

index 9edb5a6ea05121c6cb240b7b7243bcd292941415..43d00a2299ce21f7e86b1b9e5f533d7aa1deea26 100644 (file)
@@ -5,9 +5,9 @@ PKG_RELEASE=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/uclient.git
-PKG_MIRROR_HASH:=05962d4edbe7b856e017d974c3d7e34dfa5f905821ab7a3534acc5886af4e5c7
-PKG_SOURCE_DATE:=2020-06-17
-PKG_SOURCE_VERSION:=c66098611f16806a936a3a3f92113a16382fc4d9
+PKG_MIRROR_HASH:=532016a283722f21dd450e388060af0db765972956eee288c7cabf102c8303d0
+PKG_SOURCE_DATE:=2020-12-10
+PKG_SOURCE_VERSION:=2c843b2bc04c34403d9a6b4de025447e4b5d8aa4
 CMAKE_INSTALL:=1
 
 PKG_BUILD_DEPENDS:=ustream-ssl
@@ -24,7 +24,7 @@ define Package/libuclient
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=HTTP/1.1 client library
-  ABI_VERSION:=20160123
+  ABI_VERSION:=20201210
   DEPENDS:=+libubox
 endef