util-linux: Disable utils requiring libpam
authorRosen Penev <rosenp@gmail.com>
Tue, 22 Oct 2019 18:55:48 +0000 (11:55 -0700)
committerJohn Crispin <john@phrozen.org>
Sun, 27 Oct 2019 13:25:30 +0000 (14:25 +0100)
When the build system finds libpam, it enables building of these tools,
causing linker failures. Explicitly disable them as they are unused.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/utils/util-linux/Makefile

index e61e501762d99992d094b1368210627195dbf2e9..29ad1350335d37de72bf356432d8544efe9a5c61 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
 PKG_VERSION:=2.34
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.34
@@ -513,8 +513,14 @@ CONFIGURE_ARGS += \
        --disable-use-tty-group         \
        --disable-rpath                 \
        --disable-tls                   \
+       --disable-su                    \
        --disable-sulogin               \
        --disable-makeinstall-chown     \
+       --disable-login                 \
+       --disable-nologin               \
+       --disable-lslogins              \
+       --disable-runuser               \
+       --disable-chfn-chsh             \
        --without-python                \
        --without-udev                  \
        --without-readline              \