mac80211: Update to version 5.7.5-1
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 28 Jun 2020 12:57:06 +0000 (14:57 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 23 Jul 2020 20:28:52 +0000 (22:28 +0200)
The b43 and b43legacy driver now support DRIVER_11W_SUPPORT.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
12 files changed:
package/kernel/mac80211/Makefile
package/kernel/mac80211/broadcom.mk
package/kernel/mac80211/patches/ath/501-ath9k_ahb_init.patch
package/kernel/mac80211/patches/ath/530-ath9k_extra_leds.patch
package/kernel/mac80211/patches/ath/543-ath9k_entropy_from_adc.patch
package/kernel/mac80211/patches/ath/922-ath10k-increase-rx-buffer-size-to-2048.patch
package/kernel/mac80211/patches/ath/930-ath10k_add_tpt_led_trigger.patch
package/kernel/mac80211/patches/ath/973-ath10k_fix-band_center_freq-handling-for-VHT160-in-recent-firmwares.patch
package/kernel/mac80211/patches/ath/974-ath10k_add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
package/kernel/mac80211/patches/ath/975-ath10k-use-tpt-trigger-by-default.patch
package/kernel/mac80211/patches/brcm/862-brcmfmac-Disable-power-management.patch
package/kernel/mac80211/patches/brcm/998-survey.patch

index 5745839d15df34d0444832708bde86cac265ecf1..cc17031a87c9401014e1a013ddbf949db54d0678 100644 (file)
@@ -10,10 +10,10 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=mac80211
 
-PKG_VERSION:=5.7-rc3-1
-PKG_RELEASE:=2
-PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.7-rc3/
-PKG_HASH:=7bc785c932f011c65adb75ffa746be2fa90b16ab61a6e1fd883acee403ffeed1
+PKG_VERSION:=5.7.5-1
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.7.5/
+PKG_HASH:=200312d46eb6a94676f611af6baebbffc5cbf3b7dd75e72a69c767704c37b571
 
 PKG_SOURCE:=backports-$(PKG_VERSION).tar.xz
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/backports-$(PKG_VERSION)
index 41320bcc125a7ec2202c1d67f0e6845e293d4a9b..4dfc4e29a7708904bc27d2bc572118a111ee6acb 100644 (file)
@@ -105,7 +105,7 @@ define KernelPackage/b43
        CONFIG_HW_RANDOM=y
   # Depend on PCI_SUPPORT to make sure we can select kmod-bcma or kmod-ssb
   DEPENDS += \
-       @PCI_SUPPORT +kmod-mac80211 +kmod-lib-cordic \
+       @PCI_SUPPORT +@DRIVER_11W_SUPPORT +kmod-mac80211 +kmod-lib-cordic \
        $(if $(CONFIG_PACKAGE_B43_USE_SSB),+kmod-ssb) \
        $(if $(CONFIG_PACKAGE_B43_USE_BCMA),+kmod-bcma)
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/b43/b43.ko
@@ -347,7 +347,7 @@ define KernelPackage/b43legacy
   URL:=https://wireless.wiki.kernel.org/en/users/drivers/b43
   KCONFIG:= \
        CONFIG_HW_RANDOM=y
-  DEPENDS+= +kmod-mac80211 +!(TARGET_bcm47xx||TARGET_bcm63xx):kmod-ssb @!TARGET_bcm47xx_mips74k +b43legacy-firmware
+  DEPENDS+= +kmod-mac80211 +!(TARGET_bcm47xx||TARGET_bcm63xx):kmod-ssb @!TARGET_bcm47xx_mips74k +b43legacy-firmware +@DRIVER_11W_SUPPORT
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/b43legacy/b43legacy.ko
   AUTOLOAD:=$(call AutoProbe,b43legacy)
   MENU:=1
index b9c784eb25e88715d9f64c49e35e9d29406f96f9..e958769fe7ca2cacf8cb03598ecdfd5e366831d1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/ath9k/init.c
 +++ b/drivers/net/wireless/ath/ath9k/init.c
-@@ -1143,25 +1143,25 @@ static int __init ath9k_init(void)
+@@ -1141,25 +1141,25 @@ static int __init ath9k_init(void)
  {
        int error;
  
index 1f194830642e987f384d4d18843c55342a2dfa03..b3dfa105ca9731aa902fa67dbcdfe265898b4a3e 100644 (file)
  
 --- a/drivers/net/wireless/ath/ath9k/init.c
 +++ b/drivers/net/wireless/ath/ath9k/init.c
-@@ -1055,7 +1055,7 @@ int ath9k_init_device(u16 devid, struct
+@@ -1053,7 +1053,7 @@ int ath9k_init_device(u16 devid, struct
  
  #ifdef CPTCFG_MAC80211_LEDS
        /* must be initialized before ieee80211_register_hw */
index 64bd6cacfd216f0061f7018f6ccce36e3001ae7b..087b0664e77d36b6726af461a748a0ae7097e046 100644 (file)
@@ -65,7 +65,7 @@
  }
  
  static const struct ieee80211_iface_limit if_limits[] = {
-@@ -1015,6 +1016,18 @@ static void ath9k_set_hw_capab(struct at
+@@ -1013,6 +1014,18 @@ static void ath9k_set_hw_capab(struct at
        wiphy_ext_feature_set(hw->wiphy, NL80211_EXT_FEATURE_AIRTIME_FAIRNESS);
  }
  
@@ -84,7 +84,7 @@
  int ath9k_init_device(u16 devid, struct ath_softc *sc,
                    const struct ath_bus_ops *bus_ops)
  {
-@@ -1060,6 +1073,8 @@ int ath9k_init_device(u16 devid, struct
+@@ -1058,6 +1071,8 @@ int ath9k_init_device(u16 devid, struct
                ARRAY_SIZE(ath9k_tpt_blink));
  #endif
  
index a8ae3204d31dc33fb4ec5bb37438ce34656c4192..37fde808db3fe87314c8bba271d62f5328d54d5e 100644 (file)
@@ -26,7 +26,7 @@ Forwarded: https://patchwork.kernel.org/patch/11367055/
 
 --- a/drivers/net/wireless/ath/ath10k/htt.h
 +++ b/drivers/net/wireless/ath/ath10k/htt.h
-@@ -2221,7 +2221,7 @@ struct htt_rx_chan_info {
+@@ -2228,7 +2228,7 @@ struct htt_rx_chan_info {
   * Should be: sizeof(struct htt_host_rx_desc) + max rx MSDU size,
   * rounded up to a cache line size.
   */
index c95d0764c3a641e4ed67940cc13d29531d5fc325..8e34a810b34a4308ae87b1eb3477a54012a10e7b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/ath10k/mac.c
 +++ b/drivers/net/wireless/ath/ath10k/mac.c
-@@ -8781,6 +8781,21 @@ static int ath10k_mac_init_rd(struct ath
+@@ -8785,6 +8785,21 @@ static int ath10k_mac_init_rd(struct ath
        return 0;
  }
  
@@ -22,7 +22,7 @@
  int ath10k_mac_register(struct ath10k *ar)
  {
        static const u32 cipher_suites[] = {
-@@ -9109,6 +9124,12 @@ int ath10k_mac_register(struct ath10k *a
+@@ -9112,6 +9127,12 @@ int ath10k_mac_register(struct ath10k *a
  
        ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
  
index bd0104592d5fc0304bc4ac8b0344ca0d59968639..4ad93ad790ac33140291ef6fa31684d823a6464b 100644 (file)
@@ -13,7 +13,7 @@ v2: fix trailing whitespace issue and fix some typos within the commit note
  2 files changed, 8 insertions(+), 10 deletions(-)
 --- a/drivers/net/wireless/ath/ath10k/mac.c
 +++ b/drivers/net/wireless/ath/ath10k/mac.c
-@@ -4585,13 +4585,6 @@ static struct ieee80211_sta_vht_cap ath1
+@@ -4588,13 +4588,6 @@ static struct ieee80211_sta_vht_cap ath1
                vht_cap.cap |= val;
        }
  
index 65899cdd60b2795ab103283c75c696d8f2c34032..d34e5c87e83af3223057f66773877399373a7064 100644 (file)
@@ -407,7 +407,7 @@ v13:
  /* Rates */
 --- a/drivers/net/wireless/ath/ath10k/wmi-ops.h
 +++ b/drivers/net/wireless/ath/ath10k/wmi-ops.h
-@@ -216,7 +216,10 @@ struct wmi_ops {
+@@ -217,7 +217,10 @@ struct wmi_ops {
        struct sk_buff *(*gen_bb_timing)
                        (struct ath10k *ar,
                         const struct wmi_bb_timing_cfg_arg *arg);
@@ -418,7 +418,7 @@ v13:
  };
  
  int ath10k_wmi_cmd_send(struct ath10k *ar, struct sk_buff *skb, u32 cmd_id);
-@@ -1080,6 +1083,35 @@ ath10k_wmi_force_fw_hang(struct ath10k *
+@@ -1090,6 +1093,35 @@ ath10k_wmi_force_fw_hang(struct ath10k *
        return ath10k_wmi_cmd_send(ar, skb, ar->wmi.cmd->force_fw_hang_cmdid);
  }
  
@@ -456,7 +456,7 @@ v13:
  {
 --- a/drivers/net/wireless/ath/ath10k/wmi-tlv.c
 +++ b/drivers/net/wireless/ath/ath10k/wmi-tlv.c
-@@ -4447,6 +4447,8 @@ static const struct wmi_ops wmi_tlv_ops
+@@ -4462,6 +4462,8 @@ static const struct wmi_ops wmi_tlv_ops
        .gen_echo = ath10k_wmi_tlv_op_gen_echo,
        .gen_vdev_spectral_conf = ath10k_wmi_tlv_op_gen_vdev_spectral_conf,
        .gen_vdev_spectral_enable = ath10k_wmi_tlv_op_gen_vdev_spectral_enable,
index f10fe85c5f7affd7a96f8e43da2800ed9ed462bb..834bbf809f8388be79a26eb1df0caf8c74ddd77c 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        if (ret)
 --- a/drivers/net/wireless/ath/ath10k/mac.c
 +++ b/drivers/net/wireless/ath/ath10k/mac.c
-@@ -9141,7 +9141,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -9144,7 +9144,7 @@ int ath10k_mac_register(struct ath10k *a
        ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
  
  #ifdef CPTCFG_MAC80211_LEDS
index 8120af32932589c20b88e21ff2d7f4ab29c27a72..f65a7903c4accfdb4725616d100cf0b26ab9e6db 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
 +++ b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
-@@ -2942,6 +2942,10 @@ brcmf_cfg80211_set_power_mgmt(struct wip
+@@ -2941,6 +2941,10 @@ brcmf_cfg80211_set_power_mgmt(struct wip
         * preference in cfg struct to apply this to
         * FW later while initializing the dongle
         */
index 6cc370571dbc21abb83be98717a6098fde829732..7f53c97470a9d69091659443bcdd1eb5ed76f36f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
 +++ b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
-@@ -2894,6 +2894,63 @@ done:
+@@ -2893,6 +2893,63 @@ done:
  }
  
  static int
@@ -64,7 +64,7 @@
  brcmf_cfg80211_dump_station(struct wiphy *wiphy, struct net_device *ndev,
                            int idx, u8 *mac, struct station_info *sinfo)
  {
-@@ -2983,6 +3040,7 @@ static s32 brcmf_inform_single_bss(struc
+@@ -2982,6 +3039,7 @@ static s32 brcmf_inform_single_bss(struc
        struct brcmu_chan ch;
        u16 channel;
        u32 freq;
@@ -72,7 +72,7 @@
        u16 notify_capability;
        u16 notify_interval;
        u8 *notify_ie;
-@@ -3007,6 +3065,17 @@ static s32 brcmf_inform_single_bss(struc
+@@ -3006,6 +3064,17 @@ static s32 brcmf_inform_single_bss(struc
                band = NL80211_BAND_5GHZ;
  
        freq = ieee80211_channel_to_frequency(channel, band);
@@ -90,7 +90,7 @@
        bss_data.chan = ieee80211_get_channel(wiphy, freq);
        bss_data.scan_width = NL80211_BSS_CHAN_WIDTH_20;
        bss_data.boottime_ns = ktime_to_ns(ktime_get_boottime());
-@@ -5424,6 +5493,7 @@ static struct cfg80211_ops brcmf_cfg8021
+@@ -5423,6 +5492,7 @@ static struct cfg80211_ops brcmf_cfg8021
        .leave_ibss = brcmf_cfg80211_leave_ibss,
        .get_station = brcmf_cfg80211_get_station,
        .dump_station = brcmf_cfg80211_dump_station,