realtek: move Netgear recipe to subtarget Makefile
authorOlliver Schinagl <oliver@schinagl.nl>
Tue, 13 Sep 2022 14:52:50 +0000 (16:52 +0200)
committerSander Vanheule <sander@svanheule.net>
Sat, 17 Sep 2022 20:27:32 +0000 (22:27 +0200)
There seems to be no reason to have the Netgear switches as part of
the main Makefile. Move it to its subtarget-specific Makefile since
it is only applicable there.

Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
[update commit message]
Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/realtek/image/Makefile
target/linux/realtek/image/rtl838x.mk

index 7d35581488b99ed6f7a9f8f426f28973379bd494..6c7be4aa90a644ccfc528e485156e8a791cf36bf 100644 (file)
@@ -90,16 +90,6 @@ define Device/Default
        check-size | append-metadata
 endef
 
-# "NGE" refers to the uImage magic
-define Device/netgear_nge
-  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
-  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
-  SOC := rtl8380
-  IMAGE_SIZE := 14848k
-  UIMAGE_MAGIC := 0x4e474520
-  DEVICE_VENDOR := NETGEAR
-endef
-
 include $(SUBTARGET).mk
 
 $(eval $(call BuildImage))
index b221ed74a24eae3aec14c0f4f79cfcffe5b7f2d9..a4f02ba352e23e0ae753d65c839c76654bb8cbab 100644 (file)
@@ -105,6 +105,16 @@ define Device/iodata_bsh-g24mb
 endef
 TARGET_DEVICES += iodata_bsh-g24mb
 
+# "NGE" refers to the uImage magic
+define Device/netgear_nge
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
+  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
+  SOC := rtl8380
+  IMAGE_SIZE := 14848k
+  UIMAGE_MAGIC := 0x4e474520
+  DEVICE_VENDOR := NETGEAR
+endef
+
 define Device/netgear_gs108t-v3
   $(Device/netgear_nge)
   DEVICE_MODEL := GS108T