kernel: bump 5.4 to 5.4.167
authorJohn Audia <graysky@archlinux.us>
Fri, 17 Dec 2021 11:48:52 +0000 (06:48 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 17 Dec 2021 14:10:22 +0000 (15:10 +0100)
All patches automatically rebased.

Build system: x86_64
Build-tested: ramips/mt7621*

*FS#4149 affects me so I had to revert 7f1edbd41295dff9f2127b169fbc086c0fb2c14e
in order to downgrade to 2.35.1

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/layerscape/patches-5.4/301-arch-0008-arm-add-new-non-shareable-ioremap.patch

index 06c790d91e1ba5d4bf8ca34471d90a7c134b0084..caae49b9d634b1043fc590e3b4940e41a4211cf7 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .166
+LINUX_VERSION-5.4 = .167
 LINUX_VERSION-5.10 = .83
 
-LINUX_KERNEL_HASH-5.4.166 = d6a5fe54495d5c1cd0d1a3d8bfa052ef6cf12a1703cb8207b8aaac69c267f6af
+LINUX_KERNEL_HASH-5.4.167 = b4e43116217ee02009aba7eab3081e64560b81ce42bc6096fcd81257f470a5a7
 LINUX_KERNEL_HASH-5.10.83 = ef259a43f33ddb56001283f4f4e50af29b8a48fa066aed7371a90ebf38c29b70
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 85a4478cd805825f6196eff0ef6d80540175e340..c09efca5704d82e587b660a2796d5caa70600a8c 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Roy Pledge <roy.pledge@nxp.com>
        MT_LOW_VECTORS,
 --- a/arch/arm/mm/ioremap.c
 +++ b/arch/arm/mm/ioremap.c
-@@ -399,6 +399,13 @@ void __iomem *ioremap_wc(resource_size_t
+@@ -401,6 +401,13 @@ void __iomem *ioremap_wc(resource_size_t
  }
  EXPORT_SYMBOL(ioremap_wc);