hostapd: fix setting wps_state to "not configured"
authorLeon M. George <leon@georgemail.eu>
Tue, 12 Jan 2021 09:30:08 +0000 (10:30 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 15 Jan 2021 17:17:45 +0000 (18:17 +0100)
With encryption disabled, it was intended to set wpa_state=1 (enabled,
not configured) through the 'wps_not_configured' flag.
The flag is set appropriately but the condition using it is broken.
Instead, 'wps_configured' is checked and wpa_state is always 2 (enabled,
configured). Fix it by using the correct variable name.

Fixes: 498d84fc4e00 ("netifd: add wireless configuration support
and port mac80211 to the new framework")

Signed-off-by: Leon M. George <leon@georgemail.eu>
[commit title/message improvements]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd.sh

index 4f740951c0bb98f94bff59e7201ded64a0ae059a..cbbe6c100921521154097099b80e13916fcd282e 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=27
+PKG_RELEASE:=28
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 815f22db74f2bccedb8c73546b01089aac110fd7..45a49b8faa51f28bb3eddf246d236ebba003108e 100644 (file)
@@ -666,7 +666,7 @@ hostapd_set_bss_options() {
                set_default wps_independent 1
 
                wps_state=2
-               [ -n "$wps_configured" ] && wps_state=1
+               [ -n "$wps_not_configured" ] && wps_state=1
 
                [ "$ext_registrar" -gt 0 -a -n "$network_bridge" ] && append bss_conf "upnp_iface=$network_bridge" "$N"