ath79: increase kernel partition for ar9344 TP-Link CPE/WBS
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 30 Aug 2020 19:26:57 +0000 (21:26 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 30 Aug 2020 20:20:37 +0000 (22:20 +0200)
The kernel has become too big again for the ar9344-based TP-Link
CPE/WBS devices which still have no firmware-partition splitter.

Current buildbots produce a kernel size of about 2469 kiB, while
the partition is only 2048 kiB (0x200000). Therefore, increase it
to 0x300000 to provide enough room for this and, hopefully, the
next kernel.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/dts/ar9344_tplink_cpe.dtsi
tools/firmware-utils/Makefile
tools/firmware-utils/src/tplink-safeloader.c

index 9a6f0ea5abfabf379460b5e1bf52bdcf6b93c41c..e8a3bdc399fbe0d594df7f3662d562196cf0886b 100644 (file)
 
                                partition@0 {
                                        label = "kernel";
-                                       reg = <0x000000 0x200000>;
+                                       reg = <0x000000 0x300000>;
                                };
 
-                               partition@200000 {
+                               partition@300000 {
                                        label = "rootfs";
-                                       reg = <0x200000 0x580000>;
+                                       reg = <0x300000 0x480000>;
                                };
                        };
 
index 4fcda7e439655ca68d5bc7b23ad38ef49b210148..39c3503886bd29f2e40411792bd0e84c9b1a6037 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME := firmware-utils
-PKG_RELEASE := 2
+PKG_RELEASE := 3
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/kernel.mk
index ec8d084299a0994b227c8a43a84c390b7144bece..501b396343c17c4576bf30b57fe9e00b7be11e1d 100644 (file)
@@ -140,8 +140,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x200000},
-                       {"file-system", 0x240000, 0x570000},
+                       {"os-image", 0x40000, 0x300000},
+                       {"file-system", 0x340000, 0x470000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -263,8 +263,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x200000},
-                       {"file-system", 0x240000, 0x570000},
+                       {"os-image", 0x40000, 0x300000},
+                       {"file-system", 0x340000, 0x470000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -342,8 +342,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x200000},
-                       {"file-system", 0x240000, 0x570000},
+                       {"os-image", 0x40000, 0x300000},
+                       {"file-system", 0x340000, 0x470000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -384,8 +384,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x200000},
-                       {"file-system", 0x240000, 0x570000},
+                       {"os-image", 0x40000, 0x300000},
+                       {"file-system", 0x340000, 0x470000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -426,8 +426,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x200000},
-                       {"file-system", 0x240000, 0x570000},
+                       {"os-image", 0x40000, 0x300000},
+                       {"file-system", 0x340000, 0x470000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -466,8 +466,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x200000},
-                       {"file-system", 0x240000, 0x570000},
+                       {"os-image", 0x40000, 0x300000},
+                       {"file-system", 0x340000, 0x470000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -506,8 +506,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x200000},
-                       {"file-system", 0x240000, 0x570000},
+                       {"os-image", 0x40000, 0x300000},
+                       {"file-system", 0x340000, 0x470000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -538,8 +538,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x200000},
-                       {"file-system", 0x240000, 0x570000},
+                       {"os-image", 0x40000, 0x300000},
+                       {"file-system", 0x340000, 0x470000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -570,8 +570,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x200000},
-                       {"file-system", 0x240000, 0x570000},
+                       {"os-image", 0x40000, 0x300000},
+                       {"file-system", 0x340000, 0x470000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -603,8 +603,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x200000},
-                       {"file-system", 0x240000, 0x570000},
+                       {"os-image", 0x40000, 0x300000},
+                       {"file-system", 0x340000, 0x470000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -636,8 +636,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x200000},
-                       {"file-system", 0x240000, 0x570000},
+                       {"os-image", 0x40000, 0x300000},
+                       {"file-system", 0x340000, 0x470000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},