hostapd: enable the epoll-based event loop
authorRui Salvaterra <rsalvaterra@gmail.com>
Mon, 2 Nov 2020 10:35:20 +0000 (10:35 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 23 Nov 2020 03:02:21 +0000 (03:02 +0000)
Hostapd supports epoll() since 2014. Let's enable it for better performance.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd-basic.config
package/network/services/hostapd/files/hostapd-full.config
package/network/services/hostapd/files/hostapd-mini.config
package/network/services/hostapd/files/wpa_supplicant-basic.config
package/network/services/hostapd/files/wpa_supplicant-full.config
package/network/services/hostapd/files/wpa_supplicant-mini.config
package/network/services/hostapd/files/wpa_supplicant-p2p.config

index e25cd20a2a0b2e72c758a3eaae236d72e7243c26..1e20b56200958806e8879100c8b5ebb65b3ecba4 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=16
+PKG_RELEASE:=17
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 19ea850f6b87f4b673fcd418ae2d65cef5fefc2d..947e2fa200526c00fce1813507157625db609d72 100644 (file)
@@ -268,7 +268,7 @@ CONFIG_GETRANDOM=y
 #CONFIG_ELOOP_POLL=y
 
 # Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
 
 # Should we use kqueue instead of select? Select is used by default.
 #CONFIG_ELOOP_KQUEUE=y
index fee4479dfa10dc04e0d55e9cdb9615076fbf3deb..df272e443a8afc22f5007732c0038cee3fe94507 100644 (file)
@@ -268,7 +268,7 @@ CONFIG_GETRANDOM=y
 #CONFIG_ELOOP_POLL=y
 
 # Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
 
 # Should we use kqueue instead of select? Select is used by default.
 #CONFIG_ELOOP_KQUEUE=y
index d9511441e64803daeb92a7a4b96c350fe7040369..b3050f7bbc70cf68ddc3b7d63dcdd63c7d27f2c3 100644 (file)
@@ -268,7 +268,7 @@ CONFIG_GETRANDOM=y
 #CONFIG_ELOOP_POLL=y
 
 # Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
 
 # Should we use kqueue instead of select? Select is used by default.
 #CONFIG_ELOOP_KQUEUE=y
index db3f7c7a11bbc51021137736fa81aaf3744bf037..c550b37b21b3f631f4d51096f26f93a321df50b0 100644 (file)
@@ -290,7 +290,7 @@ CONFIG_NO_CONFIG_WRITE=y
 #CONFIG_ELOOP_POLL=y
 
 # Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
 
 # Should we use kqueue instead of select? Select is used by default.
 #CONFIG_ELOOP_KQUEUE=y
index 4dd3e550a68dd85f81e00141abbe8c1b571e9c61..b3e85d073d5c25f7a331918b07577f5894b0a47f 100644 (file)
@@ -290,7 +290,7 @@ CONFIG_BACKEND=file
 #CONFIG_ELOOP_POLL=y
 
 # Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
 
 # Should we use kqueue instead of select? Select is used by default.
 #CONFIG_ELOOP_KQUEUE=y
index c1e0141edda684cbf0f436a356a39bfce1579811..9eb1111e523e590b7433c8ea323c451700a2f9e5 100644 (file)
@@ -290,7 +290,7 @@ CONFIG_NO_CONFIG_WRITE=y
 #CONFIG_ELOOP_POLL=y
 
 # Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
 
 # Should we use kqueue instead of select? Select is used by default.
 #CONFIG_ELOOP_KQUEUE=y
index 5156048284847db75bef156e4d346fe29df55feb..b00847a2565fa1db99db96377d5b95b10b760ce5 100644 (file)
@@ -290,7 +290,7 @@ CONFIG_BACKEND=file
 #CONFIG_ELOOP_POLL=y
 
 # Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
 
 # Should we use kqueue instead of select? Select is used by default.
 #CONFIG_ELOOP_KQUEUE=y