odhcp6c: respect 'delegate' option for 464XLAT sub-interface
authorLech Perczak <lech.perczak@gmail.com>
Tue, 10 Aug 2021 19:37:17 +0000 (21:37 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Sun, 9 Oct 2022 17:08:36 +0000 (19:08 +0200)
dhcpv6.script contained support for disabling prefix delegation of 464XLAT
sub-interface, but netifd protocol handler was missing the required
export to disable this. Add missing export, akin to DS-Lite and MAP.

Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_RELEASE increase]
package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.sh

index 82bc7191397cbc83f559bb85f631f014a2cd4264..505aa56e41677bbc06488f437d33e3b681c8415b 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_RELEASE:=18
+PKG_RELEASE:=19
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/odhcp6c.git
index cf6847f29e212ba7b46de4805406ab1a5384a952..ac8c7797fb9f164c196fa2d4ec736b3ff5a2b69a 100755 (executable)
@@ -105,6 +105,7 @@ proto_dhcpv6_setup() {
        [ -n "$iface_464xlat" ] && proto_export "IFACE_464XLAT=$iface_464xlat"
        [ "$delegate" = "0" ] && proto_export "IFACE_DSLITE_DELEGATE=0"
        [ "$delegate" = "0" ] && proto_export "IFACE_MAP_DELEGATE=0"
+       [ "$delegate" = "0" ] && proto_export "IFACE_464XLAT_DELEGATE=0"
        [ -n "$zone_dslite" ] && proto_export "ZONE_DSLITE=$zone_dslite"
        [ -n "$zone_map" ] && proto_export "ZONE_MAP=$zone_map"
        [ -n "$zone_464xlat" ] && proto_export "ZONE_464XLAT=$zone_464xlat"