mac80211: Do not build b43legacy on BRCM47xx mips74 subtarget
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 11 Jul 2019 23:12:11 +0000 (01:12 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 11 Jul 2019 23:15:50 +0000 (01:15 +0200)
b43legacy needs ssb support and we do not compile the mips74 subtarget
of the brcm47xx target with SSB support. This causes a build failure in
the mac80211 package and only some of the kernel modules are being
created.

I am not aware of any device with a BRCM47xx mips74 CPU which uses a
b43legacy compatible device.

Fixes: FS#2334
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/mac80211/broadcom.mk

index 4b05c13dba658188277adb9ef4d62342bbbf6569..eaf736e07cd294eb86b8785e7890d84f715804db 100644 (file)
@@ -347,7 +347,7 @@ define KernelPackage/b43legacy
   URL:=https://wireless.wiki.kernel.org/en/users/drivers/b43
   KCONFIG:= \
        CONFIG_HW_RANDOM=y
-  DEPENDS+= +kmod-mac80211 +!(TARGET_brcm47xx||TARGET_brcm63xx):kmod-ssb +b43legacy-firmware
+  DEPENDS+= +kmod-mac80211 +!(TARGET_brcm47xx||TARGET_brcm63xx):kmod-ssb @!TARGET_brcm47xx_mips74k +b43legacy-firmware
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/b43legacy/b43legacy.ko
   AUTOLOAD:=$(call AutoProbe,b43legacy)
   MENU:=1