kexec-tools: add kdump scripts util
authorChen Minqiang <ptpt52@gmail.com>
Sat, 30 Apr 2022 15:28:29 +0000 (23:28 +0800)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 25 Jun 2022 08:14:18 +0000 (10:14 +0200)
This add back kdump scripts to save crashlog or vmcore to disk

Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
package/boot/kexec-tools/Makefile

index 0fbbefdc3b9f3b08aa9267d6fe22132993335175..6249efe9e78befa3b18f16dcc460020395cfcaed 100644 (file)
@@ -49,6 +49,17 @@ define Package/kexec/description
  The kexec utility allows to load and boot another kernel.
 endef
 
+define Package/kdump
+  $(call Package/kexec-tools/Default)
+  TITLE:=Kernel crash analysis
+  DEPENDS:=+kexec @(i386||x86_64||arm) @KERNEL_CRASH_DUMP
+endef
+
+define Package/kdump/description
+ The kdump package allows to automatically boot into a
+ special kernel for analyzing kernel crashes using kdump.
+endef
+
 define Package/kexec/config
        source "$(SOURCE)/Config.in"
 endef
@@ -95,5 +106,28 @@ define Package/kexec/install
        $(LN) ../usr/sbin/kexec $(1)/sbin/kexec
 endef
 
+define Package/kdump/install
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config $(1)/etc/uci-defaults
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/vmcore-dmesg $(1)/usr/sbin
+       $(INSTALL_BIN) ./files/kdump.init $(1)/etc/init.d/kdump
+       $(INSTALL_BIN) ./files/kdump.defaults $(1)/etc/uci-defaults/kdump
+       $(INSTALL_CONF) ./files/kdump.config $(1)/etc/config/kdump
+endef
+
+define Package/kdump/prerm
+#!/bin/sh
+
+case $$(uname -m) in
+       i?86|x86_64)
+               if grep -q " crashkernel=" /boot/grub/grub.cfg; then
+                       mount /boot -o remount,rw
+                       sed -i 's/ crashkernel=[^ ]*//' /boot/grub/grub.cfg
+                       mount /boot -o remount,ro
+               fi
+               ;;
+esac
+endef
+
 $(eval $(call BuildPackage,kexec-tools))
 $(eval $(call BuildPackage,kexec))
+$(eval $(call BuildPackage,kdump))