ipq40xx: add support for Extreme Networks WS-AP3915i
authorDavid Bauer <mail@david-bauer.net>
Mon, 29 Aug 2022 12:30:01 +0000 (14:30 +0200)
committerDavid Bauer <mail@david-bauer.net>
Tue, 6 Sep 2022 00:55:05 +0000 (02:55 +0200)
Hardware
--------
Qualcomm IPQ4029 WiSoC
2T2R 802.11 abgn
2T2R 802.11 nac
Macronix MX25L25635E SPI-NOR (32M)
512M DDR3 RAM
1x Gigabit LAN
1x Cisco RJ-45 Console port
Settings: 115200 8N1

Installation
------------

1. Attach to the Console port. Power up the device and press the s key
   to interrupt autoboot.

2. The default username / password to the bootloader is admin / new2day

3. Update the bootcommand to allow loading OpenWrt.

   $ setenv ramboot_openwrt "setenv serverip 192.168.1.66;
     setenv ipaddr 192.168.1.1; tftpboot 0x86000000 openwrt-3915.bin;
     bootm"
   $ setenv boot_openwrt "sf probe;
     sf read 0x88000000 0x280000 0xc00000; bootm 0x88000000"
   $ setenv bootcmd "run boot_openwrt"
   $ saveenv

4. Download the OpenWrt initramfs image. Serve it using a TFTP server as
   "openwrt-3915.bin" at 192.1681.66.

5. Download & boot the OpenWrt initramfs image on the access point.

   $ run ramboot_openwrt

6. Wait for OpenWrt to start.

7. Download and transfer the sysupgrade image to the device using e.g.
   SCP.

8. Install OpenWrt to the device using "sysupgrade"

   $ sysupgrade -n /path/to/openwrt.bin

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq40xx/base-files/lib/preinit/05_set_iface_mac_ipq40xx.sh
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ws-ap3915i.dts [new file with mode: 0644]
target/linux/ipq40xx/image/generic.mk

index 5843987627b0ba1f9478e6424ccafefecd96e694..a468c62b3c5c819e4f9164bad705502230dfc851 100644 (file)
@@ -28,6 +28,7 @@ ipq40xx_setup_interfaces()
        dlink,dap-2610 |\
        engenius,eap1300|\
        engenius,emd1|\
+       extreme-networks,ws-ap3915i|\
        meraki,mr33|\
        meraki,mr74|\
        mikrotik,lhgg-60ad|\
index f1c424a28d225277bfa98b7dff22d1c937014b50..b488bf5ddb1de70921afbd1298a80471b81d41f3 100644 (file)
@@ -104,6 +104,10 @@ case "$FIRMWARE" in
                caldata_extract "ART" 0x1000 0x2f20
                ath10k_patch_mac $(macaddr_add $(mtd_get_mac_ascii u-boot-env ethaddr) 2)
                ;;
+       extreme-networks,ws-ap3915i)
+               caldata_extract "ART" 0x1000 0x2f20
+               ath10k_patch_mac $(mtd_get_mac_ascii CFG1 RADIOADDR0)
+               ;;
        linksys,ea8300 |\
        linksys,mr8300)
                caldata_extract "ART" 0x1000 0x2f20
@@ -186,6 +190,10 @@ case "$FIRMWARE" in
                caldata_extract "ART" 0x5000 0x2f20
                ath10k_patch_mac $(macaddr_add $(mtd_get_mac_ascii u-boot-env ethaddr) 3)
                ;;
+       extreme-networks,ws-ap3915i)
+               caldata_extract "ART" 0x5000 0x2f20
+               ath10k_patch_mac $(mtd_get_mac_ascii CFG1 RADIOADDR1)
+               ;;
        linksys,ea8300 |\
        linksys,mr8300)
                caldata_extract "ART" 0x5000 0x2f20
index ba1c1963980ecc0c66f262677177e95da440d851..940af0528d513f2f5c7ac1b32b922793ef441592 100644 (file)
@@ -15,6 +15,9 @@ preinit_set_mac_address() {
                base_mac=$(cat /sys/class/net/eth0/address)
                ip link set dev eth1 address $(macaddr_add "$base_mac" 1)
                ;;
+       extreme-networks,ws-ap3915i)
+               ip link set dev eth0 address $(mtd_get_mac_ascii CFG1 ethaddr)
+               ;;
        linksys,ea8300|\
        linksys,mr8300)
                base_mac=$(mtd_get_mac_ascii devinfo hw_mac_addr)
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ws-ap3915i.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ws-ap3915i.dts
new file mode 100644 (file)
index 0000000..c140235
--- /dev/null
@@ -0,0 +1,272 @@
+// SPDX-License-Identifier: GPL-2.0-only OR MIT
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "Extreme Networks WS-AP3915i";
+       compatible = "extreme-networks,ws-ap3915i";
+
+       aliases {
+               led-boot = &led_system_green;
+               led-failsafe = &led_system_amber;
+               led-running = &led_system_green;
+               led-upgrade = &led_system_amber;
+               label-mac-device = &gmac0;
+       };
+
+       soc {
+               rng@22000 {
+                       status = "okay";
+               };
+
+               mdio@90000 {
+                       status = "okay";
+                       pinctrl-0 = <&mdio_pins>;
+                       pinctrl-names = "default";
+               };
+
+               ess-psgmii@98000 {
+                       status = "okay";
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               crypto@8e3a000 {
+                       status = "okay";
+               };
+
+               watchdog@b017000 {
+                       status = "okay";
+               };
+
+               ess-switch@c000000 {
+                       status = "okay";
+                       switch_lan_bmp = <0x20>;
+                       switch_wan_bmp = <0x00>;
+               };
+
+               edma@c080000 {
+                       status = "okay";
+                       qcom,num_gmac = <1>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_system_green: system_green {
+                       label = "green:system";
+                       gpios = <&tlmm 49 GPIO_ACTIVE_LOW>;
+               };
+
+               led_system_amber: system_amber {
+                       label = "amber:system";
+                       gpios = <&tlmm 50 GPIO_ACTIVE_LOW>;
+               };
+
+               led_wlan24_green: wlan24_green {
+                       label = "green:wlan24";
+                       gpios = <&tlmm 23 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               led_wlan24_amber: wlan24_amber {
+                       label = "amber:wlan24";
+                       gpios = <&tlmm 32 GPIO_ACTIVE_LOW>;
+               };
+
+               led_wlan5_green: wlan5_green {
+                       label = "green:wlan5";
+                       gpios = <&tlmm 22 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               led_wlan5_amber: wlan5_amber {
+                       label = "amber:wlan5";
+                       gpios = <&tlmm 26 GPIO_ACTIVE_LOW>;
+               };
+
+               iot {
+                       label = "blue:iot";
+                       gpios = <&tlmm 10 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART >;
+               };
+       };
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_uart1 {
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&qpic_bam {
+       status = "okay";
+};
+
+&tlmm {
+       mdio_pins: mdio_pinmux {
+               mux_1 {
+                       pins = "gpio6";
+                       function = "mdio";
+                       bias-pull-up;
+               };
+               mux_2 {
+                       pins = "gpio7";
+                       function = "mdc";
+                       bias-pull-up;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               pin {
+                       function = "blsp_spi0";
+                       pins = "gpio13", "gpio14", "gpio15";
+                       drive-strength = <12>;
+                       bias-disable;
+               };
+               pin_cs {
+                       function = "gpio";
+                       pins = "gpio12";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+
+       serial_pins: serial_0_pinmux {
+               mux {
+                       pins = "gpio16", "gpio17";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+};
+
+&wifi0 {
+       status = "okay";
+       qcom,ath10k-calibration-variant = "Extreme-Networks-WS-AP3915i";
+};
+
+&wifi1 {
+       status = "okay";
+       qcom,ath10k-calibration-variant = "Extreme-Networks-WS-AP3915i";
+};
+
+&blsp1_spi1 {
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+       cs-gpios = <&tlmm 12 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       /* Layout for 0x0 - 0xe0000 unknown */
+
+                       partition@e0000 {
+                               label = "CFG1";
+                               reg = <0xe0000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@f0000 {
+                               label = "BootBAK";
+                               reg = <0xf0000 0x70000>;
+                               read-only;
+                       };
+
+                       partition@160000 {
+                               label = "WINGCFG1";
+                               reg = <0x160000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@170000 {
+                               label = "ART";
+                               reg = <0x170000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@180000 {
+                               label = "BootPRI";
+                               reg = <0x180000 0x70000>;
+                               read-only;
+                       };
+
+                       partition@1f0000 {
+                               label = "WINGCFG2";
+                               reg = <0x1f0000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@200000 {
+                               label = "FS";
+                               reg = <0x200000 0x80000>;
+                               read-only;
+                       };
+
+                       partition@280000 {
+                               label = "firmware";
+                               reg = <0x280000 0x1d60000>;
+                       };
+
+                       partition@1fe0000 {
+                               label = "CFG2";
+                               reg = <0x1fe0000 0x10000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&gmac0 {
+       qcom,phy_mdio_addr = <4>;
+       qcom,poll_required = <1>;
+       qcom,forced_speed = <1000>;
+       qcom,forced_duplex = <1>;
+       vlan_tag = <1 0x20>;
+};
index 6daebd5ed0f5ec0a1a3b71168f44cc3a4e2cd8fb..e8f8fa27b9402792cec02478e08d29050a86aae9 100644 (file)
@@ -519,6 +519,18 @@ define Device/engenius_ens620ext
 endef
 TARGET_DEVICES += engenius_ens620ext
 
+define Device/extreme-networks_ws-ap3915i
+       $(call Device/FitImage)
+       DEVICE_VENDOR := Extreme Networks
+       DEVICE_MODEL := WS-AP3915i
+       IMAGE_SIZE := 30080k
+       SOC := qcom-ipq4029
+       BLOCKSIZE := 128k
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
+       DEVICE_PACKAGES := ipq-wifi-extreme-networks_ws-ap3915i
+endef
+TARGET_DEVICES += extreme-networks_ws-ap3915i
+
 define Device/ezviz_cs-w3-wd1200g-eup
        $(call Device/FitImage)
        DEVICE_VENDOR := EZVIZ