mt76: drop default eeprom file for mt7986-firmware
authorChukun Pan <amadeus@jmu.edu.cn>
Thu, 4 May 2023 15:10:03 +0000 (23:10 +0800)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 28 Sep 2023 23:18:26 +0000 (00:18 +0100)
The mt76 driver usually reads the eeprom on the mtd partition at dts.
For emmc device we need to use caldata_extract script to read the
eeprom. However, the default eeprom file breaks the caldata script
execution, so remove it.

Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
package/kernel/mt76/Makefile

index 9a3597f770c5a73b5171aa7284985937a02874ad..cc8221d7ce1c924be05f59bfb52dda29e9317ef6 100644 (file)
@@ -586,8 +586,6 @@ define KernelPackage/mt7986-firmware/install
                $(PKG_BUILD_DIR)/firmware/mt7986_wm.bin \
                $(PKG_BUILD_DIR)/firmware/mt7986_rom_patch_mt7975.bin \
                $(PKG_BUILD_DIR)/firmware/mt7986_rom_patch.bin \
-               $(PKG_BUILD_DIR)/firmware/mt7986_eeprom_mt7975_dual.bin \
-               $(PKG_BUILD_DIR)/firmware/mt7986_eeprom_mt7976_dual.bin \
                $(1)/lib/firmware/mediatek
 endef