Added cutter
authorFlorian Fainelli <florian@openwrt.org>
Fri, 23 Dec 2005 12:23:15 +0000 (12:23 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 23 Dec 2005 12:23:15 +0000 (12:23 +0000)
SVN-Revision: 2750

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/cutter/Config.in [new file with mode: 0644]
openwrt/package/cutter/Makefile [new file with mode: 0755]
openwrt/package/cutter/ipkg/cutter.control [new file with mode: 0644]

index 7fe864652dd41ef2bde909a69dad984d7c43964a..775653b7173099690c8adc7f09e8c8e59bf36184 100644 (file)
@@ -53,6 +53,7 @@ source "package/bwm/Config.in"
 source "package/chillispot/Config.in"
 source "package/cifsmount/Config.in"
 source "package/cups/Config.in"
+source "package/cutter/Config.in"
 source "package/dhcp/Config.in"
 source "package/dhcp-forwarder/Config.in"
 source "package/dropbear/Config.in"
index 34dafe8867baf2ffc3d9f24f4a2c3104d270d4f8..0e53eec2caea66bfde9945e5908ef976a244fa41 100644 (file)
@@ -23,6 +23,7 @@ package-$(BR2_PACKAGE_CHILLISPOT) += chillispot
 package-$(BR2_PACKAGE_CIFSMOUNT) += cifsmount
 package-$(BR2_PACKAGE_CUPS) += cups
 package-$(BR2_COMPILE_CURL) += curl
+package-$(BR2_PACKAGE_CUTTER) += cutter
 package-$(BR2_COMPILE_CYRUS_SASL) += cyrus-sasl
 package-$(BR2_COMPILE_DB) += libdb
 package-$(BR2_PACKAGE_DECO) += deco
@@ -153,6 +154,7 @@ package-$(BR2_PACKAGE_PARPROUTED) += parprouted
 package-$(BR2_COMPILE_PCMCIA_CS) += pcmcia-cs
 package-$(BR2_COMPILE_PCRE) += pcre
 package-$(BR2_PACKAGE_PEERCAST) += peercast
+package-$(BR2_PACKAGE_PEERGUARDIAN) += peerguardian
 package-$(BR2_COMPILE_PHP4) += php4
 package-$(BR2_COMPILE_PHP5) += php5
 package-$(BR2_PACKAGE_PICOCOM) += picocom
@@ -307,6 +309,7 @@ openswan-compile: gmp-compile
 osiris-compile: openssl-compile
 palantir-compile: jpeg-compile
 peercast-compile: uclibc++-compile
+peerguardian-compile: libpthread-compile
 portmap-compile: tcp_wrappers-compile
 postgresql-compile: zlib-compile
 ppp-compile: linux-atm-compile
diff --git a/openwrt/package/cutter/Config.in b/openwrt/package/cutter/Config.in
new file mode 100644 (file)
index 0000000..4c231fd
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_CUTTER
+       prompt "cutter............................ allows an user to abort TCP/IP connections"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+               "Cutter" is an open source program that allows Linux firewall 
+               administrators to abort TCP/IP connections routed over the 
+               firewall or router on which it is run.
+
diff --git a/openwrt/package/cutter/Makefile b/openwrt/package/cutter/Makefile
new file mode 100755 (executable)
index 0000000..c9cf5d7
--- /dev/null
@@ -0,0 +1,32 @@
+# $Id: Makefile 2745 2005-12-21 09:50:28Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cutter
+PKG_VERSION:=1.03
+PKG_RELEASE:=1
+PKG_MD5SUM:=50093db9b64277643969ee75b83ebbd1
+
+PKG_SOURCE_URL:=http://www.lowth.com/cutter/software/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=gzcat
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,CUTTER,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+       
+$(PKG_BUILD_DIR)/.built:
+       $(TARGET_CC) $(PKG_BUILD_DIR)/cutter.c -o $(PKG_BUILD_DIR)/cutter
+       install -d -m0755 $(PKG_INSTALL_DIR)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/cutter $(PKG_INSTALL_DIR)/usr/sbin/
+       
+$(IPKG_CUTTER):
+       mkdir -p $(IDIR_CUTTER)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_CUTTER)/
+       $(RSTRIP) $(IDIR_CUTTER)/
+       $(IPKG_BUILD) $(IDIR_CUTTER) $(PACKAGE_DIR)
diff --git a/openwrt/package/cutter/ipkg/cutter.control b/openwrt/package/cutter/ipkg/cutter.control
new file mode 100644 (file)
index 0000000..6c91692
--- /dev/null
@@ -0,0 +1,5 @@
+Package: cutter
+Architecture: mipsel
+Section: net
+Description: "Cutter" is an open source program that allows Linux firewall administrators to abort TCP/IP connections routed over the firewall or router on which it is run.
+Priority: optional