mediatek: expand kernel size to 6MiB for WSR-2533DHP2
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Sun, 27 Aug 2023 09:37:15 +0000 (18:37 +0900)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 24 Sep 2023 16:42:11 +0000 (18:42 +0200)
Expand kernel partition size on WSR-2533DHP2 for the kernel larger than
4 MiB.
To prevent upgrading from old firmware before this commit, bump the
compat version to 1.1 and add a message for forced sysupgrade using
factory-uboot.bin image.

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
target/linux/mediatek/image/mt7622.mk
target/linux/mediatek/mt7622/base-files/etc/uci-defaults/05_fix-compat-version

index cf9534e2a54fd6a16b9c15dadccc08a2eee44ae5..6f64740628cf6ffe3034af0d6cffb539e08b955b 100644 (file)
@@ -101,7 +101,7 @@ define Device/buffalo_wsr-2533dhp2
   DEVICE_DTS := mt7622-buffalo-wsr-2533dhp2
   DEVICE_DTS_DIR := ../dts
   IMAGE_SIZE := 59392k
-  KERNEL_SIZE := 4096k
+  KERNEL_SIZE := 6144k
   BLOCKSIZE := 128k
   PAGESIZE := 2048
   SUBPAGESIZE := 512
@@ -123,6 +123,10 @@ define Device/buffalo_wsr-2533dhp2
        buffalo-trx 0x32504844 $(KDIR)/tmp/$$(DEVICE_NAME).null | \
        sysupgrade-tar kernel=$$$$@ | append-metadata
   DEVICE_PACKAGES := kmod-mt7615-firmware swconfig
+  DEVICE_COMPAT_VERSION := 1.1
+  DEVICE_COMPAT_MESSAGE := Partition table has been changed due to kernel size restrictions. \
+       Please upgrade via sysupgrade with factory-uboot.bin image and '-F' option. \
+       (Warning: your configurations will be erased!)
 endef
 TARGET_DEVICES += buffalo_wsr-2533dhp2
 
index c77e1cb8bd19278d6d0df89b9601b28be4fb57be..83310378694da78c04942d8d642684e3c5ee4110 100644 (file)
@@ -1,7 +1,8 @@
 . /lib/functions.sh
 
 case "$(board_name)" in
-       bananapi,bpi-r64)
+       bananapi,bpi-r64|\
+       buffalo,wsr-2533dhp2)
        uci set system.@system[0].compat_version="1.1"
        uci commit system
        ;;