ath79: move the squashfs feature to the parent target
authorRui Salvaterra <rsalvaterra@gmail.com>
Mon, 23 Nov 2020 00:28:34 +0000 (00:28 +0000)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 23 Nov 2020 12:20:53 +0000 (13:20 +0100)
All subtargets define it. Move it to the parent target and remove
it from all subtargets.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
target/linux/ath79/Makefile
target/linux/ath79/generic/target.mk
target/linux/ath79/mikrotik/target.mk
target/linux/ath79/nand/target.mk
target/linux/ath79/tiny/target.mk

index e074cde8cedf3d44a12fb4891c6bc72845667acb..2a9857bfb182d4276c4ec0500593d28da308b5d7 100644 (file)
@@ -6,7 +6,7 @@ BOARDNAME:=Atheros ATH79
 CPU_TYPE:=24kc
 SUBTARGETS:=generic mikrotik nand tiny
 
-FEATURES:=ramdisk usbgadget
+FEATURES:=ramdisk squashfs usbgadget
 
 KERNEL_PATCHVER:=5.4
 KERNEL_TESTING_PATCHVER:=5.4
index 0624f795726aa9c7abe677baceca2ae4ba1b83ff..4e53c8926053dc1ef9bc3ac6ac56b82d927ae16e 100644 (file)
@@ -1,5 +1,4 @@
 BOARDNAME:=Generic
-FEATURES += squashfs
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl
 
index fb5171fea7936e4f13e370d35112e8578d3b6e97..f5df904487506034e82259738045c2916badbe87 100644 (file)
@@ -1,5 +1,5 @@
 BOARDNAME := MikroTik devices
-FEATURES += minor nand squashfs
+FEATURES += minor nand
 KERNELNAME := vmlinux vmlinuz
 IMAGES_DIR := ../../..
 
index a4069d7610becdb1b3c768d6fe95a518c9439e9e..7ea9b57f45d5fb991a8f76b2236213af25d297e5 100644 (file)
@@ -1,6 +1,6 @@
 BOARDNAME := Generic devices with NAND flash
 
-FEATURES += squashfs nand
+FEATURES += nand
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl
 
index 2ee71ea92137f7d730b63149131489f41722a76c..91f135b56eda4534edfbf68414933cb42a75d1e2 100644 (file)
@@ -1,5 +1,5 @@
 BOARDNAME:=Devices with small flash
-FEATURES += squashfs small_flash
+FEATURES += small_flash
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl