ramips: improve compatibility for Youku YK-L2 and YK-L1 series
authorShiji Yang <yangshiji66@qq.com>
Sat, 5 Nov 2022 11:52:08 +0000 (19:52 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 5 Nov 2022 20:12:24 +0000 (21:12 +0100)
Add UIMAGE_NAME and UIMAGE_MAGIC to allow users to directly install
initramfs-kernel.bin from the stock firmware Web UI. At the same time,
this change makes it possible to boot OpenWrt with the official u-boot.

Notice:
Since the stock firmware is based on OpenWrt and the configuration
will be retained by default during the upgrade process, so we must use
initramfs-kernel.bin to do a initial installation. After the system
restarts, install sysupgrade.bin and do not retain any configuration.

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
target/linux/ramips/dts/mt7620a_youku_yk-l1.dtsi
target/linux/ramips/dts/mt7621_youku_yk-l2.dts
target/linux/ramips/image/mt7620.mk
target/linux/ramips/image/mt7621.mk

index d15d2c0f4b66ec25d32cbd923f01d98b4be88473..210b0d7d1957505b40ba46c98344f4e9df2d0956 100644 (file)
@@ -86,8 +86,9 @@
                        };
 
                        firmware: partition@50000 {
-                               compatible = "denx,uimage";
+                               compatible = "openwrt,uimage", "denx,uimage";
                                label = "firmware";
+                               openwrt,ih-magic = <0x12291000>;
                                /* reg property is set based on flash size in DTS files */
                        };
                };
index e588e047eb52ddb54d350e706c861e74e09ed7e9..5342b40507af3f40516724741752ee360edabf5b 100644 (file)
@@ -95,8 +95,9 @@
                        };
 
                        partition@50000 {
-                               compatible = "denx,uimage";
+                               compatible = "openwrt,uimage", "denx,uimage";
                                label = "firmware";
+                               openwrt,ih-magic = <0x12291000>;
                                reg = <0x50000 0xfb0000>;
                        };
                };
index f6ad162779cd00c0c7e2ffda15c5b5220d5be1c8..db6ac93b2a25895bdf1add40f0ad5dc28a6ec081 100644 (file)
@@ -1281,6 +1281,8 @@ define Device/youku_yk-l1
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 \
        kmod-usb-ledtrig-usbport
   SUPPORTED_DEVICES += youku-yk1 youku,yk1
+  UIMAGE_MAGIC := 0x12291000
+  UIMAGE_NAME := 400000000000000000000000
 endef
 TARGET_DEVICES += youku_yk-l1
 
@@ -1291,6 +1293,8 @@ define Device/youku_yk-l1c
   DEVICE_MODEL := YK-L1c
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 \
        kmod-usb-ledtrig-usbport
+  UIMAGE_MAGIC := 0x12291000
+  UIMAGE_NAME := 400000000000000000000000
 endef
 TARGET_DEVICES += youku_yk-l1c
 
index 3ef4cf4efb8f37043123667dce288a45dbe09cf4..360513115f35eb33f46bbdecd9e9cd9d46a66c6e 100644 (file)
@@ -2251,6 +2251,8 @@ define Device/youku_yk-l2
   DEVICE_MODEL := YK-L2
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 \
        kmod-usb-ledtrig-usbport
+  UIMAGE_MAGIC := 0x12291000
+  UIMAGE_NAME := 400000000000000000003000
 endef
 TARGET_DEVICES += youku_yk-l2