nu801: add kmod-leds-uleds to MR26 + MR18
authorChristian Lamparter <chunkeey@gmail.com>
Wed, 17 May 2023 20:33:36 +0000 (22:33 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Thu, 18 May 2023 14:17:52 +0000 (16:17 +0200)
support for MR18 and MR26 was developped before
the userspace nu801 was integrated with x86's
MX100 into OpenWrt. The initial nu801 + kmod-leds-uleds
caused build-bot errors.

The solution that worked for the MX100 was to include
the kmod-leds-uleds to the device platform module.
Thankfully, the MR26 and MR18 can just add the uleds
package to the DEVICE_PACKAGES variable.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ath79/image/nand.mk
target/linux/bcm53xx/image/Makefile

index 4f34521a5050d569d520167dc540cd3449dc7434..d1bd4feb1fe784202f35d9ee8214d051b4bd8e8d 100644 (file)
@@ -272,7 +272,7 @@ define Device/meraki_mr18
   SOC := qca9557
   DEVICE_VENDOR := Meraki
   DEVICE_MODEL := MR18
-  DEVICE_PACKAGES := kmod-spi-gpio nu801
+  DEVICE_PACKAGES := kmod-leds-uleds kmod-spi-gpio nu801
   KERNEL_SIZE := 8m
   BLOCKSIZE := 128k
   PAGESIZE := 2048
index 1cb08effce25b588697a77fb52569362bbde5e79..defa68e59f981dc66b5d016bd5f3f6aae26aa087 100644 (file)
@@ -351,7 +351,7 @@ define Device/meraki_mr26
   DEVICE_VENDOR := Meraki
   DEVICE_MODEL := MR26
   DEVICE_PACKAGES := $(B43) kmod-i2c-bcm-iproc kmod-eeprom-at24 \
-       kmod-hwmon-ina2xx nu801
+       kmod-hwmon-ina2xx kmod-leds-uleds nu801
   DEVICE_DTS := bcm53015-meraki-mr26
 # resize the initramfs to fit the size of the existing part.safe.
   KERNEL_LOADADDR := 0x00008000