odhcpd: number UCI defaults script
authorStijn Segers <foss@volatilesystems.org>
Sun, 20 Sep 2020 21:03:32 +0000 (23:03 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Mon, 21 Sep 2020 18:59:40 +0000 (20:59 +0200)
UCI defaults scripts are supposed to be numbered, but odhcpd's lacked numbering, which
turned out to mess up my custom scripts numbered 9[0-9]_*. The idea is to have high number
(custom) scripts executed last. Jow confirmed numbering is the default case, not the
exception (thanks).

Signed-off-by: Stijn Segers <foss@volatilesystems.org>
package/network/services/odhcpd/Makefile

index d3e131caec13e07c7e9054764533e9d13869958d..62dd53774d6a958be57cbdf4180f67544ce5e6ff 100644 (file)
@@ -100,7 +100,7 @@ define Package/odhcpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/odhcpd.init $(1)/etc/init.d/odhcpd
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_BIN) ./files/odhcpd.defaults $(1)/etc/uci-defaults
+       $(INSTALL_BIN) ./files/odhcpd.defaults $(1)/etc/uci-defaults/15_odhcpd
 endef
 
 Package/odhcpd-ipv6only/install = $(Package/odhcpd/install)