hostapd: wpa_supplicant: Enable proper GCMP cipher support
authorRobert Marko <robimarko@gmail.com>
Sun, 17 Mar 2019 20:01:17 +0000 (21:01 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 5 Jan 2021 02:16:24 +0000 (02:16 +0000)
This patch enables hostapd.sh to properly configure wpa_supplicant
for when GCMP is used as cipher in station mode.
Without this wpa_supplicant will be unable to connect to AP.
This is needed for wil6210 as it does not support CCMP.

Signed-off-by: Robert Marko <robimarko@gmail.com>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd.sh

index f746f5455a3a9cd68e8cf83658d4abd6f8fe887b..8e9605fe68d8058714439fe827eb1dc31907e216 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=21
+PKG_RELEASE:=22
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 80e1f7cedf5eeac07e8b6c0e4b917eabbeeaf717..0f6741336b90c2dfa52c2525499ea16fe50f243f 100644 (file)
@@ -1312,6 +1312,11 @@ wpa_supplicant_add_network() {
                ;;
        esac
 
+       [ "$wpa_cipher" = GCMP ] && {
+               append network_data "pairwise=GCMP" "$N$T"
+               append network_data "group=GCMP" "$N$T"
+       }
+
        [ "$mode" = mesh ] || {
                case "$wpa" in
                        1)